This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 676821 - Couldn't resolve host name when installing packages over NFS
Couldn't resolve host name when installing packages over NFS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 677218 680490 (view as bug list)
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-11 07:08 EST by He Rui
Modified: 2011-04-05 17:39 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-15.26-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 17:39:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (9.70 KB, text/plain)
2011-02-11 07:08 EST, He Rui
no flags Details
error window (142.29 KB, image/png)
2011-02-11 07:09 EST, He Rui
no flags Details
program.log (47.07 KB, text/plain)
2011-02-11 22:29 EST, He Rui
no flags Details

  None (edit)
Description He Rui 2011-02-11 07:08:18 EST
Created attachment 478228 [details]
anaconda.log

Description of problem:
Install F15-alpha-tc1 by mounting the DVD to a NFS server. It failed when setting up repository(pic attached). Error in Anaconda.log showed 'couldn't resolve host name'(attached) 

Version-Release number of selected component (if applicable):
anaconda 15.19

How reproducible:


Steps to Reproduce:
1. Boot F15-alpha-tc1.i386.DVD
2. Test: https://fedoraproject.org/wiki/QA:Testcase_Nfs_Repository
Comment 1 He Rui 2011-02-11 07:09:50 EST
Created attachment 478230 [details]
error window
Comment 2 Chris Lumens 2011-02-11 09:56:27 EST
Can you also attach /tmp/program.log?  That should have the output of all the mount commands.
Comment 3 James Laska 2011-02-11 11:27:35 EST
Adding to F15Beta per the beta release criteria [1]:

    "The installer must be able to use the HTTP, FTP and NFS 
     remote package source options"

[1] https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria
Comment 4 He Rui 2011-02-11 22:29:31 EST
Created attachment 478344 [details]
program.log
Comment 5 Chris Lumens 2011-02-15 11:40:29 EST
Does updates=http://clumens.fedorapeople.org/676821.img fix this problem?  For my future reference, the patch is:

diff --git a/pyanaconda/yuminstall.py b/pyanaconda/yuminstall.py
index 6621b70..d15c6d5 100644
--- a/pyanaconda/yuminstall.py
+++ b/pyanaconda/yuminstall.py
@@ -479,7 +479,7 @@ class AnacondaYum(yum.YumBase):
                 # if there's images and if so go with this being an NFSISO
                 # install instead.
                 image = findFirstIsoImage(self.tree, self.anaconda.intf.messageWindow)
-                if not image:
+                if image:
                     isys.umount(self.tree, removeDir=False)
                     self.anaconda.methodstr = "nfsiso:%s" % m[4:]
                     self.configBaseURL()
Comment 6 James Laska 2011-02-15 14:36:39 EST
(In reply to comment #5)
> Does updates=http://clumens.fedorapeople.org/676821.img fix this problem?  For
> my future reference, the patch is:

This seems to resolve the issue for me
Comment 7 Chris Lumens 2011-02-15 15:03:29 EST
This will be fixed in the next build of anaconda post-F15 alpha.
Comment 8 Hongqing Yang 2011-02-16 03:37:48 EST
*** Bug 677218 has been marked as a duplicate of this bug. ***
Comment 9 Hongqing Yang 2011-02-16 03:41:13 EST
reproduced in f15 alpha tc2
Comment 10 He Rui 2011-02-22 01:37:35 EST
*** Bug 677218 has been marked as a duplicate of this bug. ***
Comment 11 James Laska 2011-03-11 14:41:44 EST
Discussed at 2011-03-11 blocker review meeting.  This issue is fixed and available for testing in anaconda-15.21-1.  The issue has been accepted as a beta blocker.
Comment 12 Chris Lumens 2011-03-16 14:31:57 EDT
*** Bug 680490 has been marked as a duplicate of this bug. ***
Comment 13 Michael Young 2011-03-18 11:02:36 EDT
Adding the contents of the .img file in comment #5 to my updates.img file fixes the problem I was seeing in Bug 680490 .
Comment 14 Tim Flink 2011-03-25 13:13:27 EDT
Discussed in 2011-03-25 blocker review meeting. Still waiting for more testing before marking it as resolved.
Comment 16 Fedora Update System 2011-03-29 16:59:21 EDT
anaconda-15.26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
Comment 17 Fedora Update System 2011-03-29 22:26:14 EDT
Package anaconda-15.26-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.26-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
then log in and leave karma (feedback).
Comment 18 He Rui 2011-03-30 01:40:00 EDT
Verified anaconda-15.25 of beta-tc1 fixes the problem
Comment 19 James Laska 2011-03-30 11:05:17 EDT
(In reply to comment #18)
> Verified anaconda-15.25 of beta-tc1 fixes the problem

Thanks for the feedback Hurry ... I'm moving this to VERIFIED.
Comment 20 Fedora Update System 2011-04-05 17:38:09 EDT
anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.