Bug 67723 - X will start only once per boot on i810
X will start only once per boot on i810
Status: CLOSED DUPLICATE of bug 67978
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 00:00 EDT by Alexandre Oliva
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-10 05:36:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 log of a working session (25.12 KB, text/plain)
2002-07-01 00:02 EDT, Alexandre Oliva
no flags Details
XFree86 log of the following X failure to start (14.98 KB, text/plain)
2002-07-01 00:03 EDT, Alexandre Oliva
no flags Details
kernel oops that happens when a users attempts to logout (2.21 KB, text/plain)
2002-07-01 15:01 EDT, Elliot Peele
no flags Details

  None (edit)
Description Alexandre Oliva 2002-07-01 00:00:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020610

Description of problem:
After installing Red Hat Linux 7.3 from scratch on a i686 on a MB with the i810
video controller, XFree86 would start just fine.  After logging in and then
logging out, X would no longer start.

Further investigation revealed that VT#7 appears to be still busy by the time X
attempts to restart.  Even if I switch to init level 3 and leave it like that
for a while, modules i810 and agpgart are still busy and cannot be unloaded,
which seems to indicate something is still holding to them.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Red Hat Linux 7.3 with the following X settings:
xconfig --card "Intel 810" --videoram 16384 --hsync 30-66 --vsync 50-130
--resolution 1152x864 --depth 16 --startxonboot 

2.Install all available errata:
XFree86-4.2.0-8
kernel-2.4.18-5

3.Boot
4.X starts up correctly
5.init 3; sleep 60; init 5


Actual Results:  X won't start any longer, and a reconfiguration will be
suggested, until the next reboot.

Expected Results:  It used to work just fine on Red Hat Linux 7.2.

Additional info:

I'm attaching the XFree86 logs of the successful and the unsuccessful sessions.
Comment 1 Alexandre Oliva 2002-07-01 00:02:59 EDT
Created attachment 63204 [details]
XFree86 log of a working session
Comment 2 Alexandre Oliva 2002-07-01 00:03:49 EDT
Created attachment 63205 [details]
XFree86 log of the following X failure to start
Comment 3 Elliot Peele 2002-07-01 15:01:06 EDT
Created attachment 63284 [details]
kernel oops that happens when a users attempts to logout
Comment 4 Elliot Peele 2002-07-01 15:02:24 EDT
I am having the same problem. When users logout X fails to restart it self. It
looks like the driver is causing a kernel oops. I have attached a copy of the
oops from the syslog.
Comment 5 Alexandre Oliva 2002-07-01 15:28:46 EDT
FWIW, I've switched to the following configuration to work around the problem:
[...]
        # Screen      0  "Screen0" 0 0
        Screen      0  "Screen1" 0 0
[...]
Section "Device"
        # no known options
        Identifier   "Vesa"
        Driver       "vesa"
        VendorName   "VESA driver (generic)"
        BoardName     "VESA driver (generic)"

        #BusID
EndSection

Section "Screen"
        Identifier   "Screen1"
        Device       "Vesa"
        Monitor      "Monitor0"
        DefaultDepth    16

        Subsection "Display"
                Depth       16
                Modes       "1152x864" "1024x768" "800x600" "640x480"
        EndSubsection

EndSection

Comment 6 Elliot Peele 2002-07-01 16:22:38 EDT
The only problem that I have found with this fix is that i'm limited to a
resolution of 800x600
Comment 7 Alexandre Oliva 2002-07-02 16:52:11 EDT
FWIW, I get the same kernel oops, I just had missed it because I was looking for
something in /var/log/messages at about the time X restarted.  D'oh.

Anyway, this was the hint I needed to figure the problem probably had to do with
dri.  In fact, commenting out the `Load "dri"' fixed it for now.
Comment 8 Mike A. Harris 2002-07-09 22:33:10 EDT
Arjan, is this the problem which was just fixed in i8x0 DRM?

If so, please let me know, as I think I can close this then, and dupe
many other bug reports against it.

TIA
Comment 9 Arjan van de Ven 2002-07-10 05:36:55 EDT
yup the kernel oops is the bug fixed...
Comment 10 Mike A. Harris 2002-07-10 08:59:38 EDT

*** This bug has been marked as a duplicate of 67978 ***

Note You need to log in before you can comment on or make changes to this bug.