Bug 677368 - [abrt] mutter-2.91.6-2.fc15: src_register: Process /usr/bin/mutter was killed by signal 11 (SIGSEGV)
Summary: [abrt] mutter-2.91.6-2.fc15: src_register: Process /usr/bin/mutter was killed...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: rawhide
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7a221872f662a78d4952637bb84...
Depends On:
Blocks: F15GNOMEfail
TreeView+ depends on / blocked
 
Reported: 2011-02-14 14:13 UTC by Jóhann B. Guðmundsson
Modified: 2018-04-11 14:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-18 14:29:29 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (44.52 KB, text/plain)
2011-02-14 14:13 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2011-02-14 14:13:09 UTC
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 45586 bytes
cmdline: mutter --mutter-plugins=libgnome-shell
component: mutter
Attached file: coredump, 79351808 bytes
crash_function: src_register
executable: /usr/bin/mutter
kernel: 2.6.38-0.rc4.git0.1.fc15.i686
package: mutter-2.91.6-2.fc15
rating: 4
reason: Process /usr/bin/mutter was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1297338774
uid: 500

How to reproduce
-----
1. 
2. 
3.

Comment 1 Jóhann B. Guðmundsson 2011-02-14 14:13:13 UTC
Created attachment 478631 [details]
File: backtrace

Comment 2 Peter Robinson 2011-02-14 14:28:15 UTC
This looks like a crash in the ATI mesa 3D driver

Comment 3 Jóhann B. Guðmundsson 2011-02-14 22:22:39 UTC
Indeed.. 

I do believe this is the underlying cause for my mutter crashes... 

Feb 14 19:05:22 localhost kernel: [  244.755020] mutter[2761]: segfault 
at bf8f7750 ip 04c3f32e sp bf8f2dc0 error 4 in r300_dri.so[4a90000+386000]

01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility 
Radeon X300]

Comment 4 Mike C 2011-02-26 17:07:25 UTC
This seems to be fixed in alpha tc2 - if so this bug can be closed?

Comment 5 Jóhann B. Guðmundsson 2011-02-28 12:47:47 UTC
Was not fixed for me in TC2 confirmed fixed in RC2 alpha

Comment 6 Mike C 2011-02-28 14:50:34 UTC
Argh - yes - my bad - it was a typo!  I should have written RC2 and not tc2 in #4 - apologies.

Comment 7 Matthias Runge 2011-03-02 15:58:22 UTC
Sorry for (probably) capturing this bug:

I tried 
mutter --replace 
on a system equipped with such a card. System immediately freezes. No logs found.

Smolt profile: http://www.smolts.org/client/show/pub_e6aeaf20-165f-43af-a633-5f14d3c95782

Should I file another bug, is it the same?

Comment 8 Matěj Cepl 2011-03-18 16:06:25 UTC
(In reply to comment #7)
> Should I file another bug, is it the same?

Yes, please. Please provide a backtrace of your crash, together with /var/log/Xorg.0.log, /var/log/messages, and the output of dmesg AFTER the crash happens (but before reboot obviously).

Thank you

Comment 9 Matthias Runge 2011-03-21 07:40:51 UTC
My crash has been solved lately with the release of kernel-2.6.38-1
cf. 
https://bugzilla.redhat.com/show_bug.cgi?id=683994

I guess, the original problem is solved also.

Comment 10 Adam Jackson 2011-08-18 14:29:29 UTC
Should be working in current Mesa.


Note You need to log in before you can comment on or make changes to this bug.