Bug 677368 - [abrt] mutter-2.91.6-2.fc15: src_register: Process /usr/bin/mutter was killed by signal 11 (SIGSEGV)
[abrt] mutter-2.91.6-2.fc15: src_register: Process /usr/bin/mutter was killed...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:7a221872f662a78d4952637bb84...
:
Depends On:
Blocks: F15GNOMEfail
  Show dependency treegraph
 
Reported: 2011-02-14 09:13 EST by Jóhann B. Guðmundsson
Modified: 2011-08-18 10:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-18 10:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (44.52 KB, text/plain)
2011-02-14 09:13 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-02-14 09:13:09 EST
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 45586 bytes
cmdline: mutter --mutter-plugins=libgnome-shell
component: mutter
Attached file: coredump, 79351808 bytes
crash_function: src_register
executable: /usr/bin/mutter
kernel: 2.6.38-0.rc4.git0.1.fc15.i686
package: mutter-2.91.6-2.fc15
rating: 4
reason: Process /usr/bin/mutter was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1297338774
uid: 500

How to reproduce
-----
1. 
2. 
3.
Comment 1 Jóhann B. Guðmundsson 2011-02-14 09:13:13 EST
Created attachment 478631 [details]
File: backtrace
Comment 2 Peter Robinson 2011-02-14 09:28:15 EST
This looks like a crash in the ATI mesa 3D driver
Comment 3 Jóhann B. Guðmundsson 2011-02-14 17:22:39 EST
Indeed.. 

I do believe this is the underlying cause for my mutter crashes... 

Feb 14 19:05:22 localhost kernel: [  244.755020] mutter[2761]: segfault 
at bf8f7750 ip 04c3f32e sp bf8f2dc0 error 4 in r300_dri.so[4a90000+386000]

01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility 
Radeon X300]
Comment 4 Mike C 2011-02-26 12:07:25 EST
This seems to be fixed in alpha tc2 - if so this bug can be closed?
Comment 5 Jóhann B. Guðmundsson 2011-02-28 07:47:47 EST
Was not fixed for me in TC2 confirmed fixed in RC2 alpha
Comment 6 Mike C 2011-02-28 09:50:34 EST
Argh - yes - my bad - it was a typo!  I should have written RC2 and not tc2 in #4 - apologies.
Comment 7 Matthias Runge 2011-03-02 10:58:22 EST
Sorry for (probably) capturing this bug:

I tried 
mutter --replace 
on a system equipped with such a card. System immediately freezes. No logs found.

Smolt profile: http://www.smolts.org/client/show/pub_e6aeaf20-165f-43af-a633-5f14d3c95782

Should I file another bug, is it the same?
Comment 8 Matěj Cepl 2011-03-18 12:06:25 EDT
(In reply to comment #7)
> Should I file another bug, is it the same?

Yes, please. Please provide a backtrace of your crash, together with /var/log/Xorg.0.log, /var/log/messages, and the output of dmesg AFTER the crash happens (but before reboot obviously).

Thank you
Comment 9 Matthias Runge 2011-03-21 03:40:51 EDT
My crash has been solved lately with the release of kernel-2.6.38-1
cf. 
https://bugzilla.redhat.com/show_bug.cgi?id=683994

I guess, the original problem is solved also.
Comment 10 Adam Jackson 2011-08-18 10:29:29 EDT
Should be working in current Mesa.

Note You need to log in before you can comment on or make changes to this bug.