This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 677371 - [abrt] mutter-2.91.6-3.fc15: ureg_src_undef: Process /usr/bin/mutter was killed by signal 11 (SIGSEGV)
[abrt] mutter-2.91.6-3.fc15: ureg_src_undef: Process /usr/bin/mutter was kill...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:957bb3e8761802e252d4081dd73...
:
: 677567 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-14 09:27 EST by Jóhann B. Guðmundsson
Modified: 2011-02-28 10:24 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-28 10:24:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (45.97 KB, text/plain)
2011-02-14 09:27 EST, Jóhann B. Guðmundsson
no flags Details
Good old fasion hands on debugging.. (30.64 KB, text/plain)
2011-02-22 12:17 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-02-14 09:27:00 EST
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 47074 bytes
cmdline: mutter --mutter-plugins=libgnome-shell
component: mutter
Attached file: coredump, 87724032 bytes
crash_function: ureg_src_undef
executable: /usr/bin/mutter
kernel: 2.6.38-0.rc4.git0.2.fc15.i686
package: mutter-2.91.6-3.fc15
rating: 4
reason: Process /usr/bin/mutter was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1297691632
uid: 500

How to reproduce
-----
1. Login as a regular user 
2. 
3.
Comment 1 Jóhann B. Guðmundsson 2011-02-14 09:27:03 EST
Created attachment 478638 [details]
File: backtrace
Comment 2 Peter Robinson 2011-02-15 05:38:21 EST
*** Bug 677567 has been marked as a duplicate of this bug. ***
Comment 3 Peter Robinson 2011-02-15 05:41:00 EST
Looks like an issue with ATI 3D driver in mesa
Comment 4 Jóhann B. Guðmundsson 2011-02-18 09:50:30 EST
For some reason I thought I had commented this info here perhaps it was another bug but I do believe you are right.. 

Feb 14 19:05:22 localhost kernel: [  244.755020] mutter[2761]: segfault at bf8f7750 ip 04c3f32e sp bf8f2dc0 error 4 in r300_dri.so[4a90000+386000]
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
Comment 5 Clyde E. Kunkel 2011-02-18 16:09:19 EST
saw one instance with F15TC1, but none since.  Now updated thru TC2.
RV600 card and ATI driver
Comment 6 Gianluca Sforna 2011-02-18 19:34:47 EST
Same error here on 20110217 liveCD. this is an ATI Mobility Radeon 9600 M10 (RV350)
Comment 7 Mike C 2011-02-21 11:43:39 EST
Does anyone know if there was a previous iso that did work properly?  eg if the graphics test day iso worked but one of the nightly isos failed - then looking at what changed between the two might just give a clue? (This happened for my test machine - was working pretty well for gnome3 at the test day but went into this bad crash for one of the nightly isos (and tc1/2).
Comment 8 Jóhann B. Guðmundsson 2011-02-21 11:59:57 EST
Looks like any post r600 are affected by this according to David's response to Adams query on the Desktop list.. 

"Looks like all post r600 ATI cards would be affected, something must
 have changed in mutter to trigger this, the quickest solution I can see
 at the moment is to rebase mesa and pray. If you want a targeted fix
 it'll take longer to actually work out why its going so horribly wrong."

Try downgrading mutter to older version you can fetch them from koji
Comment 9 Jóhann B. Guðmundsson 2011-02-22 12:16:34 EST
Let's see if good old fashion hands on debugging helps better out than ABRT
Comment 10 Jóhann B. Guðmundsson 2011-02-22 12:17:18 EST
Created attachment 480179 [details]
Good old fasion hands on debugging..
Comment 11 Mike C 2011-02-22 14:41:55 EST
This is not restricted to Radeon cards - I have just tried to do a test using the current test day graphics iso on the following hardware:
http://www.smolts.org/client/show/pub_90235bed-08f2-4a23-ad0a-49cfb124f8f7

I am getting this same problem as for this bz - but this hardware is:
nVidia Corporation G86M [Quadro FX 360M]

Are the there any further suggestions for getting around this or getting any further in this case?
Comment 12 Jerome Glisse 2011-02-22 15:26:13 EST
Can people affected please test if mesa package at 
http://koji.fedoraproject.org/koji/taskinfo?taskID=2858301

Fix the issue
Comment 13 Jóhann B. Guðmundsson 2011-02-24 08:34:07 EST
Tested with 0.27 which is the latest in koji as of today still present..
Comment 14 Sergey 2011-02-25 17:03:15 EST
Package: mutter-2.91.6-4.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
0. Download gfx_test_week_20110221_i386.iso
1. Boot
2. Get mutter constantly crashing


Comment
-----
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
http://www.smolts.org/client/show/pub_1bd9b7cb-0031-4bdc-9885-ab1540ba820a
Comment 15 Sergey 2011-02-25 17:33:58 EST
Jerome Glisse> Can people affected please test if mesa package at ...

Mutter from gfx_test_week_20110221_i386.iso but with updates from http://koji.fedoraproject.org/koji/taskinfo?taskID=2858301 works for me.
Comment 16 Mike C 2011-02-26 12:01:46 EST
Now fixed in f15 alpha tc2 - brilliant and great work getting this done.
Comment 17 Jóhann B. Guðmundsson 2011-02-28 07:49:19 EST
Confirmed fixed in RC2 Alpha
Comment 18 Mike C 2011-02-28 09:56:58 EST
My bad - comment #16 was a typo - should have said rc2 and not tc2 - my apologies
Comment 19 Jerome Glisse 2011-02-28 10:24:01 EST
Closing

Note You need to log in before you can comment on or make changes to this bug.