Bug 677387 - WriteImage segmentation fault in pvpython and pvbatch
WriteImage segmentation fault in pvpython and pvbatch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: paraview (Show other bugs)
15
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
http://paraview.org/Bug/view.php?id=1...
:
: 679277 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-14 10:26 EST by Rolf Fokkens
Modified: 2012-03-17 19:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: paraview-3.14.0-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-11 21:58:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
testscript to demonstrate the crash (630 bytes, text/x-python)
2011-06-20 15:30 EDT, Rolf Fokkens
no flags Details

  None (edit)
Description Rolf Fokkens 2011-02-14 10:26:03 EST
Description of problem:

In pvbatch or pvpython, WriteImage( "foo.png", "vtkPNGWriter" ) generates a segmentation fault. The same result is obtained for the jpeg writer.

Version-Release number of selected component (if applicable):
paraview-3.8.1-3.fc14.x86_64
vtk-5.6.0-38.fc14.x86_64
python-2.7-8.fc14.1.x86_64

How reproducible:
Run the attached test1.py. This is a small test based on "ParaView Scripting with Python, august 2007".

Steps to Reproduce:
1. Run test1.py
  
Actual results:
Segmentation Fault

Expected results:
image file

Additional info:

http://public.kitware.com/Bug/view.php?id=10506
Comment 1 Rolf Fokkens 2011-02-14 10:26:56 EST
Apparently it's fixed in paraview 3.10. Updating the Fedora package seems to be the solution.
Comment 2 Orion Poplawski 2011-02-14 12:13:37 EST
I'm currently working on trying to get 3.10 into F15.  Once that is done I'll look into updating F14.
Comment 3 Rolf Fokkens 2011-06-20 15:28:33 EDT
Same situation for Fedora 15:
paraview-3.10.1-3.fc15.x86_64
vtk-5.6.1-5.fc15.x86_64
python-2.7.1-7.fc15.x86_64

How to cause the bug:
[rolf@home07 ~]$ pvpython test1.py 
vtkConeSource : [ ...........]
vtkShrinkFilter : [ ...........]
vtkConeSource : [ ...........]
vtkShrinkFilter : [ ...........]
Segmentation fault (core dumped)
[rolf@home07 ~]$

http://public.kitware.com/Bug/view.php?id=12292
Comment 4 Rolf Fokkens 2011-06-20 15:30:00 EDT
Created attachment 505678 [details]
testscript to demonstrate the crash
Comment 5 Orion Poplawski 2011-06-21 13:14:22 EDT
I can reproduce.  I'll see what I can find.
Comment 6 Orion Poplawski 2011-12-30 17:51:02 EST
*** Bug 679277 has been marked as a duplicate of this bug. ***
Comment 7 Orion Poplawski 2011-12-30 17:55:30 EST
Upstream seems to think this is fixed.  But the workaround from http://paraview.org/Bug/view.php?id=10556 still works:

adding this line before the call to WriteImage:

GetActiveView().UseOffscreenRenderingForScreenshots = 0 

or in the test1.py:

view.UseOffscreenRenderingForScreenshots = 0
Comment 8 Fedora Update System 2012-03-01 16:45:28 EST
paraview-3.14.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/paraview-3.14.0-2.fc17
Comment 9 Fedora Update System 2012-03-01 16:45:37 EST
paraview-3.14.0-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/paraview-3.14.0-2.fc16
Comment 10 Fedora Update System 2012-03-01 16:45:47 EST
paraview-3.14.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/paraview-3.14.0-2.fc15
Comment 11 Fedora Update System 2012-03-01 19:58:31 EST
Package paraview-3.14.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing paraview-3.14.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2799/paraview-3.14.0-2.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-03-11 21:58:30 EDT
paraview-3.14.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-03-17 19:36:58 EDT
paraview-3.14.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2012-03-17 19:48:55 EDT
paraview-3.14.0-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.