This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 677461 - [abrt] gnome-settings-daemon-2.91.9-4.fc15: __libc_start_main: Process /usr/libexec/gnome-settings-daemon was killed by signal 11 (SIGSEGV)
[abrt] gnome-settings-daemon-2.91.9-4.fc15: __libc_start_main: Process /usr/l...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
abrt_hash:9bdf0d44ada1db2c84ae5ee10b5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-14 16:52 EST by Kjartan Maraas
Modified: 2011-12-14 11:26 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-14 11:26:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (11.10 KB, text/plain)
2011-02-14 16:52 EST, Kjartan Maraas
no flags Details
backtrace (1.32 KB, text/plain)
2011-02-23 08:53 EST, Yaroslav Gorbunov
no flags Details

  None (edit)
Description Kjartan Maraas 2011-02-14 16:52:23 EST
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 11364 bytes
cmdline: /usr/libexec/gnome-settings-daemon
component: gnome-settings-daemon
Attached file: coredump, 44527616 bytes
crash_function: __libc_start_main
executable: /usr/libexec/gnome-settings-daemon
kernel: 2.6.38-0.rc4.git0.2.fc15.i686.PAE
package: gnome-settings-daemon-2.91.9-4.fc15
rating: 4
reason: Process /usr/libexec/gnome-settings-daemon was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1297720138
uid: 500

How to reproduce
-----
1. Crash on login
2.
3.
Comment 1 Kjartan Maraas 2011-02-14 16:52:27 EST
Created attachment 478719 [details]
File: backtrace
Comment 2 Matthias Clasen 2011-02-14 17:12:16 EST
Looks like it is segfaulting in the atexit handlers. 
So there is 2 questions here:

1) Why would g-s-d exit at session start

2) Who installs an atexit handler from a loadable module that is already unloaded at that point
Comment 3 Matthias Clasen 2011-02-14 18:01:06 EST
to answer the second question: orbit does, when it gets pulled in via gconf use in the keybinding module - I guess we need to link g-s-d against gconf as long as any modules use it.
Comment 4 John Reiser 2011-02-15 13:04:18 EST
Package: gnome-settings-daemon-2.91.9-4.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.boot
2.login
3.
Comment 5 Tim Lauridsen 2011-02-16 08:25:40 EST
Package: gnome-settings-daemon-2.91.9-4.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Start Fedora 15 Alpha TC2
2. Login
3.


Comment
-----
A new crach report is created very time I login
Comment 6 Joachim Frieben 2011-02-16 08:33:08 EST
Package: gnome-settings-daemon-2.91.9-4.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Logged in to GNOME.
Comment 7 Joachim Frieben 2011-02-16 09:05:34 EST
Package: gnome-settings-daemon-2.91.9-4.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Login GNOME.
Comment 8 Raphos 2011-02-18 17:37:15 EST
Package: gnome-settings-daemon-2.91.9-4.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1.Happend at fedora start
2.I don't know...
3.
Comment 9 G.Wolfe Woodbury 2011-02-20 12:03:26 EST
Package: gnome-settings-daemon-2.91.9-4.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. normal login after latest updates
2.
3.


Comment
-----
gdm login screen crashes after first character typed on first attemt. Subsequent attempts accept full password but fail to start gnome.
Comment 10 Joachim Frieben 2011-02-20 12:22:19 EST
(In reply to comment #9)
> Subsequent attempts accept full password but fail to start gnome.
This is bug 678825. Use the mouse in order to confirm the password or downgrade to ibus-1.3.99.20110206-1.fc15.
Comment 11 Raphos 2011-02-20 15:08:09 EST
Package: gnome-settings-daemon-2.91.9-4.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1.Automatic login into gnome
2.
3.
Comment 12 Yaroslav Gorbunov 2011-02-23 08:53:07 EST
Created attachment 480455 [details]
backtrace

gnome-settings-daemon-2.91.9-4.fc15 crashs on login
Comment 13 rudi 2011-02-23 17:18:09 EST
Package: gnome-settings-daemon-2.91.9-4.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. happens at boot
2.
3.
Comment 14 Alexei Panov 2011-02-24 04:05:26 EST
Package: gnome-settings-daemon-2.91.9-4.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. this bug occurs at system startup.
2. every time
3.
Comment 15 Kjartan Maraas 2011-11-12 03:28:46 EST
Probably fixed a long time ago by now?

Note You need to log in before you can comment on or make changes to this bug.