Bug 678825 - After updating ibus-1.3.99.20110206-3.fc15, login window repeats in gdm.
After updating ibus-1.3.99.20110206-3.fc15, login window repeats in gdm.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
: 678948 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-19 20:43 EST by sangu
Modified: 2011-03-02 22:02 EST (History)
7 users (show)

See Also:
Fixed In Version: ibus-1.3.99.20110206-4.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-02 22:02:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file of GDM greeter (25.39 KB, text/plain)
2011-02-20 10:22 EST, Joachim Frieben
no flags Details

  None (edit)
Description sangu 2011-02-19 20:43:33 EST
Description of problem:
After updating ibus-1.3.99.20110206-3.fc15, login window repeats in gdm

Version-Release number of selected component (if applicable):
1.3.99.20110206-3.fc15

How reproducible:
always

Steps to Reproduce:
1. login in gdm
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Joachim Frieben 2011-02-20 10:22:18 EST
Created attachment 479772 [details]
Log file of GDM greeter

Since yesterday, I could use the graphical login anymore: even a correct password was rejected. After entering an alternate user name, I was not prompted for the password. Instead, I was dropped back to the initial login panel.
An ibus related backtrace appeared in :0-greeter.log (see attachment).

»»»»  Downgrading to ibus-1.3.99.20110206-1.fc15 solved the problem.  ««««
Comment 2 Joachim Frieben 2011-02-20 10:24:05 EST
The critical event is: "IBUS-CRITICAL: _key_snooper_cb: assertion
  `IBUS_IS_IM_CONTEXT (ibusimcontext)' failed"
Comment 3 Jason 2011-02-20 11:26:49 EST
Can you click on your user, enter password, and then click Login (as opposed to pressing return)? I think I am seeing the same bug, and this is how I was able to circumvent it for the time being.
Comment 4 Joachim Frieben 2011-02-20 12:19:24 EST
(In reply to comment #3)
Confirming the password using the mouse instead of the keyboard allows indeed to log in. Interestingly, merely hitting the tab-key to move the input focus away from the password field after entering the password resets the input dialog.
Comment 5 fujiwara 2011-02-20 22:50:18 EST
Oh, I forgot gdm changes g_return* to SEGV.
But I also understood the focus_out is called earlier than finalize.
I agree g_return* should be removed.
Comment 6 fujiwara 2011-02-20 23:15:46 EST
(In reply to comment #1)
> Created attachment 479772 [details]
> Log file of GDM greeter

Thanks for providing /var/log/messages with modifying /etc/gdm/custom.conf

http://koji.fedoraproject.org/koji/taskinfo?taskID=2853293
Comment 7 Fedora Update System 2011-02-20 23:25:08 EST
ibus-1.3.99.20110206-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110206-4.fc15
Comment 8 fujiwara 2011-03-01 04:29:06 EST
*** Bug 678948 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2011-03-02 22:01:44 EST
ibus-1.3.99.20110206-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.