Bug 678323 - Some Cannon Pixma scanners stopped working
Summary: Some Cannon Pixma scanners stopped working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends
Version: 14
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 677283
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-17 15:41 UTC by Nick Allen
Modified: 2011-04-12 21:30 UTC (History)
2 users (show)

Fixed In Version: sane-backends-1.0.22-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-12 21:30:57 UTC


Attachments (Terms of Use)

Description Nick Allen 2011-02-17 15:41:23 UTC
Description of problem:

Looks like a bug was introduced in sane-backends-1.0.21 that broke several Cannon Pixma scanners...

Version-Release number of selected component (if applicable): sane-backends-1.0.21-5 and sane-backends-1.0.21-6 are both affected, but this appears to be an issue with 1.0.21 in general with Cannon Pixma scanners.

How reproducible:

This scanner has worked since Fedora 12, this is the first time I've fired it up under Fedora 14 though.  With an affected scanner, install sane-backends-1.0.21, sane-frontends-1.0.14, and xsane-0.998.  Run xsane:

Steps to Reproduce:

1.  Press "Preview", image scans into preview window
2.  Press "scan", a popup error ===> "Operation was cancelled"
3.  Scanner never was activated, no scanned image was produced
  
Actual results:

The document did not scan...

Expected results:

I expected the document to scan...

Additional info:

I compiled sane-backends-1.0.22, the issue seems to be resolved.

Here's a link to some discussion on this from the Debian side: 

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=585887

I haven't found it referenced yet on the Redhat / Fedora side

Comment 1 Nick Allen 2011-02-17 16:16:34 UTC
ahh... I must have HUA Syndrome. I found bug 583352.  It helps if you search for Canon instead of Cannon.  677283 also exists out there to build 1.0.22.

Comment 2 Nils Philippsen 2011-04-04 11:42:44 UTC
A new upstream version with many bugfixes and enhancements has been released. Please check whether you issue persists with this updated package:

https://admin.fedoraproject.org/updates/sane-backends-1.0.22-1.fc14

Comment 3 Nick Allen 2011-04-06 03:48:50 UTC
sane-backends-1.0.22-1.fc14 works with the Pixma scanner I own (connected by usb).  It runs fine as a standard user.  I have previewed and scanned several images tonight, stopped and started Xsane several times too.  Looks good from here, thanks!

Comment 4 Nils Philippsen 2011-04-06 09:04:09 UTC
Thanks for checking!

Comment 5 Fedora Update System 2011-04-06 09:06:23 UTC
sane-backends-1.0.22-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/sane-backends-1.0.22-1.fc14

Comment 6 Fedora Update System 2011-04-12 21:30:39 UTC
sane-backends-1.0.22-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.