Bug 678388 - [abrt] gcalctool-5.32.0-1.fc14: Process /usr/bin/gcalctool was killed by signal 11 (SIGSEGV)
[abrt] gcalctool-5.32.0-1.fc14: Process /usr/bin/gcalctool was killed by sign...
Status: CLOSED DUPLICATE of bug 707350
Product: Fedora
Classification: Fedora
Component: gcalctool (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
abrt_hash:ea76edfb27512c12499844f1189...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-17 14:14 EST by Scott Douglass
Modified: 2012-03-21 11:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 11:21:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (36.56 KB, text/plain)
2011-02-17 14:14 EST, Scott Douglass
no flags Details

  None (edit)
Description Scott Douglass 2011-02-17 14:14:38 EST
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: gcalctool
component: gcalctool
executable: /usr/bin/gcalctool
kernel: 2.6.35.11-83.fc14.x86_64
package: gcalctool-5.32.0-1.fc14
reason: Process /usr/bin/gcalctool was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1297969092
uid: 500

How to reproduce
-----
1. switched to programmer mode
2. tried to paste via control-v into text area
3.
Comment 1 Scott Douglass 2011-02-17 14:14:40 EST
Created attachment 479380 [details]
File: backtrace
Comment 2 Markus 2011-02-19 22:51:18 EST
Package: gcalctool-5.32.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Set mode to "Programming"
2. Chain two (or more? didn't try myself) 'complements' with small numbers (e.g. 'ones 2 twos 2' or 'ones 3 twos 5')
3. Calculate result

Comment
-----
It won't crash every time - sometimes, it displays the overflow message, and at others, it just dies. I noticed that sometimes it did it when I used the buttons instead of typing in "ones" or "twos", but that's probably just a silly coincidence.
Comment 3 Javier Jardón 2011-03-01 21:05:24 EST
Package: gcalctool-5.32.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Open program
2. Press Control-V
3. Crash
Comment 4 abrt-bot 2012-03-21 11:21:18 EDT
Backtrace analysis found this bug to be similar to bug #707350, closing as duplicate.

Bugs which were found to be similar to this bug: bug #649540, bug #707350

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 707350 ***

Note You need to log in before you can comment on or make changes to this bug.