Bug 678414 - NFS ISO install fails during repo setup - umount.nfs4: /mnt/source: device is busy
NFS ISO install fails during repo setup - umount.nfs4: /mnt/source: device is...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-17 16:04 EST by James Laska
Modified: 2013-09-02 02:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-15.26-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 691880 (view as bug list)
Environment:
Last Closed: 2011-04-05 17:38:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-logs.tgz (/tmp/*) (49.62 KB, application/x-gzip)
2011-02-17 16:04 EST, James Laska
no flags Details
`mount` output (1.52 KB, text/plain)
2011-02-18 15:47 EST, James Laska
no flags Details
anaconda.log (anaconda-15.25-1) (3.12 KB, text/plain)
2011-03-28 15:57 EDT, James Laska
no flags Details
/tmp/syslog (anaconda-15.25-1) (50.21 KB, text/plain)
2011-03-28 16:42 EDT, James Laska
no flags Details
/tmp/program.log (anaconda-15.25-1) (387 bytes, text/plain)
2011-03-28 16:43 EDT, James Laska
no flags Details
/tmp/program.log (anaconda-15.25-1) - HD ISO (1.26 KB, text/plain)
2011-03-29 14:00 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2011-02-17 16:04:05 EST
Created attachment 479401 [details]
anaconda-logs.tgz (/tmp/*)

Description of problem:

During an NFS ISO installation, the following error appears while transitioning to the repo setup screen: "umount.nfs4: /mnt/source: device is busy"

Version-Release number of selected component (if applicable):
 * anaconda-15.20-1 (with updates for 15.21-1)

Steps to Reproduce:
1. Boot F-15-Alpha-TC2 with "askmethod"
2. At installation source dialog, select NFS and enter server+path to a F-15-Alpha-x86_64-DVD.iso
  
Actual results:

                 ┌──────┤ Error Setting Up Repository ├───────┐                 
                 │                                            │                 
                 │ The following error occurred while setting │                 
                 │ up the installation repository:            │                 
                 │                                            │                 
                 │ (16, 'umount.nfs4: /mnt/source: device is  │                 
                 │ busy\numount.nfs4: /mnt/source: device is  │                 
                 │ busy')                                     │                 
                 │                                            │                 
                 │ Please provide the correct information for │                 
                 │ installing Fedora.                         │                 
                 │                                            │                 
                 │                  ┌────┐                    │                 
                 │                  │ OK │                    │                 
                 │                  └────┘                    │                 
                 │                                            │                 
                 │                                            │                 
                 └────────────────────────────────────────────┘ 

Expected results:

Package repo available and used for installation

Additional info:

 * See attached tarball containing log files ...

-rw-r--r-- root/root     12562 2011-02-17 15:56 tmp/anaconda.log
-rw-r--r-- root/root       872 2011-02-17 15:55 tmp/ifcfg.log
-rw-r--r-- root/root     41404 2011-02-17 15:56 tmp/program.log
-rw-r--r-- root/root    319949 2011-02-17 15:56 tmp/storage.log
-rw-r--r-- root/root     54956 2011-02-17 15:59 tmp/syslog
Comment 1 Chris Lumens 2011-02-18 10:37:43 EST
Did you try testing with the updates image for 676821?
Comment 2 James Laska 2011-02-18 11:02:12 EST
(In reply to comment #1)
> Did you try testing with the updates image for 676821?

Yes, in this test, I used updates=http://jlaska.fedorapeople.org/updates/f-15-alpha-tc2.img

That contains a fix for bug#676821
Comment 3 Chris Lumens 2011-02-18 11:05:25 EST
Darn.
Comment 4 Chris Lumens 2011-02-18 11:31:53 EST
What does "mount" on tty2 think?  From the looks of things, the thing we do immediately before this error is unmount the only thing under /mnt/source.  There's got to be something else I'm not seeing.
Comment 5 James Laska 2011-02-18 15:47:52 EST
Created attachment 479605 [details]
`mount` output

(In reply to comment #4)
> What does "mount" on tty2 think?  From the looks of things, the thing we do
> immediately before this error is unmount the only thing under /mnt/source. 
> There's got to be something else I'm not seeing.

See attachment.
Comment 6 Chris Lumens 2011-02-22 10:05:29 EST
anaconda-15.21-1 will have a little extra debugging output here, since I'm curious about this /tmp/mnt business.  I'm not sure if it's related or not but it's good to be sure.  If you can retest post-alpha and look for this message:

+        logMessage(ERROR, "could not unmount /tmp/mnt in getFileFromNfs: %s", strerror(errno));
Comment 7 Adam Williamson 2011-03-11 12:37:12 EST
Discussed at the 2011-03-11 blocker review meeting, accepted as a blocker per criterion "The installer must be able to use the HTTP, FTP and NFS remote package source options".
Comment 8 Adam Williamson 2011-03-25 13:16:38 EDT
James, this one is on you - do we have images yet that would enable you to provide the info requested in comment #6, or are we waiting for those?
Comment 9 James Laska 2011-03-28 10:47:12 EDT
This needs DVD ISO's to test.  I created a sample DVD ISO last Friday, but it wasn't sufficient to test.  I'll retry again shortly.  If nothing else, we'll confirm this with TC1 DVD ISO.
Comment 10 James Laska 2011-03-28 15:57:41 EDT
Created attachment 488243 [details]
anaconda.log (anaconda-15.25-1)

Testing with a custom-built anaconda-15.25-1 DVD.iso image, I get the following ...

                     ┌─────────────┤ Error ├─────────────┐                      
                     │                                   │                      
                     │ The URL provided does not contain │                      
                     │ installation media.               │                      
                     │                                   │                      
                     │              ┌────┐               │                      
                     │              │ OK │               │                      
                     │              └────┘               │                      
                     │                                   │                      
                     │                                   │                      
                     └───────────────────────────────────┘                     

The attached anaconda.log shows ...

19:50:46,126 INFO loader: url is nfs:dell-t5400.test.redhat.com:/var/lib/libvirt/images/x86_64/.treeinfo
19:50:46,126 DEBUG loader: parseNfsHostPathOpts url: |dell-t5400.test.redhat.com:/var/lib/libvirt/images/x86_64/.treeinfo|
19:50:46,127 DEBUG loader: parseNfsHostPathOpts host: |dell-t5400.test.redhat.com|
19:50:46,127 DEBUG loader: parseNfsHostPathOpts path: |/var/lib/libvirt/images/x86_64/.treeinfo|
19:50:46,127 DEBUG loader: parseNfsHostPathOpts opts: |(null)|
19:50:46,127 INFO loader: file location: nfs:dell-t5400.test.redhat.com:/var/lib/libvirt/images/x86_64/.treeinfo
19:51:56,789 ERR loader: failed to open /tmp/mnt/.treeinfo: No such file or directory
19:51:56,789 ERR loader: failed to copy file to /tmp/.treeinfo
19:51:56,809 DEBUG loader: parseNfsHostPathOpts url: |dell-t5400.test.redhat.com:/var/lib/libvirt/images/x86_64|
19:51:56,809 DEBUG loader: parseNfsHostPathOpts host: |dell-t5400.test.redhat.com|
19:51:56,809 DEBUG loader: parseNfsHostPathOpts path: |/var/lib/libvirt/images/x86_64|
19:51:56,809 DEBUG loader: parseNfsHostPathOpts opts: |(null)|
19:51:56,825 ERR loader: couldn't mount dell-t5400.test.redhat.com:/var/lib/libvirt/images/x86_64 to look for NFSISO


Note, my NFS directory contains *only* Fedora-15-x86_64-DVD.iso, I did not add the .treeinfo file.  I didn't think that was required.
Comment 11 Chris Lumens 2011-03-28 16:15:57 EDT
You don't need a .treeinfo file.  What happens is that because the UI doesn't give you an NFS ISO choice, we have to try both kinds of NFS installs.  So first we check if it's a regular NFS tree that contains a .treeinfo file.  That fails, and then we check to see if it's an NFS ISO tree.

That last error about "couldn't mount..." is where the real problem is.  The reason should be logged in /tmp/syslog or /tmp/program.log.  Can you attach those?
Comment 12 James Laska 2011-03-28 16:42:41 EDT
Created attachment 488250 [details]
/tmp/syslog (anaconda-15.25-1)

Note, this log may contain some output when I manually ran mount from a shell.  If this is confusing matters, I can reproduce the issue without this additional noise.
Comment 13 James Laska 2011-03-28 16:43:18 EDT
Created attachment 488251 [details]
/tmp/program.log (anaconda-15.25-1)
Comment 14 James Laska 2011-03-29 08:13:40 EDT
Heads up ... it appears that loader/hdinstall.c is also impacted by the "-t auto" option (see Michael's comment#14 in bug#678086).  I've asked Michael to track that new issue in this bug. 

clumens: let me know if you prefer having the loader/hdinstall.c mount failure as a new bug, I'll be happy to create one for you.
Comment 15 Chris Lumens 2011-03-29 10:42:06 EDT
Can I see the program.log from an HD attempt to verify this is the same problem?  There are a couple places that error message can come from.
Comment 16 James Laska 2011-03-29 14:00:08 EDT
Created attachment 488520 [details]
/tmp/program.log (anaconda-15.25-1) - HD ISO

(In reply to comment #15)
> Can I see the program.log from an HD attempt to verify this is the same
> problem?  There are a couple places that error message can come from.

Looking at program.log, this appears to be sufficiently different than the NFS ISO problem.  At your command, I'll file this as a new bug.
Comment 17 Fedora Update System 2011-03-29 16:51:51 EDT
anaconda-15.26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
Comment 18 Fedora Update System 2011-03-29 22:25:22 EDT
Package anaconda-15.26-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.26-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.26-1.fc15
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2011-04-05 17:37:17 EDT
anaconda-15.26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.