Bug 697517 - grub2-mkconfig does not find other systems
grub2-mkconfig does not find other systems
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On: 678456
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-18 10:01 EDT by Barry Fishman
Modified: 2011-09-06 09:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-06 09:02:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry Fishman 2011-04-18 10:01:41 EDT
Description of problem:

uname -a
Linux ecube.site 2.6.38.2-9.fc15.x86_64 #1 SMP Wed Mar 30 16:55:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

The grub.cfg file generated by grub2-mkconfig only contains entries for
the kernels in the local /boot directory.  This makes it difficult to
boot other OS's available in a multi-boot setup.

Debian Squeeze and Ubuntu Maverick/Natty seem to find all the potential
partitions that are bootable.  Even SuSE using grub1 sets up chainload
entries to start up grub2 on these partitions.

Version-Release number of selected component (if applicable):

Found in Fedora 14 and Fedora 15 beta

How reproducible:

Always

Steps to Reproduce:
1. run grub2-mkconfig >temp.cfg
2. grep menuentry temp.cfg
  
Actual results:
menuentry "GNU/Linux, with Linux 2.6.38.2-9.fc15.x86_64" --class gnu-linux --class gnu --class os {
menuentry "GNU/Linux, with Linux 2.6.38.2-9.fc15.x86_64 (recovery mode)" --class gnu-linux --class gnu --class os {


Expected results:

For me, something more like:

menuentry "GNU/Linux, with Linux 2.6.38.2-9.fc15.x86_64" --class gnu-linux --class gnu --class os {
menuentry "GNU/Linux, with Linux 2.6.38.2-9.fc15.x86_64 (recovery mode)" --class gnu-linux --class gnu --class os {
menuentry "Memory test (memtest86+)" {
menuentry "Windows Recovery Environment (loader) (on /dev/sda1)" --class windows --class os {
menuentry "Windows 7 (loader) (on /dev/sda2)" --class windows --class os {
menuentry "Debian GNU/Linux, with Linux 2.6.32-5-amd64 (on /dev/sda3)" --class gnu-linux --class gnu --class os {
menuentry "Debian GNU/Linux, with Linux 2.6.32-5-amd64 (recovery mode) (on /dev/sda3)" --class gnu-linux --class gnu --class os {
menuentry "Ubuntu, with Linux 2.6.35-28-generic (on /dev/sda5)" --class gnu-linux --class gnu --class os {
menuentry "Ubuntu, with Linux 2.6.35-28-generic (recovery mode) (on /dev/sda5)" --class gnu-linux --class gnu --class os {
menuentry "Fedora release 15 (Lovelock) (on /dev/sdb1)" --class gnu-linux --class gnu --class os {
menuentry "openSUSE 11.4 (on /dev/sdb2)" --class gnu-linux --class gnu --class os {
menuentry "Failsafe -- openSUSE 11.4 (on /dev/sdb2)" --class gnu-linux --class gnu --class os {

Additional info:
Comment 1 Hedayat Vatankhah 2011-05-08 13:21:45 EDT
This is due to bug #678456
Comment 2 Barry Fishman 2011-09-06 09:02:24 EDT
Not a problem when the additional module is loaded.  Why this second module is required is a matter for bug #678456

Note You need to log in before you can comment on or make changes to this bug.