Bug 67848 - Incorrect setenv syntax in lang.csh
Incorrect setenv syntax in lang.csh
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-02 18:36 EDT by Need Real Name
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-02 18:36:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-02 18:36:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-34smp i686)

Description of problem:
/etc/profile.d/lang.csh contains the erroneous syntax: 
  setenv LANG=$GDM_LANG
which makes a mess for csh or tcsh. I upgraded from RH6.2 to RH7.2. Under tcsh I
have the environment variable "LANG=en_US" (really! That is the name, not the
name and value!) and it is set to null, as well as the variable "LANG" set to
"en_US". When all this passes into sh, I have only the environment variable
"LANG" but the value is "en_US=". This is an illegal locale and causes much
grief (Perl, Netscape, Emacs, etc.) Correcting the bogus line in lang.csh fixes
the problem entirely. Interestingly, on another machine with a clean
installation of RH7.2, the GDM_LANG variable is not used, so the problem does
not surface.

This could plausibly be the cause for bug 55663.  Maybe?

How reproducible:
Always

Steps to Reproduce:
1.If $GDM_LANG is set before sourcing /etc/profile.d/lang.csh
2.Pass from tcsh to sh
3.check value of $LANG
Comment 1 Bill Nottingham 2002-07-17 01:09:29 EDT
This is fixed in the current CVS initscripts, and the 7.3 initscripts.

Note You need to log in before you can comment on or make changes to this bug.