Bug 678696 - gnome-sound-applet's trayicon lacks icon
Summary: gnome-sound-applet's trayicon lacks icon
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F15Target-xfce
TreeView+ depends on / blocked
 
Reported: 2011-02-18 21:55 UTC by Christoph Wickert
Modified: 2011-08-16 11:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-14 18:09:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 693548 None None None Never
Red Hat Bugzilla 729271 None None None Never

Internal Trackers: 693548 729271

Description Christoph Wickert 2011-02-18 21:55:20 UTC
Description of problem:
When booting the Xfce livecd, the trayicon of gnome-sound-applet lacks an icon. Without looking at the code I don't know which icon it is looking for, so I file this against the Xfce spin for now.

Version-Release number of selected component (if applicable):
xfce-i386-20110217.00 with control-center-2.91.6-8.fc15

Comment 1 Kevin Fenzi 2011-02-19 19:21:41 UTC
Looks like it's looking for: 

Icon=multimedia-volume-control

which is in the control-center package, so not sure why it's not showing up. 
I can confirm the same thing here.

Comment 2 Christoph Wickert 2011-02-19 21:48:19 UTC
I have no idea what the desktop file is for, but this is not the icon for the trayicon. These icons are not static but depend on the volume.

They are defined in /gnome-control-center-2.91.6/panels/sound/gvc-applet.c

    static const char *output_icon_names[] = {
            "audio-volume-muted-symbolic",
            "audio-volume-low-symbolic",
            "audio-volume-medium-symbolic",
            "audio-volume-high-symbolic",
            NULL
    };

As the *-symbolic icons are only available from gnome-icon-theme-symbolic. control-center should depend on it. Even better: The code should not hardcode the icon *-symbolic icon names and use regular xdg ones instead.

For me this is reason enough to get rid of control-center even if this means we have no mixer in the panel by default. control-center is only pulled in through gnome-bluetooth, we could switch to blueman instead (given that bug 542812 gets fixed).

Comment 3 Christoph Wickert 2011-02-20 20:05:39 UTC
Reassigning to control-center. The control-center package needs to require gnome-icon-theme-symbolic. Even better

1. gnome-icon-theme-symbolic should have a virtual provides for something like system-icon-theme-symbolic, that is then required by other packages.

OR

2. the control-center code should not have *-symbolic hardcoded for icon names. Is anybody aware of other icon themes that provide *-symbolic icons

Comment 4 Bastien Nocera 2011-03-14 18:09:08 UTC
(In reply to comment #3)
> Reassigning to control-center. The control-center package needs to require
> gnome-icon-theme-symbolic. Even better

Done.

I think it's probably a good idea for the XFCE desktop to not use the gnome-sound-applet, or any other applets that would require symbolic icons, as even with those icons, I doubt that the XFCE panel knows how to recolour them (this requires using GTK+ 3.x).

Comment 5 Christoph Wickert 2011-03-14 18:28:15 UTC
Thanks.

We are trying our best to avoid gnome-sound-applet but it is part of gnome-control-center which is pulled in for various reasons (gnome-packagekit, gnome-bluetooth...)

How about making /etc/xdg/autostart/gnome-sound-applet.desktop OnlyShowIn=Gnome; ?

Comment 6 Christoph Wickert 2011-08-16 11:13:33 UTC
(In reply to comment #5)
> How about making /etc/xdg/autostart/gnome-sound-applet.desktop
> OnlyShowIn=Gnome; ?

for the record: This was fixed in bug 693548, however it was fixed in an incorrect manner as described in bug 729271.


Note You need to log in before you can comment on or make changes to this bug.