Bug 729271 - unable to disable gnome-sound-applet [NEEDINFO]
Summary: unable to disable gnome-sound-applet
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 15
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 10:34 UTC by Heiko Adams
Modified: 2011-08-17 10:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 10:07:39 UTC
cwickert: needinfo? (control-center-maint)


Attachments (Terms of Use)
Screenshot of my xfce4-session-settings (110.49 KB, image/png)
2011-08-09 20:14 UTC, Heiko Adams
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 678696 None None None Never
Red Hat Bugzilla 693548 None None None Never

Internal Links: 678696 693548

Description Heiko Adams 2011-08-09 10:34:37 UTC
Description of problem:
I've migrated my desktop from Gnome3 to Xfce for several reasons. But currently I'm unable to disable gnome-sound-applet which is part of the control-center package.

Version-Release number of selected component (if applicable):
control-center-3.0.1.1-6.fc15

How reproducible:
allways

Steps to Reproduce:
1. Remove gnome-sound-applet entry from gnome-session-properties
2. remove gnome-sound-applet link from ~/.config/autostart
3. restart your Xfce session
  
Actual results:
gnome-sound-applet is started

Expected results:
gnome-sound-applet should not be started because I've removed the autostart entries.

Additional info:
I can not remove control-center from my System because I need gnome-bluetooth for several reasons.

Comment 1 Ken Dreyer 2011-08-09 19:42:21 UTC
Please check the Freedesktop.org docs: http://standards.freedesktop.org/autostart-spec/autostart-spec-latest.html

"Implementation Notes

"If an application autostarts by having a .desktop file installed in the system wide autostart directory, an individual user can disable the autotomatic start of this application by placing a .desktop file of the same name in its personal autostart directory which contains the key Hidden=true."

So you should be able to copy /etc/xdg/autostart/gnome-sound-applet.desktop to ~/.config/autostart and add a line "Hidden=true".

Comment 2 Christoph Wickert 2011-08-09 20:04:42 UTC
The question is why it is started in first place. /etc/xdg/autostart/gnome-sound-applet.desktop already contains "OnlyShowIn=GNOME;" (see bug 693548). As long as there is no file ~/.config/autostart to overwrite this, it should not be started.

(In reply to comment #0)
> 1. Remove gnome-sound-applet entry from gnome-session-properties
> 2. remove gnome-sound-applet link from ~/.config/autostart

That does not make sense. As soon as you disable it in gnome-session-properties, ~/.config/autostart/gnome-sound-applet.desktop is created with "Hidden=true". So you basically reverted what you just did in gnome-session-properties. Did you try to disable it in xfce4-session-settings?

Comment 3 Heiko Adams 2011-08-09 20:12:52 UTC
xfce4-session-settings has an entry called "PulseAudio Sound System" which is diabled (see screenshot)

Comment 4 Heiko Adams 2011-08-09 20:14:00 UTC
Created attachment 517477 [details]
Screenshot of my xfce4-session-settings

Comment 5 Christoph Wickert 2011-08-09 20:31:56 UTC
It's better to look at the files than at screenshots.

$ grep OnlyShowIn /etc/xdg/autostart/gnome-sound-applet.desktop 
OnlyShowIn=GNOME;XFCE;
OnlyShowIn=GNOME;

Now we found the problem: The file contains OnlyShowIn line *twice*. It already had one and the patch to fix bug 693548 [1] added a second entry.

[1] http://pkgs.fedoraproject.org/gitweb/?p=control-center.git;a=blob;f=gnome-sound-applet.patch;h=088e93c74271a077f960a9b76f82707b8eb61578;hb=242312c3111778cbf1d3bf2cef436acececaecff

Comment 6 Heiko Adams 2011-08-09 20:41:49 UTC
Sounds like the german term "verschlimmbessert" ;-)

Comment 7 Christoph Wickert 2011-08-17 10:07:39 UTC
I have fixed this in rawhide now. control-center maintainers, please push this out to the branches that you think that are necessary and unset the NEEDINFO flag.


Note You need to log in before you can comment on or make changes to this bug.