Bug 678757 - [mutter] occasionally incomplete rendering of title bars
[mutter] occasionally incomplete rendering of title bars
Status: CLOSED DUPLICATE of bug 706761
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15GNOMEfail
  Show dependency treegraph
 
Reported: 2011-02-19 06:35 EST by Joachim Frieben
Modified: 2011-06-08 23:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-08 23:25:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
jfrieben: needinfo-


Attachments (Terms of Use)
Screenshot of firefox running in GNOME shell (23.77 KB, image/png)
2011-02-19 06:35 EST, Joachim Frieben
no flags Details
Xorg.0.log for ATI Radeon X800 (R430) (52.35 KB, text/plain)
2011-02-19 06:36 EST, Joachim Frieben
no flags Details
Screenshot of corrupted window decoration (19.18 KB, image/png)
2011-05-13 02:35 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2011-02-19 06:35:33 EST
Created attachment 479666 [details]
Screenshot of firefox running in GNOME shell

Description of problem:
For current F15, windows occasionally lose a chunk of their title bar as shown in the attached screenshot. The video card is an ATI Radeon X800.

Version-Release number of selected component (if applicable):
mutter-2.91.6-4.fc15.x86_64

How reproducible:
Sometimes.

Steps to Reproduce:
1. Run GNOME shell session.
  
Actual results:
After a while some window may lose a chunk of its title bar.

Expected results:
Windows including decorations are rendered completely.

Additional info:
Current theme is Adwaita (thickness of window frames set to 4).
Comment 1 Joachim Frieben 2011-02-19 06:36:53 EST
Created attachment 479667 [details]
Xorg.0.log for ATI Radeon X800 (R430)
Comment 2 Peter Robinson 2011-02-19 08:12:26 EST
have you tried with clutter 1.6.4 as its fixed a number of rendering issues.
Comment 3 Joachim Frieben 2011-02-19 08:21:09 EST
The system is fully updated as of today with respect to "fedora" and "updates-testing" repositories including clutter-1.6.4-1.fc15.
Comment 4 Peter Robinson 2011-03-13 22:31:23 EDT
Joachim: is this improved with the latest updates, or are you still seeing mis rendering?
Comment 5 Joachim Frieben 2011-03-25 05:24:14 EDT
Issue has been observed again today with mutter-2.91.92-1.fc15.
Comment 6 Hans de Goede 2011-04-10 17:56:19 EDT
I'm seeing this too (sometimes), my system has am Ati RV570 [Radeon X1950 Pro], so this may be related to using ati cards.
Comment 7 Joachim Frieben 2011-05-13 02:35:07 EDT
Created attachment 498697 [details]
Screenshot of corrupted window decoration

Issue still observed for current F15 including testing updates:
- gnome-shell-3.0.1-4.fc15
- mesa-libGL-7.11-0.9.20110509.0.fc15
- mutter-3.0.1-3.fc15
- xorg-x11-drv-ati-6.14.1-1.20110504gita6d2dba6.fc15
- xorg-x11-server-Xorg-1.10.1-14.fc15
Comment 8 Joachim Frieben 2011-06-02 02:18:06 EDT
Observed again today for current F15 with updates-testing including packages:
- clutter-1.6.14-1.fc15
- gnome-shell-3.0.2-1.fc15
- mesa-libGL-7.11-0.11.20110525.0.fc15
- mutter-3.0.2.1-1.fc15
- xorg-x11-drv-ati-6.14.1-2.20110525gitfe5c42f51.fc15
- xorg-x11-server-Xorg-1.10.2-1.fc15
Comment 9 Peter Robinson 2011-06-08 20:04:24 EDT
this actually looks like a dupe of 706761
Comment 10 Peter Robinson 2011-06-08 23:25:04 EDT

*** This bug has been marked as a duplicate of bug 706761 ***

Note You need to log in before you can comment on or make changes to this bug.