This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 678948 - Using enter to send password doesn't work
Using enter to send password doesn't work
Status: CLOSED DUPLICATE of bug 678825
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-20 22:13 EST by Bruno Wolff III
Modified: 2011-03-01 04:29 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-01 04:29:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2011-02-20 22:13:09 EST
Description of problem:
With gdm-2.91.6-9.fc15.i686 I cannot use the enter key to send my password. The login button is highlighted when I do this, but authentication always fails. However clicking on the login button does work.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-02-21 13:16:01 EST
Confirmed & This might help. . . . 

(gdb) continue
Continuing.

Program received signal SIGABRT, Aborted.
0x00131424 in __kernel_vsyscall ()
(gdb) thread apply all bt

Thread 2 (Thread 0xb73ffb70 (LWP 2477)):
#0  0x00131424 in __kernel_vsyscall ()
#1  0x004f1e7a in __poll (fds=0xb6a02880, nfds=3, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x00359cfc in g_poll (fds=0xb6a02880, nfds=3, timeout=-1) at gpoll.c:132
#3  0x0034ae26 in g_main_context_poll (n_fds=3, fds=0xb6a02880, timeout=<optimized out>, context=0x8138e10, priority=<optimized out>) at gmain.c:3404
#4  g_main_context_iterate (context=0x8138e10, block=3513552, dispatch=1, self=<optimized out>) at gmain.c:3086
#5  0x0034b62b in g_main_loop_run (loop=0x8138e00) at gmain.c:3299
#6  0x002183d2 in gdbus_shared_thread_func (data=0x0) at gdbusprivate.c:276
#7  0x003727f5 in g_thread_create_proxy (data=0x8138ea0) at gthread.c:1897
#8  0x0014ac8d in start_thread (arg=0xb73ffb70) at pthread_create.c:301
#9  0x004fc39e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7fe0840 (LWP 2475)):
#0  0x00131424 in __kernel_vsyscall ()
#1  0x004515df in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2  0x00452f45 in abort () at abort.c:92
#3  0x00353a14 in g_logv (log_domain=0x7b737a "IBUS", log_level=<optimized out>, format=0x3c1b7c "%s: assertion `%s' failed", args1=0xbffff78c "\355v{")
    at gmessages.c:557
#4  0x00353a54 in g_log (log_domain=0x7b737a "IBUS", log_level=G_LOG_LEVEL_CRITICAL, format=0x3c1b7c "%s: assertion `%s' failed") at gmessages.c:577
#5  0x00353cbe in g_return_if_fail_warning (log_domain=0x7b737a "IBUS", pretty_function=0x7b76ed "_key_snooper_cb", expression=
    0x7b760c "IBUS_IS_IM_CONTEXT (ibusimcontext)") at gmessages.c:586
#6  0x007b664e in _key_snooper_cb (widget=0x81ff380 [GtkButton], event=0x81388c8, user_data=0x0) at ibusimcontext.c:283
#7  0x4329fa6a in gtk_invoke_key_snoopers (event=<optimized out>, grab_widget=<optimized out>) at gtkmain.c:2384
#8  gtk_main_do_event (event=0x81388c8) at gtkmain.c:1831
#9  0x430f336d in _gdk_event_emit (event=0x81388c8) at gdkevents.c:71
#10 0x43115ef9 in gdk_event_source_dispatch (source=0x80bece8, callback=0, user_data=0x0) at gdkeventsource.c:318
#11 0x0034a7bf in g_main_dispatch (context=0x809eea0) at gmain.c:2440
#12 g_main_context_dispatch (context=0x809eea0) at gmain.c:3013
#13 0x0034af20 in g_main_context_iterate (context=0x809eea0, block=3513552, dispatch=1, self=<optimized out>) at gmain.c:3091
#14 0x0034b62b in g_main_loop_run (loop=0x8142180) at gmain.c:3299
#15 0x4329ee65 in gtk_main () at gtkmain.c:1349
#16 0x08054e56 in main (argc=1, argv=0xbffffab4) at greeter-main.c:314
Comment 2 Jóhann B. Guðmundsson 2011-02-21 13:30:18 EST
Looks like it's fixed in.. 

http://koji.fedoraproject.org/koji/buildinfo?buildID=229734
Comment 3 Jóhann B. Guðmundsson 2011-02-21 13:38:34 EST
Confirmed fixed for me Bruno could you test and report
Comment 4 Jóhann B. Guðmundsson 2011-02-21 13:44:37 EST
Note that this issue is probably duplicate of Bug 678825
Comment 5 Bruno Wolff III 2011-02-21 14:43:39 EST
I tried this out on two machines (one of which I never verified the problem on) and it seems to be fixed after the ibus update.
Comment 6 fujiwara 2011-03-01 04:29:06 EST
According to the comment #5, I assume this bug is duplicated.
Thanks.

*** This bug has been marked as a duplicate of bug 678825 ***

Note You need to log in before you can comment on or make changes to this bug.