Bug 67909 - sndconfig segfaults
Summary: sndconfig segfaults
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: sndconfig (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 68307 68554 (view as bug list)
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-04 04:20 UTC by Tom "spot" Callaway
Modified: 2014-03-17 02:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-13 03:17:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace log. (8.82 KB, text/plain)
2002-07-05 18:43 UTC, Sam Varshavchik
no flags Details

Description Tom "spot" Callaway 2002-07-04 04:20:23 UTC
Description of Problem:

sndconfig segfaults.

Version-Release number of selected component (if applicable):

sndconfig-0.68-3

How Reproducible:

Always

Steps to Reproduce:
1. run sndconfig
2. 
3. 

Actual Results:

segfault

Expected Results:

Configuration of sound card

Additional Information:
	
gdb bt:

Program received signal SIGSEGV, Segmentation fault.
0x4206d015 in _int_malloc () from /lib/i686/libc.so.6
(gdb) bt
#0  0x4206d015 in _int_malloc () from /lib/i686/libc.so.6
#1  0x4206c435 in malloc () from /lib/i686/libc.so.6
#2  0x420bc7e1 in ftw_startup () from /lib/i686/libc.so.6
#3  0x420bc141 in ftw () from /lib/i686/libc.so.6
#4  0x0804ba60 in strcpy ()
#5  0x0804f77a in strcpy ()
#6  0x420165c4 in __libc_start_main () from /lib/i686/libc.so.6

Comment 1 Tom "spot" Callaway 2002-07-04 04:21:26 UTC
Hardware is a Dell Inspiron 4000. Clean install of Limbo.

00:08.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i PCI Audio
Accelerator (rev 10)


Comment 2 Sam Varshavchik 2002-07-05 18:42:42 UTC
I can reproduce this bug.  The hardware is a non-PNP ESS audiodrive sound card
that I always configure manually, and damned if I can remember the voodoo that
usually ends up written to modules.conf...  I don't think the audio card
matters, it faults before it gets a chance to probe.





Comment 3 Sam Varshavchik 2002-07-05 18:43:54 UTC
Created attachment 63853 [details]
strace log.

Comment 4 Jim Hall 2002-07-07 00:50:44 UTC
I can also reproduce this bug.  Here is the description of my sound card from
"lspci -vv":


01:07.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 09)
        Subsystem: Intel Corp.: Unknown device 4332
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr-
DEVSEL=slow >TAbort- <TAbort+ <MAbort- >SERR- <PERR-
        Latency: 64 (3000ns min, 32000ns max)
        Interrupt: pin A routed to IRQ 10
        Region 0: I/O ports at df00 [size=64]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-


Comment 5 Bill Nottingham 2002-07-08 03:53:48 UTC
Yeah, I can reproduce this, but not if I rebuild it. How odd.

Comment 6 Bill Nottingham 2002-07-09 20:12:31 UTC
*** Bug 68307 has been marked as a duplicate of this bug. ***

Comment 7 Bill Nottingham 2002-07-12 03:55:25 UTC
*** Bug 68554 has been marked as a duplicate of this bug. ***

Comment 8 Bill Nottingham 2002-07-13 03:16:58 UTC
Rebuilt as 0.68-4; this version works for me.

Comment 9 Jay Turner 2002-07-30 12:06:35 UTC
Fix confirmed on
ESS Technology ES1983S Maestro-3i PCI Audio Accelerator (rev 10)
with sndconfig-0.68-4


Note You need to log in before you can comment on or make changes to this bug.