Bug 67910 - sm-client starting problem
Summary: sm-client starting problem
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 68927 (view as bug list)
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-04 07:15 UTC by Chun-Chung Chen
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-08 03:52:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chun-Chung Chen 2002-07-04 07:15:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020615
Debian/1.0.0-3

Description of problem:
/etc/init.d/sendmail fails to start sm-client

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
/etc/init.d/sendmail start
/etc/init.d/sendmail stop



Actual Results:  
# /etc/init.d/sendmail start
Starting sendmail:                                         [  OK  ]
Starting sm-client:
# /etc/init.d/sendmail stop
Shutting down sendmail:                                    [  OK  ]
Shutting down sm-client:                                   [ FAIL ]


Expected Results:  
# /etc/init.d/sendmail start
Starting sendmail:                                         [  OK  ]
Starting sm-client:                                        [  OK  ]
# /etc/init.d/sendmail stop 
Shutting down sendmail:                                    [  OK  ]
Shutting down sm-client:                                   [  OK  ]


Additional info:

In /etc/init.d/sendmail, "--check sm-client" should be added to line 59.
=> daemon --check sm-client /usr/sbin/sendmail ....
So that sm-client can be started properly.

The line:
define(`confPID_FILE', `/var/run/sm-client.pid')dnl
should be added to /etc/mail/submit.mc and rebuild the submit.cf with
# m4 /usr/share/sendmail-cf/m4/cf.m4 /etc/mail/submit.mc > /etc/mail/submit.cf
so that sm-client can be shut down properly.

Comment 1 Florian La Roche 2002-07-11 11:34:46 UTC
Fixed in 8.12.5-2 or higher.

Thanks a lot,

Florian La Roche


Comment 2 Bill Nottingham 2002-07-17 02:28:31 UTC
*** Bug 68927 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.