Bug 679171 - Hitting enter to move to Next screen crashes firstboot
Hitting enter to move to Next screen crashes firstboot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
RejectedBlocker AcceptedNTH
:
: 679348 (view as bug list)
Depends On:
Blocks: F15Alpha-accepted/F15AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2011-02-21 14:38 EST by Brian Lane
Modified: 2013-07-04 08:54 EDT (History)
7 users (show)

See Also:
Fixed In Version: firstboot-1.117-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-25 23:40:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (661.28 KB, text/plain)
2011-02-21 14:39 EST, Brian Lane
no flags Details

  None (edit)
Description Brian Lane 2011-02-21 14:38:55 EST
Using mouse or tab+space to activate the Next button works fine. Using Tab+Enter causes firstboot to exit and gdm to launch. On the next boot firstboot runs again.

abrt says that Xorg crashed:

Feb 21 13:50:40 localhost systemd[1]: firstboot-graphical.service: main process exited, code=exited, status=131
Feb 21 13:50:41 localhost abrt[1142]: saved core dump of pid 877 (/usr/bin/Xorg) to /var/spool/abrt/ccpp-1298314241-877.new/coredump (5849088 bytes)
Feb 21 13:50:41 localhost abrtd: Directory 'ccpp-1298314241-877' creation detected
Feb 21 13:50:41 localhost abrtd: Registered Database plugin 'SQLite3'
Feb 21 13:50:41 localhost systemd[1]: Unit firstboot-graphical.service entered failed state.
Feb 21 13:50:42 localhost systemd[1]: Startup finished in 904ms 660us (kernel) + 5s 252ms 649us (initrd) + 38s 54ms 516us (userspace) = 44s 211ms 825us.
Feb 21 13:50:42 localhost abrtd: New crash /var/spool/abrt/ccpp-1298314241-877, processing
Feb 21 13:50:42 localhost abrtd: Registered Action plugin 'RunApp'
Feb 21 13:50:42 localhost abrtd: RunApp('/var/spool/abrt/ccpp-1298314241-877','test x"`cat component`" = x"xorg-x11-server-Xorg" && cp /var/log/Xorg.0.log .')


Feb 21 14:11:24 localhost systemd[1]: firstboot-graphical.service: main process exited, code=exited, status=131
Feb 21 14:11:26 localhost abrt[1016]: saved core dump of pid 865 (/usr/bin/Xorg) to /var/spool/abrt/ccpp-1298315485-865.new/coredump (7897088 bytes)
Feb 21 14:11:26 localhost abrtd: Directory 'ccpp-1298315485-865' creation detected
Feb 21 14:11:26 localhost systemd[1]: Unit firstboot-graphical.service entered failed state.
Feb 21 14:11:26 localhost systemd[1]: Startup finished in 900ms 274us (kernel) + 7s 79ms 581us (initrd) + 1min 5s 868ms 285us (userspace) = 1min 13s 848ms 140us.
Feb 21 14:11:26 localhost abrtd: Crash is in database already (dup of /var/spool/abrt/ccpp-1298314241-877)
Feb 21 14:11:26 localhost abrtd: Deleting crash ccpp-1298315485-865 (dup of ccpp-1298314241-877), sending dbus signal
Comment 1 Brian Lane 2011-02-21 14:39:27 EST
Created attachment 479982 [details]
/var/log/messages
Comment 2 Martin Gracik 2011-02-22 03:44:17 EST
So this only happens when firstboot is run as a systemd service during boot. I tried running it in Gnome, and Enter works fine. I tried also killing Xorg, and then running firstboot from vt2 in runlevel 5, and pressing Enter works OK too.

When this happens, abrt says that Xorg was killed with signal 11 (SIGSEGV). I don't know what's causing this. Only thing that comes to my mind is that Xorg needs some other service to be running before we run the firstboot service.

Adam, do you know what can be the problem here?
Comment 3 Martin Gracik 2011-02-23 03:44:16 EST
*** Bug 679348 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2011-02-23 12:48:57 EST
679348, which was marked as a dupe of this, was proposed as F15Alpha, so moving that nomination to this bug.
Comment 5 James Laska 2011-02-23 12:53:28 EST
Patch under review on anaconda-devel-list (see https://www.redhat.com/archives/anaconda-devel-list/2011-February/msg00235.html)
Comment 6 Adam Williamson 2011-02-23 17:38:43 EST
discussed at 2011-02-23 go/no-go meeting: agreed not a blocker as it's eminently workaround-able and if you reboot you get to try again. will document for release.
Comment 7 Martin Gracik 2011-02-24 05:13:30 EST
So I found out firstboot crashes if you press the key "2" on the keyboard, which is not workaround-able (bug #679933). It's caused by the same thing as this "Enter exit", running plymouth. I think it would be nice to have this fix. Who knows what other keys can make firstboot crash or exit.
Comment 8 Adam Williamson 2011-02-24 12:14:17 EST
Yes - since we've already slipped I'd definitely like to take a fix for this into RC2. Proposing NTH.
Comment 9 Bruno Wolff III 2011-02-25 13:18:35 EST
From alpha blocker meeting:
#agreed 679171 accepted as NTH
Comment 10 Adam Williamson 2011-02-25 13:56:39 EST
RC2 will likely get spun tonight (~6hrs from now) so we need a build in and tested by then to make it. bcl will try to get a build done in time.
Comment 11 Fedora Update System 2011-02-25 17:00:42 EST
Package firstboot-1.117-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firstboot-1.117-2.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/firstboot-1.117-2.fc15
then log in and leave karma (feedback).
Comment 12 Adam Williamson 2011-02-25 17:01:48 EST
We really need testing on the fix (from bcl, thanks) in the next few hours. Unfortunately you may need to spin a live image with the fix included to test it properly, but there may be other ways to do it I hadn't thought of yet.
Comment 13 Adam Williamson 2011-02-25 17:04:12 EST
actually, just doing an install and switching to a vt on first boot to install the updated firstboot, then switching back to firstboot and making it crash should work - it will then respawn itself, using the updated version, and you should no longer be able to crash it.
Comment 14 Fedora Update System 2011-02-25 23:39:51 EST
firstboot-1.117-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Adam Williamson 2011-03-07 15:57:49 EST
drop commonbugs, as this was fixed for alpha.

Note You need to log in before you can comment on or make changes to this bug.