Bug 679348 - Firstboot starts but failed to forward on F15-Alpha-TC2
Firstboot starts but failed to forward on F15-Alpha-TC2
Status: CLOSED DUPLICATE of bug 679171
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
15
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15Alpha/F15AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-02-22 05:42 EST by He Rui
Modified: 2013-07-04 08:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-23 03:44:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (257.60 KB, text/plain)
2011-02-22 05:44 EST, He Rui
no flags Details

  None (edit)
Description He Rui 2011-02-22 05:42:29 EST
Description of problem:
Install F15-alpha-tc2 i386 dvd in kvm. After installation and reboot, firstboot welcome page prompted but failed to continue when clicking 'forward'. After clicking, login window prompted with no created user. 

Version-Release number of selected component (if applicable):
firstboot-1.117-1.fc15.i686

How reproducible:
Tried once.

Steps to Reproduce:
1. Graphical install Alpha RC1 i386
2. Reboot and click 'forword' when firstboot window prompted
  
Actual results:
Unable to create user account through firstboot
Comment 1 He Rui 2011-02-22 05:44:38 EST
Created attachment 480100 [details]
/var/log/messages
Comment 2 James Laska 2011-02-22 07:30:50 EST
(In reply to comment #1)
> Created attachment 480100 [details]
> /var/log/messages

Feb 22 17:55:12 localhost systemd[1]: firstboot-graphical.service: main process exited, code=exited, status=131
Feb 22 17:55:14 localhost systemd[1]: Unit firstboot-graphical.service entered failed state.

It looks like firstboot crashed based on the attached /var/log/messages.  Can you reproduce this, and look in /tmp for a firstboot crash file?  It should be named similar to /tmp/firstboot-<random>.  If you find that file, please attach to the bug report.  Thanks!
Comment 3 Martin Gracik 2011-02-22 10:05:23 EST
Actually...

Feb 22 17:55:12 localhost systemd[1]: firstboot-graphical.service: main process exited, code=exited, status=131
Feb 22 17:55:14 localhost abrt[1091]: saved core dump of pid 971 (/usr/bin/Xorg) to /var/spool/abrt/ccpp-1298415313-971.new/coredump (4009984 bytes)
Feb 22 17:55:14 localhost abrtd: Directory 'ccpp-1298415313-971' creation detected
Feb 22 17:55:14 localhost abrtd: Registered Database plugin 'SQLite3'
Feb 22 17:55:14 localhost systemd[1]: Unit firstboot-graphical.service entered failed state.

Xorg under firstboot crashed, but I don't know why. Did you _click_ the Forward button, or did you press Enter? Because I have a similar bug report already.
Comment 4 Adam Williamson 2011-02-22 14:02:49 EST
Discussed with jlaska out-of-meeting-cycle: we think we need more data on this to make a definite call on whether it's a blocker. We need more people to test and see if they hit trouble in firstboot.
Comment 5 James Laska 2011-02-22 15:33:48 EST
(In reply to comment #3)
> Xorg under firstboot crashed, but I don't know why. Did you _click_ the Forward
> button, or did you press Enter? Because I have a similar bug report already.

Oh, also ... can you clarify whether this was against TC2 or RC1?
Comment 6 He Rui 2011-02-23 03:29:03 EST
(In reply to comment #2)
> (In reply to comment #1)
> > Created attachment 480100 [details]
> > /var/log/messages
> 
> Feb 22 17:55:12 localhost systemd[1]: firstboot-graphical.service: main process
> exited, code=exited, status=131
> Feb 22 17:55:14 localhost systemd[1]: Unit firstboot-graphical.service entered
> failed state.
> 
> It looks like firstboot crashed based on the attached /var/log/messages.  Can
> you reproduce this, and look in /tmp for a firstboot crash file?  It should be
> named similar to /tmp/firstboot-<random>.  If you find that file, please attach
> to the bug report.  Thanks!

There's no firstboot* file under /tmp.
Comment 7 He Rui 2011-02-23 03:34:42 EST
(In reply to comment #3)
> Actually...
> 
> Feb 22 17:55:12 localhost systemd[1]: firstboot-graphical.service: main process
> exited, code=exited, status=131
> Feb 22 17:55:14 localhost abrt[1091]: saved core dump of pid 971
> (/usr/bin/Xorg) to /var/spool/abrt/ccpp-1298415313-971.new/coredump (4009984
> bytes)
> Feb 22 17:55:14 localhost abrtd: Directory 'ccpp-1298415313-971' creation
> detected
> Feb 22 17:55:14 localhost abrtd: Registered Database plugin 'SQLite3'
> Feb 22 17:55:14 localhost systemd[1]: Unit firstboot-graphical.service entered
> failed state.
> 
> Xorg under firstboot crashed, but I don't know why. Did you _click_ the Forward
> button, or did you press Enter? Because I have a similar bug report already.

I retested today, it's triggered by pressing *Enter* to the Forward button, clicking it can go forward.
Comment 8 Martin Gracik 2011-02-23 03:44:16 EST

*** This bug has been marked as a duplicate of bug 679171 ***
Comment 9 He Rui 2011-02-23 06:17:23 EST
(In reply to comment #5)
> (In reply to comment #3)
> > Xorg under firstboot crashed, but I don't know why. Did you _click_ the Forward
> > button, or did you press Enter? Because I have a similar bug report already.
> 
> Oh, also ... can you clarify whether this was against TC2 or RC1?

Firstboot wouldn't start automatically on TC2, but when I updated firstboot and made it run on TC2, this issue still happen.

Note You need to log in before you can comment on or make changes to this bug.