Bug 67955 - system tray should be invisible when empty
system tray should be invisible when empty
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: MoveUpstream, Triaged
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-07-04 15:52 EDT by Brent Fox
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 09:53:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brent Fox 2002-07-04 15:52:08 EDT
This is with Limbo-re0701.1.

With a fresh install, the system tray on the panel is empty.  You can still see
the little grippy thing, and it looks like something should be there but it's
not.  It seems that either something should always be in the system tray (like
the rhn_applet), or the systray should be invisible when it is empty.
Comment 1 Havoc Pennington 2002-07-14 23:42:03 EDT
Yeah it's a bit dumb looking. Need a solution. Garrett's mockup had some ideas iirc.
Comment 2 Jonathan Blandford 2002-08-27 21:36:14 EDT
I don't think that hiding it is such a good idea.  There's no way to remove it,
in that case.  Adding a new one looks like you've done a no-op.  Additionally,
we should have something there by default when you start up, so it won't be a
complete surprise.  I'd rather improve the default appearance, rather then hide it.
Comment 3 Brent Fox 2002-10-16 17:31:10 EDT
jrb, yeah that sounds like the right thing to do.  maybe make the background a
slightly different color so that it looks like an empty tray instead of just a
grippy floating along with nothing beside it?  

Of course, now that the applet appears properly, there's something in the panel
by default now.

garrett, any ideas?
Comment 4 Brent Fox 2003-05-28 16:33:43 EDT
garrett: any thoughts here?
Comment 5 Havoc Pennington 2003-08-06 17:34:35 EDT
I just thought of how we should do it:

 - the panel just has the tray built in
 - when there are no icons the tray vanishes
 - when there are icons it reappears
 - when it's visible you can move it
 - whenever it reappears it comes back where it was last 
   time

Needs to be done upstream though since it changes a bunch of stuff.
Comment 6 Garrett LeSage 2003-08-06 17:59:15 EDT
Sounds good to me.
Comment 7 Leonard den Ottolander 2004-02-26 07:09:04 EST
Is this still an issue? Does it need to be fixed?
Comment 8 Mark McLoughlin 2004-02-27 09:53:05 EST
Okay, moved this upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=135603

Note You need to log in before you can comment on or make changes to this bug.