Bug 680037 - [Calistoga] Xorg is killed when second monitor is connected
[Calistoga] Xorg is killed when second monitor is connected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
15
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 01:52 EST by Jaroslav Pulchart
Modified: 2011-08-16 08:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-16 08:49:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (44.47 KB, text/plain)
2011-02-24 01:53 EST, Jaroslav Pulchart
no flags Details
logs.tar (130.00 KB, application/x-tar)
2011-03-10 12:52 EST, Jaroslav Pulchart
no flags Details
dmesg.log from the archive (76.67 KB, text/plain)
2011-03-12 11:28 EST, Matěj Cepl
no flags Details
lspci.log from the archive (5.91 KB, text/plain)
2011-03-12 11:29 EST, Matěj Cepl
no flags Details
Xorg.0.log from the archive (39.63 KB, text/plain)
2011-03-12 11:29 EST, Matěj Cepl
no flags Details

  None (edit)
Description Jaroslav Pulchart 2011-02-24 01:52:48 EST
Description of problem:
Test Case https://fedoraproject.org/wiki/QA:Testcase_intelvideo_multihead from https://fedoraproject.org/wiki/Test_Day:2011-02-24_Intel

Steps to Reproduce:
1. login to Gnome 3 Shell
2. connect second monitor, do some work ...
3. disconnect second monitor
4. connect second monitor again
  
Actual results:
session is killed

Expected results:
working session

Additional Info: http://www.smolts.org/client/show/pub_8fd32f78-e42c-4df8-9a47-97f1b2558519
Comment 1 Jaroslav Pulchart 2011-02-24 01:53:55 EST
Created attachment 480668 [details]
Xorg.0.log
Comment 2 Matěj Cepl 2011-03-10 05:13:42 EST
Could we get also output of the dmesg command after this happens (bug before reboot obviously), please?

Thank you
Comment 3 Jaroslav Pulchart 2011-03-10 12:52:34 EST
Created attachment 483526 [details]
logs.tar

~/Desktop/dmesg.log
~/Desktop/lspci.log
~/Desktop/Xorg.0.log
Comment 4 Jaroslav Pulchart 2011-03-10 15:09:02 EST
Xorg.log:
...
[   575.679] (WW) intel(0): Failed to set tiling on frontbuffer.
[   575.679] (II) intel(0): Allocated new frame buffer 2944x1200 stride 11776, untiled

dmesg:
[  576.022086] mutter[1614]: segfault at 0 ip 0152634d sp bfc01a00 error 4 in i915_dri.so[14ed000+333000]

Xorg.log:
[   576.195] (II) intel(0): EDID vendor "HSD", prod id 1001
[   576.195] (II) intel(0): DDCModeFromDetailedTiming: 1024x600 Warning: We only handle separate sync.
[   576.195] (II) intel(0): Printing DDC gathered Modelines:
[   576.195] (II) intel(0): Modeline "1024x600"x0.0   45.00  1024 1077 1112 1200  600 604 609 625 -hsync -vsync (37.5 kHz)
[   576.195] (II) intel(0): Modeline "1024x600"x0.0   51.42  1024 1117 1152 1240  600 617 622 638 -hsync -vsync (41.5 kHz)
[   577.620] 
Backtrace:
[   577.963] 0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e850c]
[   577.963] 1: /usr/bin/Xorg (0x8048000+0x5ec63) [0x80a6c63]
[   577.963] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0x83140c]
[   577.963] 3: /usr/lib/xorg/modules/extensions/libglx.so (0x56f000+0x35a5e) [0x5a4a5e]
[   577.963] 4: /usr/bin/Xorg (FreeClientResources+0xd9) [0x8090259]
[   577.964] 5: /usr/bin/Xorg (CloseDownClient+0x6a) [0x807030a]
[   577.964] 6: /usr/bin/Xorg (0x8048000+0x2856c) [0x807056c]
[   577.964] 7: /usr/bin/Xorg (0x8048000+0x28e47) [0x8070e47]
[   577.964] 8: /usr/bin/Xorg (0x8048000+0x1bf7a) [0x8063f7a]
[   577.964] 9: /lib/libc.so.6 (__libc_start_main+0xf3) [0x375413]
[   577.964] 10: /usr/bin/Xorg (0x8048000+0x1c291) [0x8064291]
[   577.965] Segmentation fault at address 0x3ff6
[   577.965] 
Fatal server error:
[   577.965] Caught signal 11 (Segmentation fault). Server aborting
Comment 5 Matěj Cepl 2011-03-12 11:28:49 EST
Created attachment 483913 [details]
dmesg.log from the archive
Comment 6 Matěj Cepl 2011-03-12 11:29:00 EST
Created attachment 483914 [details]
lspci.log from the archive
Comment 7 Matěj Cepl 2011-03-12 11:29:08 EST
Created attachment 483915 [details]
Xorg.0.log from the archive
Comment 8 Matěj Cepl 2011-03-12 11:45:15 EST
Seems similar to bug 680828 and bug 672842
Comment 9 Jaroslav Pulchart 2011-08-16 08:49:10 EDT
I cannot reproduce this issue now :).

Kernel 2.6.40-4
xorg-x11-drv-intel-2.15.0-5
xorg-x11-server-Xorg-1.10.3-1

Note You need to log in before you can comment on or make changes to this bug.