Bug 680129 - LVM installation traceback
LVM installation traceback
Status: CLOSED DUPLICATE of bug 677571
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 07:52 EST by Jakub Hrozek
Modified: 2011-02-24 09:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-24 09:56:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacoda.log (8.46 KB, text/x-log)
2011-02-24 07:52 EST, Jakub Hrozek
no flags Details

  None (edit)
Description Jakub Hrozek 2011-02-24 07:52:51 EST
Created attachment 480743 [details]
anacoda.log

Description of problem:
My kickstart includes the following partitioning schema:
---
part /boot --fstype ext3 --size=150
part pv.01 --size=1024 --grow
volgroup vg_root pv.01
logvol  /  --vgname=vg_root  --size=1024 --grow  --name=lv_root
---

This had worked OK in Fedoras up to 14. In F-15, I get the following traceback:
----
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 494, in execute
    label=self.label,
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1208, in execute
    obj.execute()
  File "/usr/sbin/anaconda", line 915, in <module>
    anaconda.ksdata.execute()
AttributeError: 'LogVolData' object has no attribute 'label'
----

Version-Release number of selected component (if applicable):
15.20

How reproducible:
install with a KS using the above partitioning

Full anaconda.log is attached.
Comment 1 Chris Lumens 2011-02-24 09:56:16 EST

*** This bug has been marked as a duplicate of bug 677571 ***

Note You need to log in before you can comment on or make changes to this bug.