Bug 677571 - kickstart.py: 'LogVolData' object has no attribute 'label'
kickstart.py: 'LogVolData' object has no attribute 'label'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
15
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
anaconda_trace_hash:bf1cbe9ae098b4017...
:
: 680129 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-15 04:31 EST by Ales Kozumplik
Modified: 2014-09-30 19:39 EDT (History)
8 users (show)

See Also:
Fixed In Version: pykickstart-1.82-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-11 01:10:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (173.97 KB, text/plain)
2011-02-15 04:31 EST, Ales Kozumplik
no flags Details
my kickstart (1.08 KB, text/plain)
2011-02-15 04:36 EST, Ales Kozumplik
no flags Details
Attached traceback automatically from anaconda. (161.42 KB, text/plain)
2011-02-17 11:14 EST, James Laska
no flags Details

  None (edit)
Description Ales Kozumplik 2011-02-15 04:31:16 EST
The following was filed automatically by anaconda:
anaconda 15.20 exception report
Traceback (most recent call first):
  File "/tmp/updates/pyanaconda/kickstart.py", line 494, in execute
    label=self.label,
  File "/tmp/updates/pyanaconda/kickstart.py", line 1208, in execute
    obj.execute()
  File "/tmp/updates/anaconda", line 915, in <module>
    anaconda.ksdata.execute()
AttributeError: 'LogVolData' object has no attribute 'label'
Comment 1 Ales Kozumplik 2011-02-15 04:31:21 EST
Created attachment 478820 [details]
Attached traceback automatically from anaconda.
Comment 2 Ales Kozumplik 2011-02-15 04:36:10 EST
Created attachment 478822 [details]
my kickstart
Comment 3 James Laska 2011-02-17 11:14:55 EST
Created attachment 479361 [details]
Attached traceback automatically from anaconda.
Comment 4 James Laska 2011-02-17 11:15:57 EST
My reproducer was to install F14, then re-use /root/anaconda-ks.cfg for a F-15 install
Comment 5 Michael Young 2011-02-22 09:30:20 EST
Could we have pykickstart-1.82-1 for F15 please? Currently there is only a post-fork rawhide/F16 version.
Comment 6 Fedora Update System 2011-02-23 11:29:45 EST
pykickstart-1.82-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/pykickstart-1.82-1.fc15
Comment 7 Fedora Update System 2011-02-23 15:28:35 EST
pykickstart-1.82-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pykickstart'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/pykickstart-1.82-1.fc15
Comment 8 Chris Lumens 2011-02-24 09:56:16 EST
*** Bug 680129 has been marked as a duplicate of this bug. ***
Comment 9 James Laska 2011-03-07 14:24:28 EST
(In reply to comment #5)
> Could we have pykickstart-1.82-1 for F15 please? Currently there is only a
> post-fork rawhide/F16 version.

Greetings Michael, an updated pykickstart package is available for Fedora 15, but requires additional Karma.  Can you add your feedback to the update?

https://admin.fedoraproject.org/updates/pykickstart-1.82-1.fc15
Comment 10 Adam Williamson 2011-03-07 14:54:28 EST
jlaska: I note you didn't put any karma on it yet :)
Comment 11 James Laska 2011-03-07 15:32:27 EST
(In reply to comment #10)
> jlaska: I note you didn't put any karma on it yet :)

Geez, just can't sneak one by ya :)   

After discussing with clumens, it seems that this is more than just install the update and apply Karma.  I am rebuilding installation media with the updated pykickstart and will post them for testing.
Comment 12 James Laska 2011-03-07 16:17:49 EST
I built updated pxeboot images using the newest pykickstart package (pykickstart-1.82-1.fc15).  Kernel and initrd.img are available at http://jlaska.fedorapeople.org/updates/F-15-Alpha-677571

Using those images, I'm still seeing the reported problem using the procedure noted in comment#4.  Talking to clumens, it seems a one-line fix will also be needed in anaconda.
Comment 13 Chris Lumens 2011-03-07 16:29:23 EST
You can use updates=http://clumens.fedorapeople.org/677571.img to check the kickstart.py portion.
Comment 14 James Laska 2011-03-07 16:36:18 EST
(In reply to comment #13)
> You can use updates=http://clumens.fedorapeople.org/677571.img to check the
> kickstart.py portion.

Confirmed that the issue is fixed using the updates.img provided and the custom kernel+initrd.img images from comment#12.

I'll give karma for pykickstart based on this and other pykickstart testing.
Comment 15 Michael Young 2011-03-08 05:40:26 EST
It works for me (until I hit bug 680490) with the new pykickstart.py file added to my own updates.img file (which I had constructed earlier from the new pykickstart-1.82-1.fc15 package but hadn't got working).

I have given it some karma.
Comment 16 Fedora Update System 2011-03-11 01:09:56 EST
pykickstart-1.82-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.