This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 680162 - guest migrations fail
guest migrations fail
Status: CLOSED DUPLICATE of bug 615941
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.3
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 09:13 EST by Ivars Strazdins
Modified: 2011-03-16 03:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 03:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivars Strazdins 2011-02-24 09:13:14 EST
Description of problem:

Cannot migrate virtual machines.

Version-Release number of selected component (if applicable):

[root@rhel6-1 ~]# rpm -qa | grep -E "virt|kvm"
qemu-kvm-tools-0.12.1.2-2.113.el6_0.6.x86_64
fence-virt-0.2.1-5.el6.x86_64
virt-manager-0.8.4-8.el6.noarch
python-virtinst-0.500.3-7.el6.noarch
libvirt-0.8.1-27.el6.x86_64
libvirt-client-0.8.1-27.el6.x86_64
virt-viewer-0.2.1-2.el6.x86_64
virt-top-1.0.4-3.1.el6.x86_64
qemu-kvm-0.12.1.2-2.113.el6_0.6.x86_64
libvirt-python-0.8.1-27.el6.x86_64

How reproducible:

Always.

Steps to Reproduce:

1. Create virtual machine, Linux
2. Connect to another host with virt-manager
2. Try to migrate to another host.
  
Actual results:


Unable to migrate guest:
 Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/migrate.py", line 457, in _async_migrate
    vm.migrate(dstconn, migrate_uri, rate, live, secure)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1387, in migrate
    self._backend.migrate(destconn.vmm, flags, newname, interface, rate)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 511, in migrate
    if ret is None:raise libvirtError('virDomainMigrate() failed', dom=self)
libvirtError: operation failed: Migration unexpectedly failed


Expected results:

No errors, be able to migrate.

Additional info:

Both systems were really identical, the same machine model, same bios revision, same software. CPU type  AMD Turion(tm) 64 X2 Mobile Technology TL-50
Found bug  654593 (Fedora 14) with exactly the same messages.
Comment 1 Ivars Strazdins 2011-02-24 09:17:07 EST
/var/log/messages entries (with libvirt debug enabled)

source host:
Feb 24 16:14:52 rhel6-2 libvirtd: 16:14:52.089: error : qemuDomainWaitForMigrationComplete:5394 : operation failed: Migration unexpectedly failed

destination host:

Feb 24 16:14:51 rhel6-1 libvirtd: 16:14:51.406: info : qemuSecurityDACSetOwnership:40 : Setting DAC user and group on '/VMs/debian6.img' to '107:107'
Feb 24 16:14:51 rhel6-1 libvirtd: 16:14:51.418: info : SELinuxSetFilecon:321 : Setting SELinux context on '/VMs/debian6.img' to 'system_u:object_r:svirt_image_t:s0:c286,c655'
Feb 24 16:14:51 rhel6-1 libvirtd: 16:14:51.427: info : SELinuxSetFilecon:349 : Setting security context 'system_u:object_r:svirt_image_t:s0:c286,c655' on '/VMs/debian6.img' not supported
Feb 24 16:14:51 rhel6-1 libvirtd: 16:14:51.496: info : qemudDispatchSignalEvent:397 : Received unexpected signal 17
Feb 24 16:14:51 rhel6-1 libvirtd: 16:14:51.561: info : qemudDispatchSignalEvent:397 : Received unexpected signal 17
Feb 24 16:14:51 rhel6-1 kernel: device vnet0 entered promiscuous mode
Feb 24 16:14:51 rhel6-1 kernel: br0: port 2(vnet0) entering forwarding state
Feb 24 16:14:51 rhel6-1 libvirtd: 16:14:51.673: info : qemudDispatchSignalEvent:397 : Received unexpected signal 17
Feb 24 16:14:51 rhel6-1 libvirtd: 16:14:51.719: info : udevGetDeviceProperty:116 : udev reports device 'vnet0' does not have property 'DRIVER'
Feb 24 16:14:51 rhel6-1 libvirtd: 16:14:51.719: info : udevGetDeviceProperty:116 : udev reports device 'vnet0' does not have property 'PCI_CLASS'
Feb 24 16:14:52 rhel6-1 kernel: br0: port 2(vnet0) entering disabled state
Feb 24 16:14:52 rhel6-1 kernel: device vnet0 left promiscuous mode
Feb 24 16:14:52 rhel6-1 kernel: br0: port 2(vnet0) entering disabled state


[root@rhel6-1 log]# grep 107 /etc/passwd
qemu:x:107:107:qemu user:/:/sbin/nologin
[root@rhel6-1 log]# 

[root@rhel6-2 log]# grep 107 /etc/passwd
qemu:x:107:107:qemu user:/:/sbin/nologin
[root@rhel6-2 log]#
Comment 2 Ivars Strazdins 2011-02-24 09:18:55 EST
Completely forgot to mention that shared storage is NFS.
Comment 4 Ivars Strazdins 2011-02-24 15:20:15 EST
After disabling firewall, problem disappeared.
Comment 5 Osier Yang 2011-03-16 03:24:46 EDT
see bug https://bugzilla.redhat.com/show_bug.cgi?id=615941, and https://bugzilla.redhat.com/show_bug.cgi?id=670727, the problem for this bug
is to say libvirt can't give a clear error message, so I duplicate it with 615941

*** This bug has been marked as a duplicate of bug 615941 ***

Note You need to log in before you can comment on or make changes to this bug.