Bug 680252 - [abrt] mutter-2.91.90-1.fc15: strcmp: Process /usr/bin/mutter was killed by signal 11 (SIGSEGV)
[abrt] mutter-2.91.90-1.fc15: strcmp: Process /usr/bin/mutter was killed by s...
Status: CLOSED DUPLICATE of bug 684992
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
abrt_hash:ce6484eb28fc53f72c887589561...
:
Depends On:
Blocks: F15GNOMEfail
  Show dependency treegraph
 
Reported: 2011-02-24 14:54 EST by Bill Nottingham
Modified: 2014-03-16 23:26 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-26 12:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (102.96 KB, text/plain)
2011-02-24 14:54 EST, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2011-02-24 14:54:35 EST
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 105426 bytes
cmdline: mutter --mutter-plugins=libgnome-shell
component: mutter
Attached file: coredump, 364511232 bytes
crash_function: strcmp
executable: /usr/bin/mutter
kernel: 2.6.37-2.fc15.x86_64
package: mutter-2.91.90-1.fc15
rating: 4
reason: Process /usr/bin/mutter was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
time: 1298577006
uid: 2166

comment
-----
Assorted messages in the log:

Window manager warning: Log level 16: invalid uninstantiatable type `(null)' in cast to `GObject'
Window manager warning: Log level 8: g_object_get_data: assertion `G_IS_OBJECT (object)' failed
Window manager warning: Log level 8: g_ascii_strncasecmp: assertion `s2 != NULL' failed
** Message: applet now removed from the notification area
GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
Shell killed with signal 11

How to reproduce
-----
1. I was logging into fedorahosted trac
2. I submitted the user/password dialog
3. It closed
4. shell crashed
Comment 1 Bill Nottingham 2011-02-24 14:54:37 EST
Created attachment 480850 [details]
File: backtrace
Comment 2 Matěj Cepl 2011-02-25 02:15:11 EST
Package: mutter-2.91.90-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. no idea, just browsing with firefox
2.
3.
Comment 3 P. A. López-Valencia 2011-02-27 09:37:20 EST
Package: mutter-2.91.90-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
Crash happened while executing PackageKit-gstreamer-plugin
Comment 4 Colin Walters 2011-02-28 14:27:08 EST
This looks like a pretty generic reference-counting error; since gdb doesn't know how to walk the SpiderMonkey stack, a lot of bugs are going to get dup'd against this one.
Comment 5 Bill Nottingham 2011-02-28 17:22:39 EST
Full backtrace:

Thread 6 (Thread 0x7fd3e30e3700 (LWP 25011)):
#0  0x00000033000d74b3 in __poll (fds=<optimized out>, nfds=<optimized out>, 
    timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003f96642fd4 in g_main_context_poll (n_fds=5, fds=0x17b2a00, timeout=
    -1, context=0xe81c60, priority=<optimized out>) at gmain.c:3404
#2  g_main_context_iterate (context=0xe81c60, block=<optimized out>, dispatch=
    1, self=<optimized out>) at gmain.c:3086
#3  0x0000003f966438ba in g_main_loop_run (loop=0xe848b0) at gmain.c:3299
#4  0x0000003f986b4604 in gdbus_shared_thread_func (data=<optimized out>)
    at gdbusprivate.c:276
#5  0x0000003f96668664 in g_thread_create_proxy (data=0xe81d50)
    at gthread.c:1897
#6  0x0000003300807d0b in start_thread (arg=0x7fd3e30e3700)
    at pthread_create.c:301
#7  0x00000033000dfd3d in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7fd3dfe85700 (LWP 25032)):
#0  0x00000033000d74b3 in __poll (fds=<optimized out>, nfds=<optimized out>, 
    timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003f96642fd4 in g_main_context_poll (n_fds=1, fds=0xe72fd0, timeout=
    -1, context=0x125a320, priority=<optimized out>) at gmain.c:3404
#2  g_main_context_iterate (context=0x125a320, block=<optimized out>, dispatch=
    1, self=<optimized out>) at gmain.c:3086
#3  0x0000003f966438ba in g_main_loop_run (loop=0x124b900) at gmain.c:3299
#4  0x00007fd3dfe8a60b in ?? () from /usr/lib64/gio/modules/libdconfsettings.so
#5  0x0000003f96668664 in g_thread_create_proxy (data=0x125a260)
    at gthread.c:1897
#6  0x0000003300807d0b in start_thread (arg=0x7fd3dfe85700)
    at pthread_create.c:301
#7  0x00000033000dfd3d in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7fd3df226700 (LWP 25034)):
#0  pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x000000330d8230d0 in PR_WaitCondVar (cvar=0x13c82b0, timeout=4294967295)
    at ../../../mozilla/nsprpub/pr/src/pthreads/ptsynch.c:417
#2  0x00007fd3e1f79a37 in threadLoop (rt=0x136be30, this=0x136c0a0)
    at jsgc.cpp:2092
#3  js::GCHelperThread::threadMain (arg=0x136be30) at jsgc.cpp:2078
#4  0x000000330d828443 in _pt_root (arg=0x13c8350)
    at ../../../mozilla/nsprpub/pr/src/pthreads/ptthread.c:187
#5  0x0000003300807d0b in start_thread (arg=0x7fd3df226700)
    at pthread_create.c:301
#6  0x00000033000dfd3d in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fd3da2d8700 (LWP 25036)):
#0  0x00000033000d74b3 in __poll (fds=<optimized out>, nfds=<optimized out>, 
    timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003e2c82c05f in poll_func (ufds=0x14491c0, nfds=2, timeout=-1, 
    userdata=0x1441d10) at pulse/thread-mainloop.c:75
#2  0x0000003e2c81dee6 in pa_mainloop_poll (m=0x1441c00)
    at pulse/mainloop.c:879
#3  0x0000003e2c81e519 in pa_mainloop_iterate (m=0x1441c00, 
    block=<optimized out>, retval=0x0) at pulse/mainloop.c:961
#4  0x0000003e2c81e5d0 in pa_mainloop_run (m=0x1441c00, retval=0x0)
    at pulse/mainloop.c:979
#5  0x0000003e2c82c00f in thread (userdata=0x1443150)
    at pulse/thread-mainloop.c:94
#6  0x0000003e2c0387a8 in internal_thread_func (userdata=0x1443ea0)
    at pulsecore/thread-posix.c:83
#7  0x0000003300807d0b in start_thread (arg=0x7fd3da2d8700)
    at pthread_create.c:301
#8  0x00000033000dfd3d in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fd3c9d6f700 (LWP 25148)):
#0  0x000000330080e60d in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x0000003f9664492b in read (__nbytes=20, __buf=0x7fd3c9d6ebb0, 
    __fd=<optimized out>) at /usr/include/bits/unistd.h:45
#2  child_watch_helper_thread (data=<optimized out>) at gmain.c:4294
#3  0x0000003f96668664 in g_thread_create_proxy (data=0x1dabdc0)
    at gthread.c:1897
#4  0x0000003300807d0b in start_thread (arg=0x7fd3c9d6f700)
    at pthread_create.c:301
#5  0x00000033000dfd3d in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fd3eab4a9c0 (LWP 25010)):
#0  0x00007fd3d96a75e3 in gjs_object_from_g_object (context=0x13d1820, gobj=
    0x27e8fd0) at gi/object.c:1531
#1  0x00007fd3d969ef65 in gjs_value_from_g_argument (context=0x13d1820, 
    value_p=0x7fff112ae010, type_info=<optimized out>, arg=0x7fff112ae240)
    at gi/arg.c:1840
#2  0x00007fd3d96a3def in gjs_invoke_c_function (context=0x13d1820, function=
    0x1c144f0, obj=0x7fd3c47f5a00, js_argc=<optimized out>, js_argv=
    0x7fd3de605648, js_rval=0x7fff112ae2a8) at gi/function.c:651
#3  0x00007fd3d96a4510 in function_call (context=0x13d1820, js_argc=0, 
    vp=<optimized out>) at gi/function.c:873
#4  0x00007fd3e1f95824 in CallJSNative (vp=<optimized out>, 
    argc=<optimized out>, native=<optimized out>, cx=0x13d1820)
    at jscntxtinlines.h:697
#5  js::Invoke (cx=0x13d1820, argsRef=<optimized out>, flags=<optimized out>)
    at jsinterp.cpp:697
#6  0x00007fd3e1f84ab2 in js::Interpret (cx=0x13d1820, entryFrame=
    0x7fd3de6055d8, inlineCallCount=0, interpMode=JSINTERP_NORMAL)
    at jsinterp.cpp:4795
#7  0x00007fd3e1f952d3 in js::RunScript (cx=0x13d1820, script=<optimized out>, 
    fp=0x7fd3de6055d8) at jsinterp.cpp:661
#8  0x00007fd3e1f95622 in js::Invoke (cx=0x13d1820, argsRef=<optimized out>, 
    flags=<optimized out>) at jsinterp.cpp:741
#9  0x00007fd3e1f69e41 in js_fun_apply (cx=0x13d1820, argc=<optimized out>, vp=
    0x7fd3de605598) at jsfun.cpp:2188
#10 0x00007fd3e1f8deaf in CallJSNative (vp=0x7fd3de605598, argc=2, 
    native=<optimized out>, cx=0x13d1820) at jscntxtinlines.h:697
#11 js::Interpret (cx=0x13d1820, entryFrame=0x7fd3de605540, inlineCallCount=0, 
    interpMode=JSINTERP_NORMAL) at jsinterp.cpp:4784
#12 0x00007fd3e1f952d3 in js::RunScript (cx=0x13d1820, script=<optimized out>, 
    fp=0x7fd3de605540) at jsinterp.cpp:661
#13 0x00007fd3e1f95622 in js::Invoke (cx=0x13d1820, argsRef=<optimized out>, 
    flags=<optimized out>) at jsinterp.cpp:741
#14 0x00007fd3e1f69e41 in js_fun_apply (cx=0x13d1820, argc=<optimized out>, vp=
    0x7fd3de6054f0) at jsfun.cpp:2188
#15 0x00007fd3e1f8deaf in CallJSNative (vp=0x7fd3de6054f0, argc=2, 
    native=<optimized out>, cx=0x13d1820) at jscntxtinlines.h:697
#16 js::Interpret (cx=0x13d1820, entryFrame=0x7fd3de6052c0, inlineCallCount=3, 
    interpMode=JSINTERP_NORMAL) at jsinterp.cpp:4784
#17 0x00007fd3e1f952d3 in js::RunScript (cx=0x13d1820, script=<optimized out>, 
    fp=0x7fd3de6052c0) at jsinterp.cpp:661
#18 0x00007fd3e1f95622 in js::Invoke (cx=0x13d1820, argsRef=<optimized out>, 
    flags=<optimized out>) at jsinterp.cpp:741
#19 0x00007fd3e1f69e41 in js_fun_apply (cx=0x13d1820, argc=<optimized out>, vp=
    0x7fd3de605278) at jsfun.cpp:2188
#20 0x00007fd3e1f8deaf in CallJSNative (vp=0x7fd3de605278, argc=2, 
    native=<optimized out>, cx=0x13d1820) at jscntxtinlines.h:697
#21 js::Interpret (cx=0x13d1820, entryFrame=0x7fd3de605108, inlineCallCount=2, 
    interpMode=JSINTERP_NORMAL) at jsinterp.cpp:4784
#22 0x00007fd3e1f952d3 in js::RunScript (cx=0x13d1820, script=<optimized out>, 
    fp=0x7fd3de605108) at jsinterp.cpp:661
#23 0x00007fd3e1f95622 in js::Invoke (cx=0x13d1820, argsRef=<optimized out>, 
    flags=<optimized out>) at jsinterp.cpp:741
#24 0x00007fd3e1f69e41 in js_fun_apply (cx=0x13d1820, argc=<optimized out>, vp=
    0x7fd3de6050c8) at jsfun.cpp:2188
#25 0x00007fd3e1f8deaf in CallJSNative (vp=0x7fd3de6050c8, argc=2, 
    native=<optimized out>, cx=0x13d1820) at jscntxtinlines.h:697
#26 js::Interpret (cx=0x13d1820, entryFrame=0x7fd3de605068, inlineCallCount=0, 
    interpMode=JSINTERP_NORMAL) at jsinterp.cpp:4784
#27 0x00007fd3e1f952d3 in js::RunScript (cx=0x13d1820, script=<optimized out>, 
    fp=0x7fd3de605068) at jsinterp.cpp:661
#28 0x00007fd3e1f95622 in js::Invoke (cx=0x13d1820, argsRef=<optimized out>, 
    flags=<optimized out>) at jsinterp.cpp:741
#29 0x00007fd3e1f963d3 in js::ExternalInvoke (cx=0x13d1820, thisv=..., fval=
    ..., argc=2, argv=0x7fff112b0560, rval=0x7fff112b05f0) at jsinterp.cpp:862
#30 0x00007fd3e1f13551 in JS_CallFunctionValue (cx=0x13d1820, 
    obj=<optimized out>, fval=18445617984259937136, argc=<optimized out>, 
    argv=<optimized out>, rval=<optimized out>) at jsapi.cpp:5053
#31 0x00007fd3e242f28c in gjs_call_function_value (context=0x13d1820, obj=0x0, 
    fval=18445617984259937136, argc=2, argv=<optimized out>, 
    rval=<optimized out>) at gjs/jsapi-util.c:1151
#32 0x00007fd3d96a20dd in gjs_closure_invoke (closure=0x1640780, argc=2, argv=
    0x7fff112b0560, retval=0x7fff112b05f0) at gi/closure.c:267
#33 0x00007fd3d96aaf09 in closure_marshal (closure=0x1640780, return_value=
    0x0, n_param_values=2, param_values=0x5a2fad0, 
    invocation_hint=<optimized out>, marshal_data=<optimized out>)
    at gi/value.c:128
#34 0x0000003f97e0e2de in g_closure_invoke (closure=0x1640780, return_value=
    0x0, n_param_values=2, param_values=0x5a2fad0, invocation_hint=
    0x7fff112b0770) at gclosure.c:767
#35 0x0000003f97e1eeeb in signal_emit_unlocked_R (node=<optimized out>, detail=
    0, instance=0x1341640, emission_return=0x0, instance_and_params=0x5a2fad0)
    at gsignal.c:3252
#36 0x0000003f97e288ea in g_signal_emit_valist (instance=<optimized out>, 
    signal_id=<optimized out>, detail=<optimized out>, 
    var_args=<optimized out>) at gsignal.c:2983
#37 0x0000003f97e28a92 in g_signal_emit (instance=<optimized out>, 
    signal_id=<optimized out>, detail=<optimized out>) at gsignal.c:3040
#38 0x0000003e298af122 in emit_frame_signal (timeline=
    0x1341640 [ClutterTimeline]) at ./clutter-timeline.c:553
#39 clutter_timeline_do_frame (timeline=0x1341640 [ClutterTimeline])
    at ./clutter-timeline.c:615
#40 0x0000003e29881600 in _clutter_master_clock_advance (master_clock=
    0xe6b0c0 [ClutterMasterClock]) at ./clutter-master-clock.c:563
#41 0x0000003e298816e8 in clutter_clock_dispatch (source=<optimized out>, 
    callback=<optimized out>, user_data=<optimized out>)
    at ./clutter-master-clock.c:365
#42 0x0000003f96642a9d in g_main_dispatch (context=0xe4b300) at gmain.c:2440
#43 g_main_context_dispatch (context=0xe4b300) at gmain.c:3013
#44 0x0000003f96643278 in g_main_context_iterate (context=0xe4b300, 
    block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3091
#45 0x0000003f966438ba in g_main_loop_run (loop=0xe53360) at gmain.c:3299
#46 0x0000000000421589 in main (argc=1, argv=0x7fff112b12b8) at core/main.c:707
(gdb) 

GJS backtrace:

== Stack trace for context 0x13544a0 ==
0 anonymous(actor = [0x2c040e0 MetaWindowActor], shellwm = [object instance proxy GIName:Shell.WM jsobj@0x7fd3de5f3630 native@0x14420a0]) ["/usr/share/gnome-shell/js/ui/windowManager.js":404]
1 anonymous([object instance proxy GIName:Shell.WM jsobj@0x7fd3de5f3630 native@0x14420a0], [0x2c040e0 MetaWindowActor]) ["/usr/share/gnome-shell/js/ui/tweener.js":108]
2 _callOnFunction(params = [object instance proxy GIName:Shell.WM jsobj@0x7fd3de5f3630 native@0x14420a0],[0x2c040e0 MetaWindowActor], fallbackScope = [0x2c040e0 MetaWindowActor], scope = [object Object], fnname = "onComplete", fn = [function]) ["/usr/share/gjs-1.0/tweener/tweener.js":202]
3 _updateTweenByIndex(i = 0) ["/usr/share/gjs-1.0/tweener/tweener.js":332]
4 _updateTweens() ["/usr/share/gjs-1.0/tweener/tweener.js":344]
5 _onEnterFrame([object Object]) ["/usr/share/gjs-1.0/tweener/tweener.js":359]
6 _emit(name = "prepare-frame") ["/usr/share/gjs-1.0/signals.js":124]
7 anonymous(frame = 252) ["/usr/share/gnome-shell/js/ui/tweener.js":244]
8 anonymous(frame = 252, timeline = [object instance proxy GIName:Clutter.Timeline jsobj@0x7fd3de5f00d0 native@0x1341640]) ["/usr/share/gnome-shell/js/ui/tweener.js":220]
9 anonymous([object instance proxy GIName:Clutter.Timeline jsobj@0x7fd3de5f00d0 native@0x1341640], 252) ["/usr/share/gjs-1.0/lang.js":110]
Comment 6 Owen Taylor 2011-03-26 12:56:26 EDT

*** This bug has been marked as a duplicate of bug 684992 ***

Note You need to log in before you can comment on or make changes to this bug.