Bug 68058 - System locks up when playing video file
System locks up when playing video file
Status: CLOSED DUPLICATE of bug 68668
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
limbo
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-05 18:07 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-19 03:45:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/XF86Config (12.46 KB, text/plain)
2002-07-05 18:08 EDT, Need Real Name
no flags Details
/etc/X11/XF86Config-4 (1.78 KB, text/plain)
2002-07-05 18:09 EDT, Need Real Name
no flags Details
XFree86 log - DRI is enabled (30.86 KB, text/plain)
2002-07-10 01:32 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-07-05 18:07:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
Dell Inspiron 8000 w/ATI Mobility 16 MB video card will lockup (screen washes
out, keyboard/mouse non-responsive, not ping-able) when playing video files. 
This behavior occurs with the limbo beta 7.3.92 and with Red Hat 7.3.  It is
reproducible with smpeg-mtv, xine, realplayer and mplayer (from freshrpms.net).
 Files (MPEG, AVI, RealVideo) will play for a few seconds (they have a greenish
tint for some reason) before the lockup occurs.  Moving/resizing the video
window seems to trigger the problem faster than if the window is untouched.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Red Hat limbo or 7.3 on a computer with an ATI Mobility vid card
2.Play any video file, with any video player.
3.The computer will lock up.
	

Actual Results:  screen washes out, keyboard/mouse non-responsive, not ping-able

Expected Results:  The video file should have played

Additional info:

I know of one other person who has the same problem.  Red Hat 7.3, ATI video
card (unfortunately he didn't know the model so this is probably less than helpful.)
Comment 1 Need Real Name 2002-07-05 18:08:42 EDT
Created attachment 63904 [details]
/etc/X11/XF86Config
Comment 2 Need Real Name 2002-07-05 18:09:16 EDT
Created attachment 63905 [details]
/etc/X11/XF86Config-4
Comment 3 Need Real Name 2002-07-06 20:06:15 EDT
Addendum:

I seem to have found a workaround.  Disabling the DRI XFree86 module will
prevent lockups during video file playback.
Comment 4 Mike A. Harris 2002-07-09 21:05:46 EDT
Please attach your XFree86 log file with DRI enabled.
Comment 5 Need Real Name 2002-07-10 01:32:20 EDT
Created attachment 64524 [details]
XFree86 log - DRI is enabled
Comment 6 Joe Ceklosky 2002-07-19 00:14:51 EDT
This is the same as BUG 68668.  The Xfree 4.2.0 needs the patch that I supplied,
created by Michel Danzar.  Please patch Xfree 4.2.0 from Redhat 7.3 and Limbo
with this patch.
Comment 7 Mike A. Harris 2002-07-19 03:45:25 EDT
jceklosk:  Cool.. I've been trying to find that bug number for a day or so  ;o)

I'm trying to go through all open bugs looking for ones with supplied patches,
and integrate the sane ones.  I'll have a look at integrating your patch
for the next build.

Caught me just before going to bed.  ;o)
Comment 8 Mike A. Harris 2002-07-19 06:34:22 EDT

*** This bug has been marked as a duplicate of 68668 ***
Comment 9 Joe Ceklosky 2002-07-19 06:41:27 EDT
mharris: I think this is a very sane patch.  It just adds the ability to control
the DMA copies for the r128 chipset with DGA video.  It defaults to off since
there appears to be some kind of bug out there.  This new feature was added in
Xfree 4.2.0, but must have a bug floating in there.

Note You need to log in before you can comment on or make changes to this bug.