Bug 68668 - (Rage 128) X lockup when using XVideo
(Rage 128) X lockup when using XVideo
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 64503 67204 68058 (view as bug list)
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-12 07:17 EDT by Markku Kolkka
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-19 06:32:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 config file (2.98 KB, text/plain)
2002-07-12 07:18 EDT, Markku Kolkka
no flags Details
ffix r128 fullscreen video locks using DMA (3.22 KB, patch)
2002-07-15 23:03 EDT, Joe Ceklosky
no flags Details | Diff

  None (edit)
Description Markku Kolkka 2002-07-12 07:17:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
When trying to watch a DVD using either Xine with Xv video driver or Ogle, the
screen and keyboard lock up after a while. The mouse cursor moves but otherwise
the display isn't updated, and the system doesn't respond to any keyboard input
including Ctrl-Alt-Backspace, Ctrl-Alt-Fn or Ctrl-Alt-Del. Because Xine works OK
with the XShm video driver and the problem happens with two different programs,
I'm assuming that the bug is in XFree86.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.xine -V Xv
2.start playback

	

Actual Results:  A randomly varying time of the film is shown, then the display
freezes and keyboard doesn't work.

Expected Results:  Film plays normally.

Additional info:

ATI Xpert2000Pro video card (Rage Pro PF chip)
AthlonXP 1600+
ECS K7S5A motherboard
Comment 1 Markku Kolkka 2002-07-12 07:18:23 EDT
Created attachment 65104 [details]
XFree86 config file
Comment 2 Joe Ceklosky 2002-07-12 12:34:13 EDT
mharris, please pick up the DMA turn off patches from Michel Danzer in
the Xfree CVS.  This will SOLVE the problems.  I have patched Xfree-4.2.0-52
with these changes and everything is FINE.
Comment 3 Mike A. Harris 2002-07-12 17:49:03 EDT
jceklosk:  Can you please attach a patch that _just_ fixes this code and
does not add any new features?  I don't have time currently to dig through
CVS myself, but if someone can attach a bugfix patch, I can get it integrated
much sooner.

Thanks guys.
Comment 4 Joe Ceklosky 2002-07-12 18:58:43 EDT
mharris, what version of the Redhat Xfree 4.2.0 do you want the patch against?
4.2.0-52 or the latest from rawhide.  The tricky thing about this patch is that
I have to patch things you already patched in the r128 code.  The patch also
applies to the radeon drivers too.
Comment 5 Joe Ceklosky 2002-07-15 23:02:33 EDT
mharris, I have created a patch for the r128 fullscreen video locks.  The acutal
patch to the Xfree86 code was created by Michel Danzer.  I created diffs for it
based on Rehat's Xfree 4.2.0-52 code baseline.  Apply this patch file AFTER all
other r128 patches have been run.  I included this same patch for Redhat 7.3 BUG
64503 too!
Comment 6 Joe Ceklosky 2002-07-15 23:03:20 EDT
Created attachment 65508 [details]
ffix r128 fullscreen video locks using DMA
Comment 7 Mike A. Harris 2002-07-19 06:32:24 EDT
*** Bug 64503 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2002-07-19 06:33:37 EDT
Patch applied to rawhide 4.2.0-53, thanks for providing the patch.
Comment 9 Mike A. Harris 2002-07-19 06:34:17 EDT
*** Bug 68058 has been marked as a duplicate of this bug. ***
Comment 10 Joe Ceklosky 2002-07-22 21:42:38 EDT
mharris, 4.2.0-53 with Michel Danzer's patch is perfect now on the r128 driver
for Xvideo, Please include these changes in the next Xfree 4.2.0 update in
Redhat 7.3 as well as any future Redhat Beta.  Once the next version of Xfree86
has been released, these patches can be dropped because they are already in the
cvs version.

Comment 11 Mike A. Harris 2002-07-23 04:06:23 EDT
Great to get feedback on it working.  Thanks again for submitting the
patches.  It will indeed be in the final release of our next RHL product.
Any future 7.3 erratum will also most likely have all current patches
that are in rawhide, although likely the RPM package will be rearranged.
Comment 12 Mike A. Harris 2002-07-23 05:36:49 EDT
*** Bug 67204 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.