Bug 68077 - beta iso will not boot
beta iso will not boot
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: syslinux (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 69110 (view as bug list)
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-07-05 23:52 EDT by Jef Spaleta
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-03 02:41:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2002-07-05 23:52:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
limbo beta iso will not boot on my pentium box (p100 with 32 megs ram).  Redhat
7.3 disks boot fine on this machine.  I have successfully booted several newer
boxes with the limbo disk I have created, and the mediacheck command shows the
disks as good.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot p100 32 Meg box with limbo cdrom 1
2. cdrom boot failure.
	

Expected Results:  I expect to get a linux installer text prompt similar to what
I say on boot a 7.3 iso.

Additional info:
Comment 1 Jeremy Katz 2002-07-06 13:26:48 EDT
We are now using isolinux to boot CDs.  If you could download the test image at
http://people.redhat.com/~katzj/debugiso.bin and burn it to a CD, what are the
last lines of output before it hangs?
Comment 2 Jef Spaleta 2002-07-06 19:51:15 EDT
using the aformentioned debugiso....my p100 system boots just fine it seems.

I can boot in text mode using the debugiso image...i get the language and
keyboard selection dialogs..then I'm told to insert the redhat boot cd...but
when i swap out the debugiso disk for the redhat limbo disk 1..i get the error
message saying there was a mismatch between the first and second stages of the
boot process...and the installer tells me it's going to reboot my
system...obviously there is something incompatible with the debugiso and the
limbo disk...I dont know if this is a problem or expected behavior for the debugiso.

I'm not sure what's wrong, there's nothing obvious in any of the virtual
terminal #2 messages that would suggest an error.

I'm going to download and burn the limbo disk1 iso again just to double
check..but since the iso boots in "new" machines I'm doubtful there is a problem
with how I burned the image...but I could be wrong..better to double check on my
end just to make sure.

Any other suggestions?

Comment 3 Jeremy Katz 2002-07-07 15:44:45 EDT
Hmm.. the only differences between the isolinux in the two versions is supposed
to be debug messages.  I'll have to double-check a diff to ensure there's not
anything else.  It's entirely expected that you won't be able to install after
booting that CD because I just made that image a few weeks ago when I was first
testing out isolinux and so it's keyed to a tree from that time-frame. 
Verifying that the actual limbo CD doesn't boot would be great.
Comment 4 Jef Spaleta 2002-07-09 02:05:46 EDT
Hi again...
I just reburned the first disk iso image...still doesn't boot on my p100 box
with 32 megs of ram....i booted the iso and ran mediacheck on one of my newer
boxes...so as far as I can tell its a good disk with a good image..but the image
isnt bootin on my p100 box.  All i get is a bios message saying boot from cdrom
failed. So it looks like the iso really does have a problem booting on older
systems.

to recap
1) limbo disk 1 iso will not boot on my p100 32meg system
2) the debugiso image boots on the p100 32meg system
3) redhat 7.3 isos boot without a problem on the p100 as well
4) limbo disk 1 iso will boot on the athlon >= 1GHz systems I have on hand along
with my amd k6-2 400 MHz system

Any other ideas?  I'm going to move on and try to boot with one of the floppy
images and do a network install...see if that gets me anywhere until this bug in
the cdrom image is nailed down.  I'd like to move on and find some application
level bugs for you guys to fix, but if you have any more ideas for me to try
concerning this iso boot problem I'm all ears.


-jef
Comment 5 Jeremy Katz 2002-08-22 02:23:05 EDT
*** Bug 69110 has been marked as a duplicate of this bug. ***
Comment 6 Nigel Smith 2002-08-24 09:00:03 EDT
I originally reported this as bug 69110

I have tried booting the old Gateway Pentium P-75 from the null-7.3.94 cd#1, 
but is still fails, as it seems it is the same isolinux as the limbo-7.3.92 !

I have burned the image debugiso.bin to cd & tried that. It reports:

ISOLINUX 1.75 2002-06-14  Copyright (C) 1994-2002 H. peter Anvin
isolinux: Starting up, DL=00
isolinux: Loading spec packet failed, trying to wing it...
isolinux: Failed to locate CD-ROM device; boot failed.
Comment 7 Jeremy Katz 2002-12-29 03:18:06 EST
Does Phoebe work any better?
Comment 8 Nigel Smith 2003-01-01 14:18:44 EST
Ok, I have tried with 'Phoebe 8.0.92', but it is no better:

ISOLINUX 2.00 2002-10-25
isolinux: Loading spec packet failed, trying to wing it...
isolinux: Failed to locate CD-ROM device; boot failed.
Comment 9 Jeremy Katz 2003-01-03 02:41:03 EST
This is a BIOS bug, then and you're going to have to use boot floppies for this
machine.

Note You need to log in before you can comment on or make changes to this bug.