This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 680837 - route command option mss sets MTU
route command option mss sets MTU
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-tools (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jiri Popelka
qe-baseos-daemons
: ManPageChange, Patch
Depends On:
Blocks: GSS_6_2_PROPOSED 697582
  Show dependency treegraph
 
Reported: 2011-02-28 00:48 EST by Takuma Umeya
Modified: 2011-12-06 07:00 EST (History)
5 users (show)

See Also:
Fixed In Version: net-tools-1.60-107.el6
Doc Type: Bug Fix
Doc Text:
The route(8) manual page now includes an explicit description of the "mss M" option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 07:00:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
man patch against RHEL6 (734 bytes, patch)
2011-02-28 00:48 EST, Takuma Umeya
no flags Details | Diff

  None (edit)
Description Takuma Umeya 2011-02-28 00:48:42 EST
Created attachment 481308 [details]
man patch against RHEL6

Description of problem:
This is same as BZ671321, but this addresses RHEL6. 

mss option of route command sets MTU value. Looking in the code the value is
passed to inet_ioctl() of kernel, which only accepts setting MTU. I have a
patch to address this issue HOWEVER. Since this may affect the change in
behavior significantly, I'd like to propose man page change, so users are aware
that setting mss would mean setting MTU (although they are actually not the
same thing). 

Version-Release number of selected component (if applicable):
net-tools-1.60-102.el6

How reproducible:
Always 

Steps to Reproduce:                                                      
e.g: 
1. # route del default
2. # route add default gw 192.168.122.1 mtu 1500
Above the action shows the below: 
[root@olive-kvm164 ~]# cat /proc/net/route
Iface   Destination     Gateway         Flags   RefCnt  Use     Metric  Mask   
        MTU     Window  IRTT                                                    
eth0    007AA8C0        00000000        0001    0       0       0      
00FFFFFF        0       0       0                                               
eth0    0000FEA9        00000000        0001    0       0       0      
0000FFFF        0       0       0                                               
eth0    00000000        017AA8C0        0003    0       0       0      
00000000        1500    0       0           


Actual results:
Man page is not clear that mss sets MTU. 

Expected results:
Should be clear that mss sets MTU. 

Additional info:
Comment 6 Miroslav Svoboda 2011-08-26 11:13:08 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The route(8) manual page now includes an explicit description of the "mss M" option.
Comment 9 errata-xmlrpc 2011-12-06 07:00:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1596.html

Note You need to log in before you can comment on or make changes to this bug.