Bug 681281 - [abrt] abrt-1.1.17-2.fc15.1: yumRepo.py:842:_getFile:NoMoreMirrorsRepoError: failure: repodata/7e6632b82c91a2e88a66ad848e231f14c48259cbf3a1c3e992a77b1fc0e9d2f6-filelists.sqlite.bz2 from fedora-debuginfo: [Errno 256] No more mirrors to try.
Summary: [abrt] abrt-1.1.17-2.fc15.1: yumRepo.py:842:_getFile:NoMoreMirrorsRepoError: ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Denys Vlasenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6638f960
: 684501 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-01 16:31 UTC by Mads Kiilerich
Modified: 2011-09-27 11:25 UTC (History)
12 users (show)

Fixed In Version: abrt-2.0.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-24 03:23:54 UTC


Attachments (Terms of Use)
File: backtrace (1.93 KB, text/plain)
2011-03-01 16:31 UTC, Mads Kiilerich
no flags Details

Description Mads Kiilerich 2011-03-01 16:31:38 UTC
abrt version: 1.1.17
architecture: i686
cmdline: /usr/bin/python -u /usr/bin/abrt-debuginfo-install /var/spool/abrt/ccpp-1298996389-3186/coredump /var/run/abrt/tmp-7382-1298996627 /var/cache/abrt-di
component: abrt
executable: /usr/bin/abrt-debuginfo-install
kernel: 2.6.38-0.rc6.git6.1.fc15.i686.PAE
package: abrt-1.1.17-2.fc15.1
reason: yumRepo.py:842:_getFile:NoMoreMirrorsRepoError: failure: repodata/7e6632b82c91a2e88a66ad848e231f14c48259cbf3a1c3e992a77b1fc0e9d2f6-filelists.sqlite.bz2 from fedora-debuginfo: [Errno 256] No more mirrors to try.
release: Fedora release 15 (Lovelock)
time: 1298996780
uid: 0

backtrace
-----
yumRepo.py:842:_getFile:NoMoreMirrorsRepoError: failure: repodata/7e6632b82c91a2e88a66ad848e231f14c48259cbf3a1c3e992a77b1fc0e9d2f6-filelists.sqlite.bz2 from fedora-debuginfo: [Errno 256] No more mirrors to try.

Traceback (most recent call last):
  File "/usr/bin/abrt-debuginfo-install", line 454, in <module>
    result = downloader.download(missing)
  File "/usr/bin/abrt-debuginfo-install", line 192, in download
    self.repos.populateSack(mdtype='filelists', cacheonly=1)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 289, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 172, in populate
    db_fn = repo._retrieveMD(mydbtype)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1607, in _retrieveMD
    size=thisdata.size)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 842, in _getFile
    raise Errors.NoMoreMirrorsRepoError, errstr
NoMoreMirrorsRepoError: failure: repodata/7e6632b82c91a2e88a66ad848e231f14c48259cbf3a1c3e992a77b1fc0e9d2f6-filelists.sqlite.bz2 from fedora-debuginfo: [Errno 256] No more mirrors to try.

Local variables in innermost frame:
e: URLGrabError(256, 'No more mirrors to try.')
start: None
url: None
text: 'fedora-debuginfo/filelists_db'
self: <yum.yumRepo.YumRepository object at 0x95a8fec>
cache: True
reget: 'simple'
relative: 'repodata/7e6632b82c91a2e88a66ad848e231f14c48259cbf3a1c3e992a77b1fc0e9d2f6-filelists.sqlite.bz2'
headers: ()
checkfunc: (<bound method YumRepository.checkMD of <yum.yumRepo.YumRepository object at 0x95a8fec>>, ('filelists_db',), {})
errstr: 'failure: repodata/7e6632b82c91a2e88a66ad848e231f14c48259cbf3a1c3e992a77b1fc0e9d2f6-filelists.sqlite.bz2 from fedora-debuginfo: [Errno 256] No more mirrors to try.'
copy_local: 1
end: None
local: '/var/cache/yum/i386/15/fedora-debuginfo/7e6632b82c91a2e88a66ad848e231f14c48259cbf3a1c3e992a77b1fc0e9d2f6-filelists.sqlite.bz2'
size: '8661505'

How to reproduce
-----
1. I tried to report a crash on a system that just had been upgraded to f15 - and where "nothing" works
2.
3.

Comment 1 Mads Kiilerich 2011-03-01 16:31:41 UTC
Created attachment 481677 [details]
File: backtrace

Comment 2 Mads Kiilerich 2011-03-01 16:35:32 UTC
It is fair enough that it fails, but it shouldn't crash.

Comment 3 STEVEN WARD 2011-03-12 10:20:34 UTC
Package: abrt-1.1.17-2.fc15.1
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1.Log into the latest Fedora Alpha 15 
2.Launch Abrt
3.

Comment 4 Jiri Moskovcak 2011-03-15 09:15:54 UTC
*** Bug 684501 has been marked as a duplicate of this bug. ***

Comment 5 Fred 2011-03-30 15:55:51 UTC
Package: abrt-addon-ccpp-2.0.0-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
was submitting a bug and some packages needed to be downloaded to get the trace

Comment 6 luigi votta 2011-04-01 15:45:23 UTC
Package: abrt-addon-ccpp-2.0.0-3.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
ABRT2 testing, please disregard

Comment 7 luigi votta 2011-04-01 15:48:54 UTC
(In reply to comment #6)
> Package: abrt-addon-ccpp-2.0.0-3.fc15
> Architecture: i686
> OS Release: Fedora release 15 (Lovelock)
> 
> 
Please disregard Comment #6

Comment 8 Kamil Páral 2011-04-01 20:07:13 UTC
Package: abrt-addon-ccpp-2.0.0-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I sent gnome-shell crash to be generated on the retrace server. This stacktrace appeared in the "Analyzing" window.

Comment 9 Denys Vlasenko 2011-04-21 21:28:25 UTC
Fixed in git, commit 65ede0e06ac3d9ce1e9857231a22b97baa1d3954, to at least not die with the exception.

Comment 10 Fedora Update System 2011-06-21 13:43:49 UTC
abrt-2.0.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.3-1.fc15

Comment 11 Fedora Update System 2011-06-21 23:54:51 UTC
Package abrt-2.0.3-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.3-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/abrt-2.0.3-1.fc15
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2011-06-24 03:21:48 UTC
abrt-2.0.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.