Bug 68135 - First time setup agent is never started
First time setup agent is never started
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: firstboot (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 70259 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-06 16:03 EDT by Bernd Bartmann
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 16:19:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2002-07-06 16:03:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
In the LIMBO release notes you mention a first time setup agent which should be
automatically started when the system boots for the first time after a fresh
install. The agent didn't start on my system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do a fresh LIMBO install
2. Watch if first time setup agent get's started
3.
	

Additional info:
Comment 1 Bernd Bartmann 2002-07-06 18:48:50 EDT
Error found! This is a GUI only tool. I disabled graphical login during install
and so couldn't see this agent. But it suddenly appeared after "init 5".
Comment 2 Brent Fox 2002-07-13 18:21:21 EDT
I have changed the default behavior to start firstboot in both runlevels 5 and
3.  I plan to leave it like this for the next public beta.  However, people may
complain about having a GUI app start in runlevel 3.  If a sizable number of
people complain, then the options are to create a text mode for firstboot
(problaby not time for this release) or to have firstboot set to never run if
the user selects non-graphical login in the installer.  This would prevent
firstboot from starting up on random runlevel changes.

As it is now, firstboot is going to run that first time, and once it runs, it
will never run again, so the behavior you reported does not happen anymore. 
Thanks for your report.
Comment 3 Bernd Bartmann 2002-07-17 15:23:45 EDT
How do you intend to run a GUI app in runlevel 3? I would REALLY prefer to see
an additional text mode firstboot version.
Comment 4 Brent Fox 2002-07-17 18:06:16 EDT
It starts an X server to run firstboot in and then kills it when firstboot is
finished.
Comment 5 Bernd Bartmann 2002-07-17 18:09:47 EDT
What happens when I didn't configure X at installation time? Most of our server
don't have X configured at all.
Comment 6 Warren Togami 2002-08-05 07:42:18 EDT
Please do NOT run firstboot even during the first init 3.  Some people like
nForce motherboards owners cannot allow X to run because it causes a complete
hard lock.
Comment 7 Brent Fox 2002-08-13 16:18:35 EDT
Ok, I've changed firstboot to never start in runlevel 3.  However, it will run
the first time the machine enters runlevel 5.  Should be fixed in firstboot-0.9.9-9

QA, please verify that this is the current behavior.
Comment 8 Brent Fox 2002-08-13 16:19:09 EDT
*** Bug 70259 has been marked as a duplicate of this bug. ***
Comment 9 Jay Turner 2002-08-20 09:15:27 EDT
Fix confirmed in firstboot-0.9.9-13.

Note You need to log in before you can comment on or make changes to this bug.