Bug 68141 - Broken wrt UTF-8
Summary: Broken wrt UTF-8
Status: CLOSED DUPLICATE of bug 75280
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: xchat (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-06 21:51 UTC by Richard Hult
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-01 06:23:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysconfig as requested (98 bytes, text/plain)
2002-08-06 07:45 UTC, Thomas Schuett
no flags Details

Description Richard Hult 2002-07-06 21:51:18 UTC
Description of Problem:

The switch to UTF-8 locales have broken xchat completely, at least when choosing
Swedish as default language.

Steps to Reproduce:
1. Choose Swedish during installation 
2. Start xchat
3. Join a channel and type Swedish characters (edv) while looking at the same
channel with another client, say using Red Hat 7.3, where you will notice that
the Swedish characters will be displayed as raw UTF-8 in ASCII. Also if other
people use Swedish characters, they are not displayed at all in the limbo client.

Comment 1 Thomas Schuett 2002-08-01 22:19:29 UTC
the same applies for german characters.

Comment 2 Mike A. Harris 2002-08-06 06:30:38 UTC
Please supply your /etc/sysconfig/i18n file

Comment 3 Thomas Schuett 2002-08-06 07:45:48 UTC
Created attachment 69028 [details]
sysconfig as requested

Comment 4 Mike A. Harris 2002-08-08 06:45:45 UTC
Defering for future release.

Comment 5 Richard Hult 2002-08-19 20:33:24 UTC
Hm, does this mean that non-english speaking people won't be able to use IRC on
the next release?


Comment 6 Mike A. Harris 2002-11-01 06:29:34 UTC
At the time I first received this bug report, I wasn't exactly sure
_what_ the issues were.  Fortunately... now I am.  There have been
various bug reports similar in nature to this one, and I've created
a master bug to close duplicates against.   Rather than re-iterate
all of it in every bug report, I'm going to close this as a duplicate
of the master bug.  For detailed answer, please read that bug report,
as well as any duplicates of it for the official full details.

*** This bug has been marked as a duplicate of 75280 ***


Note You need to log in before you can comment on or make changes to this bug.