Bug 75280 - xchat doesn't accept danish characters fxeFXE
xchat doesn't accept danish characters fxeFXE
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 68141 73801 75681 76775 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 15:08 EDT by Henrik Brix Andersen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-06 15:14:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrik Brix Andersen 2002-10-06 15:08:50 EDT
Description of Problem:
X-Chat doesn't accept input of danish characters fxeFXE when 
LANG=en_US.UTF-8

Version-Release number of selected component (if applicable):
xchat-1.8.10-8

How Reproducible:
Every time

Steps to Reproduce:
1. export LANG=en_US.UTF-8 (this is set in /etc/sysconfig/i18n)
2. Login with gdm
3. Run xchat
4. Try entering danish characters fxeFXE in the text entry

Actual Results:
Letters fxeFXE shows up as other characters (C|C,C%C etc)
(note: when copied and inserted into other application they show up right)

Expected Results:
You should be able to use danish charaters even though the locale isn't set 
to da_DK.*

Additional Information:
This doesn't happen when LANG=da_DK.ISO_8859_1
Comment 1 Henrik Brix Andersen 2002-10-06 15:14:07 EDT
seems opera messed up the danish characters...
any clue to how I can get them right on the bug report?
Comment 2 Mike A. Harris 2002-10-06 17:55:56 EDT
This is not an xchat bug.  When multiple people are communicating, either
via IRC, email, or otherwise, or when any to applications are communicating
streams of text, both ends of communication MUST be using an agreed upon
character encoding.  If both ends are not using the same encoding, then
garbled characters will result.  This is expected behaviour.

The solution to this "problem", is to either:

1) disable UTF-8, and set your locale to a non unicode locale, or start
   xchat with a non unicode locale, ie:  "LANG=de_DE xchat"

or

2) enable "fontset" support by default in xchat.  Many people are happy
   with that.

or

3) force everyone else you communicate with to also use UTF-8
   (very unlikely)

The IRC protocol itself specifies an 8bit encoding, but doesn't specify
a particular encoding.  This is most unfortunate, since it leaves
encoding undefined.  Any encoding is therefore theoretically valid.

The unfortunate consequence of that, is that any people who are
communicating with each other, must use the same encoding, otherwise
any non-ASCII characters will appear as random junk.  This includes
using UTF-8 as well.

There is no way to solve this unfortunate problem.  It's just a flaw
in the IRC protocol itself.  Hopefully at some point the IRC protocol
will be officially enhanced and will specify UTF-8 as the encoding.
That would enable worldwide communication via IRC with a single
official standard 8 bit character encoding.  Of course, it would
likely take years for all IRC servers and clients to become properly
UTF-8 aware at that point.
Comment 3 Mike A. Harris 2002-11-01 01:25:18 EST
*** Bug 73801 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2002-11-01 01:26:44 EST
*** Bug 75681 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2002-11-01 01:29:27 EST
*** Bug 68141 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2002-11-01 01:30:24 EST
*** Bug 76775 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.