Bug 68147 - ksconfig can only select 1 of GRUB/LILO/MBR/1st sector of boot partition
ksconfig can only select 1 of GRUB/LILO/MBR/1st sector of boot partition
Status: CLOSED DUPLICATE of bug 69667
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-kickstart (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Depends On:
Blocks: 67217
  Show dependency treegraph
Reported: 2002-07-06 19:56 EDT by Andrew Parker
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-29 16:59:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andrew Parker 2002-07-06 19:56:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Boot loader selection should consist of 2 questions GRUB/LILO and MBR/1st sector
of boot partition.  Currently, only 1 of these options is allowed.  ie, you can
either select a boot loader or where to install it, but not both.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Click 'Boot Loader Options' on left hand side.  Neither GRUB nor LILO are
selected but MBR is.
2.  Click GRUB. GRUB is selected and MBR is deselected
3.  Click MBR.  MBR is selected and GRUB is deselected

Actual Results:  (see steps to reproduce)

Expected Results:  Should be able to select both a boot loader and where to
install it

Additional info:
Comment 1 Brent Fox 2002-07-25 00:34:42 EDT
Arrrgh, libglade-convert strikes again!  When I ran the libglade-convert script
to convert the gtk1.2 glade file into a gtk2 glade file, it grouped all those
radio buttons into one big group, which wasn't the right thing to do.  This
should be fixed in redhat-config-kickstart-2.3.2-4.  I renamed ksconfig to
redhat-config-kickstart last week.

Thanks for your report.
Comment 2 Jay Turner 2002-07-29 16:58:56 EDT
I'm still seeing this behavior with redhat-config-kickstart-2.3.2-4.
Comment 3 Jay Turner 2002-08-08 09:53:26 EDT

*** This bug has been marked as a duplicate of 69667 ***

Note You need to log in before you can comment on or make changes to this bug.