Bug 69667 - Boot Loader options don't make sense
Summary: Boot Loader options don't make sense
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-kickstart   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 68147 (view as bug list)
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-24 11:12 UTC by Jay Turner
Modified: 2015-01-07 23:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 18:38:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Turner 2002-07-24 11:12:58 UTC
Description of Problem:
In the Boot Loader options section, there are several things which don't make sense.
1) It's not intuitive that to get to the upgrade options, you have to deselect
the "Install boot loader" option
2) You can only select one of [grub, lilo, MBR, first sector]; should be
one of [grub,lilo] and one of [MBR, first sector]
3) Selecting LILO still leaves the option for "Encrypt GRUB password" available

Version-Release number of selected component (if applicable):
redhat-config-kickstart-2.3.2-3

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Brent Fox 2002-08-02 01:29:24 UTC
1, 2, and 3 should all be fixed in redhat-config-kickstart-2.3.2-5.  Please verify.

Comment 2 Jay Turner 2002-08-05 15:44:25 UTC
Think that we missed something in the build system, as all three problems are
still present with redhat-config-kickstart-2.3.2-5.

Comment 3 Brent Fox 2002-08-05 21:18:02 UTC
Dammit!  I think there's a bug in glade that keeps writing over the radio button
groupings.  I wish I'd never used Glade in the first place.

Comment 4 Jay Turner 2002-08-08 13:53:21 UTC
*** Bug 68147 has been marked as a duplicate of this bug. ***

Comment 5 Brent Fox 2002-08-11 13:16:23 UTC
Ok, please try again with 2.3.2-9.  Sorry about that.

Comment 6 Jay Turner 2002-08-13 14:51:23 UTC
OK, we're getting there, but still not quite.  What I have now is that if I
enter something in the GRUB password field, then change to using lilo as the
bootloader, the GRUB password still gets written to the ks.cfg file as an option
for LILO.  So, we end up with something like this:

bootloader -useLilo -linear -location=mbr -password=tclmeRHS

Comment 7 Brent Fox 2002-08-13 18:38:09 UTC
Should be fixed in 2.3.2-11.  I mean it this time.  Seriously.  Quit laughing.

Comment 8 Jay Turner 2002-08-14 19:25:42 UTC
Fix confirmed with redhat-config-kickstart-2.3.2-14.


Note You need to log in before you can comment on or make changes to this bug.