Bug 68156 - "first-fit" window placement crashes Sawfish
"first-fit" window placement crashes Sawfish
Status: CLOSED DUPLICATE of bug 67918
Product: Red Hat Public Beta
Classification: Retired
Component: gmp (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-07 02:31 EDT by jbowman
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-07 17:15:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jbowman 2002-07-07 02:31:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
Choosing "first-fit" for window placement in the sawfish configuration tool
results in sawfish crashing to the desktop the next time it tries to place a
window. Upon restart, it continues to crash as soon as it tries to place a window.

This has also occurred very occasionally (once a day, so far) with the standard
"top-left" placement method, however the first-fit method *always* works. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Middle-click on the desktop and choose "customize", then "placement"
2. Choose "first-fit" and hit okay.
3. Spawn a new window by any means.
	

Actual Results:  Sawfish crashed back to the desktop and left me with the
following on my console:

rep: received fatal signal: Aborted

struct debug_buf common:

Backtrace in `fatal_signal_handler':
        <(null)+1107457944>
        <abort+409>
        <(null)+1074448636>
        <(null)+1074450908>
        <__gmp_rand+306>
        <__gmpz_urandomm+249>
        <(null)+1074026346>
        <(null)+1073985400>

Lisp backtrace:
#4   random ...
#3   sp-prune-points ...
#2   sp-make-grid ...
#1   sp-do-placement ...
#0   place-window (#<window 1a00002>)


waiting for X server to shut down


Expected Results:  The new window should have been placed appropriately.

Additional info:

This is on a pristine install of Limbo. The machine is a 1ghz Thunderbird Athlon
with 512mb RAM, Abit KT7a-RAID motherboard, and a Western Digital WD120JB hard
drive.
Comment 1 Havoc Pennington 2002-07-07 10:04:57 EDT
Filed upstream as http://bugzilla.gnome.org/show_bug.cgi?id=87565
Comment 2 jbowman 2002-07-07 15:33:24 EDT
Thanks. Here's the screendump from the occasional "top-left" mode crash:

randraw.c:118: GNU MP assertion failed: ((mp_limb_t) 1 << m2exp) > c
rep: received fatal signal: Aborted

struct debug_buf common:

Backtrace in `fatal_signal_handler':
        <(null)+1107457944>
        <abort+409>
        <(null)+1074448636>
        <(null)+1074450908>
        <__gmp_rand+306>
        <__gmpz_urandomm+249>
        <(null)+1074026346>
        <(null)+1073985400>

Lisp backtrace:
#2   random ...
#1   place-window-randomly ...
#0   place-window (#<window 1805d87>)


waiting for X server to shut down
Comment 3 Havoc Pennington 2002-07-07 17:15:26 EDT
gmp issue, see gnome.org bug comments.
Comment 4 jbowman 2002-07-07 17:28:12 EDT

*** This bug has been marked as a duplicate of 67918 ***

Note You need to log in before you can comment on or make changes to this bug.