Bug 681641 - Unhelpful message from ipa-getcert
Unhelpful message from ipa-getcert
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: certmonger (Show other bugs)
5.6
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Nalin Dahyabhai
:
Depends On: 652047 683926
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-02 14:51 EST by Nalin Dahyabhai
Modified: 2011-07-21 03:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: certmonger-0.34-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 652047
Environment:
Last Closed: 2011-07-21 03:26:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Jenny Galipeau 2011-05-13 12:31:59 EDT
This does not seem to be the expected behavior .


-sh-4.1$ ipa-getcert list
Error connecting to DBus.
-sh-4.1$ echo $?
1

versions:

ipa-server-2.0.0-23.1.el6.x86_64
certmonger-0.42-1.el6.x86_64
Comment 4 Jenny Galipeau 2011-05-13 14:01:55 EDT
Additional automated regression test :

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: TEST PROTOCOL
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: Test run ID   : 1894670
:: [   LOG    ] :: Package       : certmonger
:: [   LOG    ] :: Test started  : 2011-05-13 13:49:02 EDT
:: [   LOG    ] :: Test finished : 2011-05-13 13:49:29 EDT
:: [   LOG    ] :: Test name     : /Regression/BZ_652047
:: [   LOG    ] :: Distro:       : Red Hat Enterprise Linux Server release 5.7 Beta (Tikanga)
:: [   LOG    ] :: Hostname      : dell-pe830-02.rhts.eng.bos.redhat.com
:: [   LOG    ] :: Architecture  : x86_64

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Test description
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Purpose of /Automation/Certmonger/Test/BZ_652047
Description: Testing of certmonger's 'ipa-getcert list' command when run as
non-root 
Author : kaleemullah Siddiqui <ksiddiqu@redhat.com>


::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Setup
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Running 'yum install certmonger -y'
:: [   PASS   ] :: Checking for the presence of certmonger rpm
:: [   LOG    ] :: Duration: 17s
:: [   LOG    ] :: Assertions: 2 good, 0 bad
:: [   PASS   ] :: RESULT: Setup

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Test
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Service started successfully
:: [   PASS   ] :: Running 'adduser certtest'
:: [   FAIL   ] :: Running 'su certtest -c 'ipa-getcert list > /tmp/temp.out'' (Expected 1, got 0)
:: [   PASS   ] :: File /tmp/temp.out should exist
:: [   FAIL   ] :: File '/tmp/temp.out' should contain 'Insufficient access.  Please retry operation as root.' 
:: [   PASS   ] :: File '/tmp/temp.out' should not contain 'Error org.freedesktop.DBus.Error.AccessDenied'
:: [   PASS   ] :: Running 'rm -rf /tmp/temp.out'
:: [   PASS   ] :: Running 'userdel -r certtest'
:: [   LOG    ] :: Duration: 2s
:: [   LOG    ] :: Assertions: 6 good, 2 bad
:: [   FAIL   ] :: RESULT: Test

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Cleanup
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Running 'yum remove certmonger -y'
:: [   LOG    ] :: Duration: 4s
:: [   LOG    ] :: Assertions: 1 good, 0 bad
:: [   PASS   ] :: RESULT: Cleanup
Comment 5 Nalin Dahyabhai 2011-05-13 15:04:50 EDT
(In reply to comment #3)
> This does not seem to be the expected behavior .
> 
> 
> -sh-4.1$ ipa-getcert list
> Error connecting to DBus.
> -sh-4.1$ echo $?
> 1
> 
> versions:
> 
> ipa-server-2.0.0-23.1.el6.x86_64
> certmonger-0.42-1.el6.x86_64

Is the DBus service ("/sbin/service messagebus status") running?
Comment 6 Dmitri Pal 2011-05-13 15:23:22 EDT
Yes it seems you hit a different issue and not executed the scenario in the bug.
Please retry.
Comment 7 Jenny Galipeau 2011-05-13 15:37:49 EDT
The scenario that was verified by Kaleem against RHEL 6.1 was automated and that failed - it passed against RHEL 6.1 after the fix.   Please see comment #4.
Comment 8 Dmitri Pal 2011-05-13 15:54:44 EDT
You are getting a different message from the one that you are testing. It is neither the old one nor the expected new one. That means that something else is wrong. That means that you are not testing what you think you are testing. So you need to resolve the issue and then retest. The issue seems to be that the message bus is not running in the first place. But it might be something else.
Please retest an if the issue persist keep the environment so that Nalin can investigate. It might be some kind of the race condition that we would not be able to investigate or reproduce otherwise. Please move to ON_QE yourself.
Comment 10 Nalin Dahyabhai 2011-05-17 14:00:12 EDT
(In reply to comment #7)
> The scenario that was verified by Kaleem against RHEL 6.1 was automated and
> that failed - it passed against RHEL 6.1 after the fix.   Please see comment
> #4.

It would be useful to know what was written to /tmp/temp.out during that run.
Comment 11 Jenny Galipeau 2011-05-17 16:01:10 EDT
verified


certmonger-0.42-1.el5

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.7 Beta (Tikanga)

# adduser certtest

# service certmonger start
Starting certmonger: [  OK  ]

# service certmonger status
certmonger (pid  21736) is running...


# su certtest -c 'ipa-getcert list'
Number of certificates and requests being tracked: 0.
Comment 12 errata-xmlrpc 2011-07-21 03:26:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1002.html

Note You need to log in before you can comment on or make changes to this bug.