This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 681669 - fence_rhevm needs to change "RUNNING" status to "UP" status as the REST-API has changed.
fence_rhevm needs to change "RUNNING" status to "UP" status as the REST-API h...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents (Show other bugs)
6.0
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Marcus Barrow
Brandon Perkins
:
Depends On:
Blocks: 595383 681670 731166 731167
  Show dependency treegraph
 
Reported: 2011-03-02 16:38 EST by Brandon Perkins
Modified: 2011-08-16 15:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: fence-agents-3.0.12-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 681670 731166 (view as bug list)
Environment:
Last Closed: 2011-05-19 10:17:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against RHEL60 branch. (759 bytes, patch)
2011-03-07 12:10 EST, Brandon Perkins
no flags Details | Diff
updated patch. (877 bytes, patch)
2011-03-09 16:20 EST, Marcus Barrow
no flags Details | Diff

  None (edit)
Description Brandon Perkins 2011-03-02 16:38:33 EST
Description of problem:
fence_rhevm needs to change "RUNNING" status to "UP" status as the REST-API has changed.

Version-Release number of selected component (if applicable):
fence-agents-3.0.12-8.el6_0.2.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Run fence_rhevm -o status
  
Actual results:
Will always show as OFF because "UP" != "RUNNING"

Expected results:
Will show ON if UP and OFF otherwise.

Additional info:
Change line 44 of /usr/sbin/fence_rhevm as such will fix the glitch:

    44          if (status == "UP"):
Comment 1 Brandon Perkins 2011-03-07 12:10:19 EST
Created attachment 482732 [details]
Patch against RHEL60 branch.

Patch against RHEL60 branch.
Comment 3 Marcus Barrow 2011-03-09 16:20:40 EST
Created attachment 483308 [details]
updated patch.
Comment 7 errata-xmlrpc 2011-05-19 10:17:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0745.html

Note You need to log in before you can comment on or make changes to this bug.