Bug 681901 - build conflict subversion with kdelibs3
Summary: build conflict subversion with kdelibs3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kdelibs3
Version: 6.0
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Than Ngo
QA Contact: Desktop QE
URL:
Whiteboard:
: 711434 817794 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-03 14:46 UTC by Juraj Marko
Modified: 2015-09-01 03:38 UTC (History)
9 users (show)

Fixed In Version: kdelibs3-3.5.10-25.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-07 12:50:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
Rebase Fedora changeset fcb3f122712fc9f1bc95b530875cad6689c1024a (1.77 KB, patch)
2011-05-12 04:20 UTC, Mathieu Bridon
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1244 normal SHIPPED_LIVE kdelibs3 bug fix update 2012-09-07 16:48:41 UTC

Description Juraj Marko 2011-03-03 14:46:02 UTC
Description of problem:
subversion has a build conflict with kdelib3. When kdelibs3 is installed on a machine a build is not done ok

How reproducible:
100% when kdelib3 is installed

Steps to Reproduce:
1. install kdelib3
2. rebuild subversion
  
Actual results:
if kdelibs3 is installed and kdelibs3-devel not the rebuild fails:
g++: /usr/lib/libkdeui.so: No such file or directory
g++: /usr/lib/libkdecore.so: No such file or directory
g++: /usr/lib/libDCOP.so: No such file or directory
g++: /usr/lib/libkdefx.so: No such file or directory

if kdelibs3 is installed and kdelibs3-devel is installed too rebuild fails in config script.

Expected results:
rebuild works ok or inform about a build conflict in any way

Comment 2 RHEL Program Management 2011-03-03 15:18:07 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 Mathieu Bridon 2011-05-12 04:18:34 UTC
The bug is in the kdelibs3 package.

It comes from the fact that subversion has a BuildRequires on "kdelibs-devel >= 4.0.0", and that kdelibs3-devel Provides: kdelibs-devel 6:3.5....

This was fixed in Fedora some time ago by Rex Dieter:
http://pkgs.fedoraproject.org/gitweb/?p=kdelibs3.git;a=commit;h=fcb3f122712fc9f1bc95b530875cad6689c1024a

I'm attaching a patch rebased on the RHEL6 srpm. Once a kdelibs3 package has been rebuilt with it, then subversion builds fine.

Comment 6 Mathieu Bridon 2011-05-12 04:20:53 UTC
Created attachment 498432 [details]
Rebase Fedora changeset fcb3f122712fc9f1bc95b530875cad6689c1024a

This patch, applied to kdelibs3, fixes the build issue in subversion.

Note: I didn't change the component for this bug to kdelibs3, I assumed you might have your own processes inside Red Hat and it might not be welcome for random community members to make this kin of changes to tickets.

Comment 7 Petr Sklenar 2011-06-07 15:36:44 UTC
*** Bug 711434 has been marked as a duplicate of this bug. ***

Comment 8 RHEL Program Management 2011-07-06 01:37:20 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 16 Joe Orton 2012-05-01 12:00:07 UTC
*** Bug 817794 has been marked as a duplicate of this bug. ***

Comment 17 Levente Farkas 2012-05-02 15:37:46 UTC
than this should have to fix for rhel-6/3 final!

Comment 24 Tuomo Soini 2012-08-24 20:56:08 UTC
The fix in the patch is completely wrong while it actually fixes the issue.

This bug should be moved to subversion which has the real problem.

This change in subversion.spec does really fix the issue correctly.

-BuildRequires: gnome-keyring-devel, dbus-devel, kdelibs-devel >= 4.0.0
+BuildRequires: gnome-keyring-devel, dbus-devel, kdelibs-devel >= 6:4.0.0

When epoch is used in kdelibs it MUST be used in requirements with version...

I'd suggest reverting the wrong fix and fixing this in the correct place - subversion.

Comment 25 Than Ngo 2012-08-28 11:06:55 UTC
(In reply to comment #24)
> The fix in the patch is completely wrong while it actually fixes the issue.
> 

i don't think the patch is wrong, the patch just drops the old, useless Obsoletes/Provides which can cause such conflicts.


> This bug should be moved to subversion which has the real problem.
> 
> This change in subversion.spec does really fix the issue correctly.
> 
> -BuildRequires: gnome-keyring-devel, dbus-devel, kdelibs-devel >= 4.0.0
> +BuildRequires: gnome-keyring-devel, dbus-devel, kdelibs-devel >= 6:4.0.0
> 
> When epoch is used in kdelibs it MUST be used in requirements with version...
> 

it's correct that the real prblem is in subversion, it must use epoche in the requirement in this case.

Comment 31 errata-xmlrpc 2012-09-07 12:50:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1244.html


Note You need to log in before you can comment on or make changes to this bug.