This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 682141 - gnome-shell failed to start when changing user language to Chinese(China)
gnome-shell failed to start when changing user language to Chinese(China)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
15
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
AcceptedBlocker
: i18n, Patch, Triaged
: 683118 (view as bug list)
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-03-04 04:32 EST by He Rui
Modified: 2011-03-27 01:11 EDT (History)
10 users (show)

See Also:
Fixed In Version: 2.91.92-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-27 01:11:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xsession-errors (13.34 KB, text/plain)
2011-03-04 04:33 EST, He Rui
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 643350 None None None Never

  None (edit)
Description He Rui 2011-03-04 04:32:27 EST
Description of problem:
Fresh installed F15 system with all updates including updates-testing. Change user language in 'user account' to Chinese(China). Gnome shell failed to start after relogin. File .xsession-errors attached                                                    

Version-Release number of selected component (if applicable):
gnome-shell-2.91.90-2.fc15.x86_64
gnome-desktop3-2.91.90-1.fc15.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install F15 system and update all with updates-testing enabled.
2. Change language in my account to Chinese(China)
3. logout and relogin
  
Actual results:
gnome-shell failed to start unless changing the language back to English or Chinese(Hong Kong)

Additional info:
Chinese(Hong Kong) doesn't have this issue.
Comment 1 He Rui 2011-03-04 04:33:54 EST
Created attachment 482257 [details]
xsession-errors
Comment 2 bsfmig 2011-03-08 23:00:10 EST
https://bugzilla.redhat.com/show_bug.cgi?id=683118

Another case only with locale settings went to zh_CN.
Comment 3 He Rui 2011-03-08 23:36:01 EST
Proposed as F15Beta since it blocks all the users who need a simplified Chinese environment of the system.
Comment 4 Adam Williamson 2011-03-11 12:43:37 EST
Discussed at the 2011-03-11 blocker review meeting. Before deciding the blocker status, we'd like to check what exactly happens: does GNOME go to fallback mode (intended for graphics adapters that don't support Shell), or do you just wind up with an unusable blank desktop? Thanks.
Comment 5 Owen Taylor 2011-03-11 13:10:19 EST
This is definitely a blocker; the system locks up with an infinite respawn loop of the shell, so you can't access the UI to change the language or force fallback mode. Shouldn't be hard to fix, though.
Comment 6 Adam Williamson 2011-03-11 13:49:32 EST
Thanks, Owen.
Comment 7 Chen Xing 2011-03-12 12:57:36 EST
I'm suffering from the same problem. GNOME 3 on Archlinux is suffering from the same problem, and I found what happens.

The error gnome-shell is:
=======================================================
    JS ERROR: !!!   Exception was: Error: Failed to convert locale string to UTF8: 转换输入中出现无效字符序列
    JS ERROR: !!!     lineNumber = '0'
    JS ERROR: !!!     fileName = 'gjs_throw'
    JS ERROR: !!!     stack = 'Error("Failed to convert locale string to UTF8: \u8F6C\u6362\u8F93\u5165\u4E2D\u51FA\u73B0\u65E0\u6548\u5B57\u7B26\u5E8F\u5217")@:0
("Failed to convert locale string to UTF8: \u8F6C\u6362\u8F93\u5165\u4E2D\u51FA\u73B0\u65E0\u6548\u5B57\u7B26\u5E8F\u5217")@gjs_throw:0
()@/usr/share/gnome-shell/js/ui/dateMenu.js:210
()@/usr/share/gnome-shell/js/ui/dateMenu.js:148
DateMenuButton()@/usr/share/gnome-shell/js/ui/dateMenu.js:44
()@/usr/share/gnome-shell/js/ui/panel.js:932
Panel()@/usr/share/gnome-shell/js/ui/panel.js:794
start()@/usr/share/gnome-shell/js/ui/main.js:147
@<main>:1
'
    JS ERROR: !!!     message = 'Failed to convert locale string to UTF8: lb�e-���HW&�^W'
窗口管理器警告:Log level 32: Execution of main.js threw exception: Error: Failed to convert locale string to UTF8: 转换输入中出现无效字符序列
=======================================================

If I comment out the 210 line of /usr/share/gnome-shell/js/ui/dateMenu.js :
 this._date.set_text(displayDate.toLocaleFormat(dateFormat));

gnome-shell will run.
Comment 8 bsfmig 2011-03-12 21:21:15 EST
*** Bug 683118 has been marked as a duplicate of this bug. ***
Comment 9 He Rui 2011-03-14 02:40:56 EDT
(In reply to comment #4)
> Discussed at the 2011-03-11 blocker review meeting. Before deciding the blocker
> status, we'd like to check what exactly happens: does GNOME go to fallback mode
> (intended for graphics adapters that don't support Shell), or do you just wind
> up with an unusable blank desktop? Thanks.

It entered to an unusable blank desktop after login at gdm.
Comment 10 Elad Alfassa 2011-03-15 03:31:59 EDT
Upstream fixed this bug, http://git.gnome.org/browse/gnome-shell/commit/?id=7ad89dc46b5307ecb17c1eba133b410eb010aee1

It affects not only Chinese, but any language with Unicode characters in it's date format.
Please update the package in fedora to include this fix. thanks.
Comment 11 Adam Williamson 2011-03-18 14:32:30 EDT
Discussed at 2011-03-18 blocker review meeting. Owen, can you please pull in this fix ASAP, as this is a Beta blocker? Thanks.
Comment 12 Adam Williamson 2011-03-25 13:36:59 EDT
Discussed at 2011-03-25 blocker review meeting. We think the fix for this should be present in gnome-shell-2.91.92-1 . Can those affected please test that version (or any later version) and let us know if the problem is fixed? Thanks.
Comment 13 Elad Alfassa 2011-03-25 14:10:00 EDT
(In reply to comment #12)
> Discussed at 2011-03-25 blocker review meeting. We think the fix for this
> should be present in gnome-shell-2.91.92-1 . Can those affected please test
> that version (or any later version) and let us know if the problem is fixed?
> Thanks.
It is fixed.
Comment 15 bsfmig 2011-03-27 00:41:28 EDT
Confirmed fixed.
I used a latest daily CD to erase existing faulty F-15 installation today and everything is fine now, including when language settings set to zh_CN. Logon process proceeded correctly and Simplified Chinese interface showed up well.
Comment 16 Adam Williamson 2011-03-27 01:11:07 EDT
2.91.92-1 went stable, so closing.

Note You need to log in before you can comment on or make changes to this bug.