Bug 682286 - [abrt] gdb-7.2-41.fc14: check_typedef: Process /usr/bin/gdb was killed by signal 11 (SIGSEGV)
Summary: [abrt] gdb-7.2-41.fc14: check_typedef: Process /usr/bin/gdb was killed by sig...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a1fd5a303a652d1340f7b7e567a...
: 541691 620763 648284 653409 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-04 18:30 UTC by anizman09+redhat
Modified: 2011-03-14 05:37 UTC (History)
8 users (show)

Fixed In Version: gdb-7.2.50.20110305-28.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 682891 (view as bug list)
Environment:
Last Closed: 2011-03-08 20:26:22 UTC


Attachments (Terms of Use)
File: backtrace (20.32 KB, text/plain)
2011-03-04 18:30 UTC, anizman09+redhat
no flags Details
KDevelop screenshot (29.80 KB, image/png)
2011-03-04 19:31 UTC, Jan Kratochvil
no flags Details
gdb-in file created using the script in comment 4 (2.38 KB, text/plain)
2011-03-04 23:13 UTC, anizman09+redhat
no flags Details
gdb-out file created using the script in comment 4 (10.74 KB, text/plain)
2011-03-04 23:13 UTC, anizman09+redhat
no flags Details
gdb internal commands, obtained as mentioned in comment 5 (13.39 KB, text/plain)
2011-03-04 23:16 UTC, anizman09+redhat
no flags Details
KDevelop project that creates the crash (18.37 MB, application/gzip)
2011-03-04 23:50 UTC, anizman09+redhat
no flags Details

Description anizman09+redhat 2011-03-04 18:30:36 UTC
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 20811 bytes
cmdline: gdb --interpreter=mi2 -quiet
component: gdb
Attached file: coredump, 13758464 bytes
crash_function: check_typedef
executable: /usr/bin/gdb
kernel: 2.6.35.11-83.fc14.i686
package: gdb-7.2-41.fc14
rating: 4
reason: Process /usr/bin/gdb was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1299262683
uid: 500

How to reproduce
-----
1. Open KDevelop 4.1.2 (shipped with Fedora 14).
2. Create a C++ project (CMake) with a simple hello world-like code (needs at least 2 executable lines).
3. Place a breakpoint in an executable line.
4. Compile the project.
5. Debug the project.
6. When the execution reaches the breakpoint and stops, select 'Step Over' the statement.

GDB crashes at that point

Comment 1 anizman09+redhat 2011-03-04 18:30:38 UTC
Created attachment 482344 [details]
File: backtrace

Comment 2 Jan Kratochvil 2011-03-04 19:31:46 UTC
Created attachment 482354 [details]
KDevelop screenshot

Reproducibility of this Bug would be great as it is probably a duplicate of the popular Bug 653409 (which has older duplicates).
But I do not have it reproducible according to your description, do you?
Thanks.

Comment 3 anizman09+redhat 2011-03-04 19:47:09 UTC
The bug is reproducible for me from within KDevelop (launching gdb from KDevelop; launching gdb from a console works fine). I have another box with Fedora 14 (similar configuration) and I can reproduce the bug in both of them.

Comment 4 Jan Kratochvil 2011-03-04 20:45:23 UTC
I have even ran that gdb under valgrind with no luck.

Could you please provide your project (source file / executable etc., the dir) and even specify
Launch Configurations->...->Debug->Debugger executable
as this script:
#! /bin/sh
tee /tmp/gdb-in|gdb "$@"|tee /tmp/gdb-out
(chmod +x it!)
and send these gdb-in and gdb-out along?

Thanks.

Comment 5 Tom Tromey 2011-03-04 21:11:45 UTC
Could you post your exact c++ source?
It is ok if it is trivial, it might still help.

Also, if you open the GDB view in KDevelop, you can right-click
and select "show internal commands" on the menu.
This information would be very useful.

Comment 6 anizman09+redhat 2011-03-04 23:13:01 UTC
Created attachment 482396 [details]
gdb-in file created using the script in comment 4

Comment 7 anizman09+redhat 2011-03-04 23:13:28 UTC
Created attachment 482397 [details]
gdb-out file created using the script in comment 4

Comment 8 anizman09+redhat 2011-03-04 23:16:22 UTC
Created attachment 482398 [details]
gdb internal commands, obtained as mentioned in comment 5

Comment 9 anizman09+redhat 2011-03-04 23:50:36 UTC
Created attachment 482401 [details]
KDevelop project that creates the crash

KDevelop project that generates the GDB crash.

The program takes several parameters; only the value of '-tdd' needs to be updated to reflect path to the terrain data file (included in the attachment) in the filesystem.

The best location to place the breakpoint is in topofilereader.cpp:114 or after:
   for (int j = 0; j < maxIndexLon - minIndexLon + 1; j++) {

Other lines of code before that one have also generated the crash, but intermittently; the one proposed has always generated the crash.

Comment 10 Fedora Update System 2011-03-05 06:59:58 UTC
gdb-7.2-46.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gdb-7.2-46.fc14

Comment 11 Jan Kratochvil 2011-03-05 07:02:00 UTC
I thought the archer-jankratochvil-vla branch has the unfinished types garbage collector disabled but it was enabled.  varobj (=MI) did not properly mark the types as still used and thus a freed memory access happened, I am sorry.
Disabled the garbage collector for now.

Comment 12 Jan Kratochvil 2011-03-05 07:07:00 UTC
*** Bug 648284 has been marked as a duplicate of this bug. ***

Comment 13 Jan Kratochvil 2011-03-05 07:07:45 UTC
*** Bug 653409 has been marked as a duplicate of this bug. ***

Comment 14 Jan Kratochvil 2011-03-05 07:08:44 UTC
*** Bug 620763 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2011-03-05 12:37:23 UTC
gdb-7.2.50.20110305-28.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gdb-7.2.50.20110305-28.fc15

Comment 16 Fedora Update System 2011-03-05 19:23:17 UTC
gdb-7.2.50.20110305-28.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gdb'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gdb-7.2.50.20110305-28.fc15

Comment 17 anizman09+redhat 2011-03-07 19:42:15 UTC
I have tested the new version (in FC14), and as far as I can tell, it fixes the problem. I have tested it though several different systems that experienced the problem before, and for all of them the problem is fixed.

Comment 18 Fedora Update System 2011-03-08 20:26:15 UTC
gdb-7.2-46.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Jan Kratochvil 2011-03-11 19:11:29 UTC
*** Bug 541691 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2011-03-14 05:37:24 UTC
gdb-7.2.50.20110305-28.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.