Bug 682378 - makes assumptions about network device names
makes assumptions about network device names
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: powertop (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jaroslav Škarvada
Jeff Bastian
:
Depends On: 829800 996975
Blocks: 682269 947784
  Show dependency treegraph
 
Reported: 2011-03-04 20:46 EST by Bill Nottingham
Modified: 2013-11-21 02:52 EST (History)
7 users (show)

See Also:
Fixed In Version: powertop-2.3-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: The 'eth0' was hardcoded in the the powertop code. Consequence: The WOL status on interfaces named other than 'eth0' wasn't checked and for such interfaces the powertop doesn't show the suggestion about turning the WOL off to save the power. Fix: The powertop-2.X handles the network interfaces different way. It gets the available interfaces from the sysfs. The problem was resolved by rebase to powertop-2.X Result: The new code handles the interfaces with arbitrary names correctly.
Story Points: ---
Clone Of: 682377
Environment:
Last Closed: 2013-11-21 02:52:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2011-03-04 20:46:58 EST
+++ This bug was initially created as a clone of Bug #682377 +++

Description of problem:

Network devices can have arbitrary names, and due to
http://fedoraproject.org/wiki/Features/ConsistentNetworkDeviceNaming, will have
different names in Fedora 15.

powertop-1.13/ethernet.c:

The wake-on-lan tests and the wake-on-lan disable both hardcode 'eth0'.

powertop-1.13/powertop.c:static void do_proc_irq(void)
...
                /* deal with multi-queue NICs */
                if (strncmp(name, "eth",3) == 0 && strchr(name,' ') == NULL) {
                        c = strchr(name, '-');
                        if (c)
                                *c = 0;
                }
...

This implies this will mishandle any devices *not* named ethX, if they have multiple queues.

Version-Release number of selected component (if applicable):

powertop-1.13

How reproducible:

By visual inspection.
Comment 4 RHEL Product and Program Management 2011-07-05 21:36:56 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 11 errata-xmlrpc 2013-11-21 02:52:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1575.html

Note You need to log in before you can comment on or make changes to this bug.