Bug 682379 - assumes all ethernet devices are named ethX
assumes all ethernet devices are named ethX
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tuned (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Vcelak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 682334 682380
  Show dependency treegraph
 
Reported: 2011-03-04 20:50 EST by Bill Nottingham
Modified: 2014-03-16 23:26 EDT (History)
6 users (show)

See Also:
Fixed In Version: tuned-0.2.20-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 682380 (view as bug list)
Environment:
Last Closed: 2011-03-23 00:57:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2011-03-04 20:50:48 EST
Description of problem:

Network devices can have arbitrary names, and due to
http://fedoraproject.org/wiki/Features/ConsistentNetworkDeviceNaming, will have
different names in Fedora 15.

tuned-0.2.19/monitorplugins/net.py:
...
                devs = open("/proc/net/dev").readlines()
                for l in devs:
                        l = l.replace(":", " ")
                        v = l.split()
                        d = v[0]
                        if not d.startswith("eth"):
                                continue
...

Version-Release number of selected component (if applicable):

tuned-0.2.19

How reproducible:

By visual inspection.
Comment 1 Jan Vcelak 2011-03-08 11:46:17 EST
Resolved in git (upstream):
http://git.fedorahosted.org/git/?p=tuned.git;a=commit;h=ae41fe8
Comment 2 Jan Vcelak 2011-03-08 13:12:42 EST
Better fix:
http://git.fedorahosted.org/git/?p=tuned.git;a=commit;h=fd2656d
Comment 3 Fedora Update System 2011-03-21 04:26:37 EDT
tuned-0.2.20-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/tuned-0.2.20-1.fc15
Comment 4 Fedora Update System 2011-03-21 04:26:39 EDT
tuned-0.2.20-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/tuned-0.2.20-1.fc15
Comment 5 Fedora Update System 2011-03-23 00:57:39 EDT
tuned-0.2.20-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.