Bug 682406 - [abrt] gnucash-2.4.3-1.fc15: do_lookup_x: Process /usr/bin/gnucash was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnucash-2.4.3-1.fc15: do_lookup_x: Process /usr/bin/gnucash was killed...
Keywords:
Status: CLOSED DUPLICATE of bug 682307
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d6d5208d3ef3a73241bbedbd148...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-05 07:53 UTC by Ian Pilcher
Modified: 2016-11-24 16:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-06 21:18:50 UTC


Attachments (Terms of Use)
File: backtrace (46.76 KB, text/plain)
2011-03-05 07:53 UTC, Ian Pilcher
no flags Details

Description Ian Pilcher 2011-03-05 07:53:06 UTC
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 47882 bytes
cmdline: gnucash
component: gnucash
Attached file: coredump, 20516864 bytes
crash_function: do_lookup_x
executable: /usr/bin/gnucash
kernel: 2.6.38-0.rc6.git6.1.fc15.x86_64
package: gnucash-2.4.3-1.fc15
rating: 4
reason: Process /usr/bin/gnucash was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
time: 1299311364
uid: 500

How to reproduce
-----
1.  Attempt to start gnucash

Comment 1 Ian Pilcher 2011-03-05 07:53:14 UTC
Created attachment 482416 [details]
File: backtrace

Comment 2 Ian Pilcher 2011-03-05 08:19:59 UTC
Downgrading glibc and associated packages from 2.13.90-5 to 2.13.90-4 makes
the crash go away.

Changing component to glibc.

Comment 3 Tom London 2011-03-06 01:16:59 UTC
Believe I'm seeing a similar segfault in qemu-kvm. 

Backtrace below.

As in #2 above, Downgrading to 2.13.90-4 makes qemu-kvm run again.
----------------------------------------------------------------


Core was generated by `qemu-kvm -localtime -vga std -m 1024 -usbdevice tablet -name Windows 7 -soundhw'.
Program terminated with signal 11, Segmentation fault.
#0  do_lookup_x (new_hash=2999033617, old_hash=<optimized out>, 
    ref=<optimized out>, result=0x7fff4126c2b0, scope=<optimized out>, i=6, 
    flags=2, skip=0x0, undef_map=0x7fe2b8f97000) at dl-lookup.c:99
99	      const struct link_map *map = list[i]->l_real;
Missing separate debuginfos, use: debuginfo-install celt051-0.5.1.3-3.fc15.x86_64 libaio-0.3.109-3.fc15.x86_64 spice-server-0.8.0-1.fc16.x86_64
(gdb) set pagination off
(gdb) bt full
#0  do_lookup_x (new_hash=2999033617, old_hash=<optimized out>, ref=<optimized out>, result=0x7fff4126c2b0, scope=<optimized out>, i=6, flags=2, skip=0x0, undef_map=0x7fe2b8f97000) at dl-lookup.c:99
        symtab = <optimized out>
        sym = <optimized out>
        bitmask = <optimized out>
        n = 7
        list = 0x35fe7d0
        __PRETTY_FUNCTION__ = "do_lookup_x"
        num_versions = 0
        versioned_sym = 0x0
        map = 0x358c021998
        type_class = 0
        undef_name = 0x35a1a5edf4 "XAllocClassHint"
        strtab = 0x358be00630 ""
        symidx = 0
        version = 0x0
#1  0x000000358be09f7f in _dl_lookup_symbol_x (undef_name=0x35a1a5edf4 "XAllocClassHint", undef_map=0x7fe2b8f97000, ref=0x7fff4126c3d0, symbol_scope=0x7fe2b8f97388, version=0x0, type_class=0, flags=2, skip_map=0x0) at dl-lookup.c:736
        res = <optimized out>
        start = <optimized out>
        new_hash = 2999033617
        old_hash = 4294967295
        current_value = {s = 0x0, m = 0x0}
        scope = 0x7fe2b8f97388
        __PRETTY_FUNCTION__ = "_dl_lookup_symbol_x"
        i = 0
        protected = <optimized out>
#2  0x000000358c31aeea in do_sym (handle=<optimized out>, name=0x35a1a5edf4 "XAllocClassHint", who=<optimized out>, vers=<optimized out>, flags=2) at dl-sym.c:177
        map = 0x7fe2b8f97000
        ref = 0x0
        result = <optimized out>
        caller = <optimized out>
        match = 0x7fe2b8f989c0
#3  0x000000358ce01044 in dlsym_doit (a=0x7fff4126c5a0) at dlsym.c:51
        args = 0x7fff4126c5a0
#4  0x000000358be0e846 in _dl_catch_error (objname=0x35fe770, errstring=0x35fe778, mallocedp=0x35fe768, operate=0x358ce01030 <dlsym_doit>, args=0x7fff4126c5a0) at dl-error.c:178
        errcode = 0
        old = 0x0
        c = {objname = 0x35fe4e0 "\237\342&A\377\177", errstring = 0x0, malloced = false, env = {{__jmpbuf = {56616800, -708425491894904204, 140734286448032, 140611742691328, 230347483584, 0, 702193519359810164, -708432086545737100}, __mask_was_saved = 1093060096, __saved_mask = {__val = {229996761056, 0, 0, 56616800, 17738318580780751476, 140734286448128, 0, 0, 0, 702193519355615860, 17738311987163814516, 0, 229996758432, 56616800, 17738318580818500212, 56618688}}}}}
        catchp = 0x7fe2b8d6a828
#5  0x000000358ce0152f in _dlerror_run (operate=0x358ce01030 <dlsym_doit>, args=0x7fff4126c5a0) at dlerror.c:164
        result = 0x35fe760
#6  0x000000358ce0109a in __dlsym (handle=<optimized out>, name=<optimized out>) at dlsym.c:71
        args = {handle = 0x7fe2b8f97000, name = 0x35a1a5edf4 "XAllocClassHint", who = 0x35a1a36abe, sym = 0x358be0de74}
        result = <optimized out>
#7  0x00000035a1a36abe in SDL_LoadFunction (handle=0x7fe2b8f97000, name=0x35a1a5edf4 "XAllocClassHint") at src/loadso/dlopen/SDL_sysloadso.c:46
        symbol = <optimized out>
#8  0x00000035a1a3a025 in X11_GetSym (fnname=0x35a1a5edf4 "XAllocClassHint", rc=0x35a1c6df38, fn=0x35a1c7a9c0) at src/video/x11/SDL_x11dyn.c:70
        i = <optimized out>
#9  0x00000035a1a3af34 in SDL_X11_LoadSymbols () at src/video/x11/SDL_x11sym.h:24
        thismod = 0x35a1c6df38
        rc = 1
#10 0x00000035a1a41bca in X11_CreateDevice (devindex=<optimized out>) at src/video/x11/SDL_x11video.c:105
        device = 0x0
#11 0x00000035a1a31d9c in SDL_VideoInit (driver_name=<optimized out>, flags=0) at src/video/SDL_video.c:194
        video = 0x0
        i = <optimized out>
        vformat = {palette = 0x966f40, BitsPerPixel = 133 '\205', BytesPerPixel = 70 'F', Rloss = 225 '\341', Gloss = 139 '\213', Bloss = 53 '5', Aloss = 0 '\000', Rshift = 0 '\000', Gshift = 0 '\000', Bshift = 0 '\000', Ashift = 0 '\000', Rmask = 0, Gmask = 86, Bmask = 0, Amask = 2, colorkey = 0, alpha = 0 '\000'}
        video_flags = <optimized out>
#12 0x00000035a1a0806c in SDL_InitSubSystem (flags=1048608) at src/SDL.c:70
No locals.
#13 0x00000035a1a080dc in SDL_Init (flags=1048608) at src/SDL.c:162
No locals.
#14 0x00000000004b1e9a in sdl_display_init (ds=0x30f0150, full_screen=0, no_frame=0) at ui/sdl.c:843
        flags = 1048608
        data = 0 '\000'
        da = <optimized out>
        vi = <optimized out>
#15 0x000000000040af40 in main (argc=<optimized out>, argv=<optimized out>, envp=<optimized out>) at /usr/src/debug/qemu-kvm-0.14.0/vl.c:3119
        gdbstub_dev = 0x0
        i = <optimized out>
        snapshot = 0
        linux_boot = 0
        icount_option = 0x0
        initrd_filename = 0x0
        kernel_filename = 0x0
        kernel_cmdline = 0x5ff33c ""
        boot_devices = "cad", '\000' <repeats 29 times>
        ds = 0x30f0150
        dcl = <optimized out>
        cyls = 0
        heads = 0
        secs = 0
        translation = 0
        hda_opts = <optimized out>
        opts = <optimized out>
        olist = <optimized out>
        optind = 14
        optarg = 0x7fff4126e27c "/home/tbl/VirtualMachines/Win7.img"
        loadvm = 0x0
        machine = 0x966f40
        cpu_model = 0x0
        tb_size = 0
        pid_file = 0x0
        incoming = 0x0
        defconfig = <optimized out>
(gdb)

Comment 4 Christopher Aillon 2011-03-06 21:18:50 UTC

*** This bug has been marked as a duplicate of bug 682307 ***


Note You need to log in before you can comment on or make changes to this bug.