This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 682621 - [zh_TW][fix available] Font size of menu is significantly small in OpenOffice.org writer/calc/impress
[zh_TW][fix available] Font size of menu is significantly small in OpenOffice...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openoffice.org (Show other bugs)
6.1
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Caolan McNamara
QE Internationalization Bugs
: i18n
: 664008 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-06 23:01 EST by Kenichi Takemura
Modified: 2014-08-04 18:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 11:32:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
zh_TW tiny menu font in writer/clac/impress (286.13 KB, image/png)
2011-03-06 23:01 EST, Kenichi Takemura
no flags Details
with DejaVu Sans present (71.71 KB, image/png)
2011-03-07 03:16 EST, David Tardon
no flags Details
without DejaVu Sans present (64.96 KB, image/png)
2011-03-07 03:17 EST, David Tardon
no flags Details
this seems to work much better (5.29 KB, patch)
2011-03-09 10:42 EST, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 112247 None None None Never

  None (edit)
Description Kenichi Takemura 2011-03-06 23:01:58 EST
Created attachment 482590 [details]
zh_TW tiny menu font in writer/clac/impress

Description of problem:

Menu font size is significantly small and hard to recognize.
OpenOffice.org writer/calc/impress in zh_TW locale.

Version-Release number of selected component (if applicable):
openoffice.org-xsltfilter-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-impress-core-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-draw-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-langpack-zh_CN-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-calc-core-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-core-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-graphicfilter-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-draw-core-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-impress-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-langpack-zh_TW-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-ure-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-presenter-screen-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-writer-core-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-calc-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-langpack-en-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-writer-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-math-core-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-opensymbol-fonts-3.2.1-19.6.el6_0.5.noarch
openoffice.org-math-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-brand-3.2.1-19.6.el6_0.5.x86_64
openoffice.org-pdfimport-3.2.1-19.6.el6_0.5.x86_64
pango-1.28.1-3.el6_0.5.x86_64
libicu-4.2.1-9.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run anaconda in zh_TW locale
2. Launch OpenOffice.org writer/calc/impress
3.
  
Actual results:
Menu font size is tiny.

Expected results:
At least menu font size is as same as other application(eg. firefox, teminal)

Additional info:
Comment 2 RHEL Product and Program Management 2011-03-06 23:18:14 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 David Tardon 2011-03-07 03:15:45 EST
It seems that glyphs from DejaVu Sans, which are smaller than corresponding glyphs from AR PL Uming, are picked when available. Cf. the following two screenshots, the first with default system configuration and the second with dejavu-sans-fonts forcibly uninstalled. The text for "File" on the first screenshot is rendered in AR PL Uming (as are some items in the menus), but the rest are DejaVu Sans.
Comment 4 David Tardon 2011-03-07 03:16:37 EST
Created attachment 482619 [details]
with DejaVu Sans present
Comment 5 David Tardon 2011-03-07 03:17:05 EST
Created attachment 482620 [details]
without DejaVu Sans present
Comment 6 Caolan McNamara 2011-03-07 14:56:13 EST
Without looking into this, this is probably due to the glyph fallback stuff worried that the glyph would be out of scale and shrinking them down. 

As an aside, I think 6.1.0 is a bad idea for a bug with such low impact.
Comment 7 Caolan McNamara 2011-03-08 12:18:25 EST
Yeah, its the fix for rhbz#577823. But it shrinks too much. I'll try a solution that uses the exact height of the used glyphs rather than the generic font metrics
Comment 8 Caolan McNamara 2011-03-09 10:42:17 EST
Created attachment 483245 [details]
this seems to work much better
Comment 9 Caolan McNamara 2011-03-09 10:44:19 EST
from my side
-1 for 6.1.0 as I'd like some bake-in time for this fix in e.g. F-15
+1 for 6.2.0 on that basis
Comment 10 RHEL Product and Program Management 2011-03-09 10:59:28 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 11 David Tardon 2011-03-16 05:47:14 EDT
*** Bug 664008 has been marked as a duplicate of this bug. ***
Comment 12 Caolan McNamara 2011-06-09 04:21:01 EDT
Note: ensure http://cgit.freedesktop.org/libreoffice/libs-gui/commit/?id=0adcbfa45f1c387d35acdc34c4a945dc88fecead is added as well, looks like I was right in -1 for 6.1.0 :-)
Comment 13 RHEL Product and Program Management 2011-07-05 20:01:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 16 Suzanne Yeghiayan 2012-02-14 18:07:42 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 17 Caolan McNamara 2012-06-08 11:32:28 EDT
This should be fixed as a side effect of rebasing to LibreOffice 3.4.5

Note You need to log in before you can comment on or make changes to this bug.