Bug 682677 - Wrong thinkness for letter 'u'
Wrong thinkness for letter 'u'
Status: CLOSED DUPLICATE of bug 715309
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-03-07 04:03 EST by Fabian Greffrath
Modified: 2012-02-09 12:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-02-09 12:48:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
See the attached screenshot I took from the SPON website, especially the word "um" (97 bytes, text/plain)
2011-03-07 04:03 EST, Fabian Greffrath
no flags Details
Artifact for character "u" when employing Liberation fonts (20.54 KB, image/png)
2011-03-08 10:28 EST, Joachim Frieben
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 616620 None None None Never

  None (edit)
Description Fabian Greffrath 2011-03-07 04:03:52 EST
Created attachment 482628 [details]
See the attached screenshot I took from the SPON website, especially the word "um"

Originally reported by Michael Biebl to the Debian Bug Tracking System, see <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=616620>:


since upgrading ttf-liberation from to, the letter 'u' and 'U' has become much "thiner" in
comparison to other letters. See the attached screenshot I took from the
SPON website, especially the word "um".

I downgraded to the squeeze version again and the problem is gone, so
this is a regression of the new upstream release.


> Is only the sans variant affected or also the serif one?

Hard to say, as the serif letter is completely different. I only recognized this
with the sans version.

I have to add, that I use LCD, RGB, and full hinting
Comment 1 Pravin Satpute 2011-03-08 05:12:02 EST
i have not done any change specifically to 'u' and 'U' characters, but will check those again
Comment 2 Joachim Frieben 2011-03-08 10:28:25 EST
Created attachment 482925 [details]
Artifact for character "u" when employing Liberation fonts

Issue still present for liberation-fonts- as demonstrated by the attached screenshot. The issue only occurs for the particular font size used in the title: after zooming in or zooming out, the rendering is even again.
(Note: attachment 482628 [details] is broken, only the external link is displayed instead of the image itself).
Comment 3 Fabian Greffrath 2011-03-08 10:48:27 EST
The same headline is rendered perfectly normal in Epiphany, regardless of the zoom factor.
Comment 4 Pravin Satpute 2011-03-09 00:26:09 EST
As per comment #2 and #3 it looks like hinting issues.
Yet i have not touched hinting instructions of liberation fonts :)
dunno should i try for something for specific size (please let me know the size) mentioned in #2, 

I did not able to reproduce same in fedora 14 gedit and openoffice
Comment 5 Pravin Satpute 2012-02-09 12:48:13 EST

*** This bug has been marked as a duplicate of bug 715309 ***

Note You need to log in before you can comment on or make changes to this bug.