Bug 715309 - [hinting] Bold 'u' looks skinny
[hinting] Bold 'u' looks skinny
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
: 682677 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 10:16 EDT by Marek Kašík
Modified: 2013-09-01 19:07 EDT (History)
7 users (show)

See Also:
Fixed In Version: liberation-fonts-1.07.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 14:38:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ftview of LiberationSans-Bold.ttf (32.82 KB, image/png)
2011-06-22 10:16 EDT, Marek Kašík
no flags Details

  None (edit)
Description Marek Kašík 2011-06-22 10:16:14 EDT
Created attachment 506011 [details]
ftview of LiberationSans-Bold.ttf

Description of problem:
Letter 'u' from LiberationSans-Bold.ttf has vertical lines narrower than it should have at size 18 (when comparing with 'n').


Version-Release number of selected component (if applicable):
liberation-sans-fonts-1.07.0-1.fc15


How reproducible:
execute "ftview 18 /usr/share/fonts/liberation/LiberationSans-Bold.ttf" (or see the attached image) and compare letter 'u' with letter 'n'.


Additional info:
This was introduced in upstream commit http://git.fedorahosted.org/git/?p=liberation-fonts.git;a=commit;h=054d3217e6f3ec8ff7d2495c8fe9af85c1214ba3 which is a fix of https://bugzilla.redhat.com/show_bug.cgi?id=463036.
Comment 1 Pravin Satpute 2011-06-23 02:18:48 EDT
check same thing in gedit or libreoffice. It looks fine.
might be some other problem
Comment 2 Marek Kašík 2011-06-23 05:51:43 EDT
I forgot to mention that the problem shows up for different size in Gnome. It is 13.5 for me in gedit and libreoffice. It takes DPI value into account. The ftview shows the problem for 72 DPI for size 18, but gedit shows the problem for 13.5 for 96 DPI.

You can try it with:
pango-view --font="LiberationSans Bold 18" --dpi 72 --text "nun"
or
pango-view --font="LiberationSans Bold 13.5" --dpi 96 --text "nun"

Marek
Comment 3 Pravin Satpute 2011-06-23 06:02:59 EDT
yeah, agree!!
problem happening at particular size.
this looks me one more issues with liberation-fonts hinting.

Dunno should we remove hiting instruction for affected characters and try autohinting of fontforge, to see is it work or not.
Comment 4 Pravin Satpute 2011-12-21 05:51:32 EST
I think this is regression of bug #463036

I will restore those instructions again and update this bug
Comment 5 Pravin Satpute 2012-02-09 12:48:13 EST
*** Bug 682677 has been marked as a duplicate of this bug. ***
Comment 6 Pravin Satpute 2012-02-09 12:50:04 EST
Summary from duplicate bug
****************************************************
Fabian Greffrath 2011-03-07 04:03:52 EST

Created attachment 482628 [details]
See the attached screenshot I took from the SPON website, especially the word
"um"

Originally reported by Michael Biebl to the Debian Bug Tracking System, see
<http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=616620>:

Hi,

since upgrading ttf-liberation from 1.05.2.20091019-4 to
1.06.0.20100721-1, the letter 'u' and 'U' has become much "thiner" in
comparison to other letters. See the attached screenshot I took from the
SPON website, especially the word "um".

I downgraded to the squeeze version again and the problem is gone, so
this is a regression of the new upstream release.

Cheers,
Michael

> Is only the sans variant affected or also the serif one?

Hard to say, as the serif letter is completely different. I only recognized
this
with the sans version.

I have to add, that I use LCD, RGB, and full hinting
****************************************************
Comment 7 Fedora Update System 2012-02-13 11:03:31 EST
liberation-fonts-1.07.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.2-2.fc16
Comment 8 Fedora Update System 2012-02-14 04:12:09 EST
Package liberation-fonts-1.07.2-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liberation-fonts-1.07.2-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1644/liberation-fonts-1.07.2-2.fc16
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-03-06 14:38:19 EST
liberation-fonts-1.07.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-08-28 07:57:47 EDT
liberation-fonts-1.07.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.3-2.fc19
Comment 11 Fedora Update System 2013-09-01 19:07:41 EDT
liberation-fonts-1.07.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.