Bug 682735 - Issue with radio buttons on Administration->System Settings page
Issue with radio buttons on Administration->System Settings page
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core Server (Show other bugs)
4.0.0.B02
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
: 683966 (view as bug list)
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-03-07 07:31 EST by Sunil Kondkar
Modified: 2011-10-06 15:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sunil Kondkar 2011-03-07 07:31:56 EST
Description of problem:

I found below issue while entering to LDAP config properties on Administration->System Settings page

I had the following values set for radio buttons:

Enable Agent Auto updates  = yes
Enable debug mode   = yes
Enable experimental features  = yes
Reindex Data Tables Nightly - Yes
Enable LDAP    - yes
SSL  - No

I entered ldap config settings and no text box / radio button was empty.

Clicking on Save button displays the message 'Please fix the invalid values before saving'.

The radio boxes show a red exclamation icon

The value of 'SSL' field in LDAP Configuration Properties' section changes from 'No' to 'Yes'.

Version-Release number of selected component (if applicable):

Build# 1074  (Version: 4.0.0-SNAPSHOT Build Number: 77ad7aa)

How reproducible:

Always

Steps to Reproduce:

1. Login to RHQ.

2. Set following values for radio buttons on Administration->System Settings page :

Enable Agent Auto updates  = yes
Enable debug mode   = yes
Enable experimental features  = yes
Reindex Data Tables Nightly - Yes
Enable LDAP    - yes
SSL  - No

3. Click on Save button

4. Notice the value of 'SSL' field in LDAP Configuration Properties' section. It changes from 'No' to 'Yes'.

Actual results:
After saving the 'System Settings' properties, a message 'Please fix the invalid values before saving' appears with red exclamation icon and the value of 'SSL' field changes from 'No' to 'Yes'.

Expected results: 
The 'System Settings' properties should be saved successfully and  value of 'SSL' field should not change.


Additional info:
Comment 1 John Mazzitelli 2011-03-21 16:17:33 EDT
this was fixed recently. I just tried on master build and it is working as expected now.
Comment 2 John Mazzitelli 2011-03-24 14:39:29 EDT
*** Bug 683966 has been marked as a duplicate of this bug. ***
Comment 3 Sunil Kondkar 2011-03-30 06:20:13 EDT
Verified on build#1099

The 'System Settings' properties are saved successfully and  value of
'SSL' field does not change.

Marking as verified.
Comment 4 Corey Welton 2011-05-23 21:12:38 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:12:38 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.