This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 683966 - Attempting to enable "Debug" sends falls or confusing error messages.
Attempting to enable "Debug" sends falls or confusing error messages.
Status: CLOSED DUPLICATE of bug 682735
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.B02
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-03-10 14:39 EST by Corey Welton
Modified: 2011-10-04 15:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-24 14:39:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2011-03-10 14:39:12 EST
Description of problem:
When trying to enable debug mode in system settings, user is told that various settings need to be changed in order to enable debug.  What exactly needs to be changed, however, is not clear - and in fact NOT making any apparent changes works upon resubmit. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Install a fresh JON server
2.  Administration > Server settings
3.  Assure the following toggles are set (per default)
 *  Auto-Updates: Y
 *  Debug Mode: N
 *  Experimental Features: N
 *  Reindex Data Tables: Y
4.  Attempt to toggle debug mode to 'Yes'
5. Save
6. Noting error messages, hit Save again
7. View results.
  
Actual results:
Attempting to save the first time results in error messages for the following fields
 * Auto-Updates
 * Experimental Features
 * Reindex Data Tables

Furthermore, after getting these error messages, the following toggles have been set:

 * Auto-Updates: Y
 * Debug Mode: Y
 * Experimental Features: Y
 * Reindex Data Tables: Y

Submitting yet again then allows settings to be saved


Expected results:

* We need clarification as to "WHAT" needs to be changed and why -- if even in user docs some where.  The tool tip is basically useless.
* I don't know why it is flagging Auto-updates and Reindex Data Tables as invalid when they are already set to "Yes" and it keeps them that way -- and seems to even accept submission the second time.


Additional info:

It should be noted that similar things happen when trying to reverse this, and disable debug.  And sometimes debug can even be disabled anyway w/o changing anything. 

This page/debug stuff needs some serious love because it doesn't at all work as one might expect it to.  There may be a whole lot of separate bugs causing this aggregate behavior but it's difficult to tell them apart.
Comment 1 John Mazzitelli 2011-03-24 14:39:29 EDT

*** This bug has been marked as a duplicate of bug 682735 ***

Note You need to log in before you can comment on or make changes to this bug.